Help Wizard

Step 1


"Spotify can't play this right now. If you have the file on your computer you can import it."


"Spotify can't play this right now. If you have the file on your computer you can import it."






Samsung ion Laptop

Operating System



My Question or Issue

I recently changed my laptop so I downloaded Spotify again. When I tried to play a dong there would be a notice that says "Spotify can't play this right now. If you have the file on your computer you can import it." I tried re-installing it, re-logging in. How can I fix this problem?

31 Replies

What can I do if it didnt work? Ive tried logging in and out many times and reinstalling it 3 times.

Hi @Toby09!


Could you let us know if you're trying to play your local files or songs uploaded on Spotify? If you haven't already, check your playback device's sample rate (found in your Sound settings) and make sure it's set to anywhere from 44.1 kHz to 192 kHz. Spotify doesn't currently support a sample rate higher than 192 kHz.


In any case, a short screen recording which shows how things look on your end would be greatly appreciated. If you're unable to attach the video in your reply, you can instead upload it to a cloud service and share the link.


Keep us posted. Cheers!

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

2 years later and the bug still happens... smh ive done everything that u recommended and also on the other thread and it still happens 3everytime i try to put a song 

pls help 

I came across this error just now and after logging out and back in worked like a charm. hope this helps

I've tried all steps in this forum post. I have cleared all spotify files and did a reinstall twice and logging in and out twice. It works fine on browser player. It does not work fine for the players downloaded on my macbook and pc. There is a large portion of music which does not work, specifically a portion of my "liked music" added after a specific date. I am able to play the song on web player and transfer players to my mac, and my mac will begin playing the song it was unable to before. 

I've also tried every step from this post, but nothing seems to work. I can play on every other device, but not on the windows app itself. I can open the app en play it on another device from there, but not in the app itself. I have been able to play music up until a month ago, maybe 2. I've even tried downloading older versions, since that has been a solution on another post. But also, no luck. 


Are there any options left for me to try?

Same things. Only thing I found to work was to Unlike and Like again, but then that messes up the order of my music which was chronologically added. 

I'm a Spotify Premium subscriber and am also experiencing this issue. Like a previous commenter, it seems to only happen when I'm filtering in my "Liked Songs" by a text string (in my case, searching by two letters; makes for a fun random playlist when you've got a lot of saved songs!). My computer is running Windows 10 20H2.


Here are the steps I've tried:

  • Clearing desktop client's cache
  • Uninstalling & reinstalling app (both standalone client and Windows Store versions)
  • Logging in and out twice consecutively with no other actions taken in between

Here's some behavior I noticed regarding the issue:

  • Issue does not occur on mobile app and I'm able to transfer the session to the desktop client
  • I can double-click on the first 150 songs in the search results and they will play normally, but anything after the first 150 results gives the "Spotify can't play this right now." error message
  • I am still able to listen to the songs if I right-click them and manually add them to my play queue
  • I am able to play the same song(s) producing the error if I do not sort, but just manually scroll down to the song in my Liked Songs and play it from there

Anybody have a clue as to what's going on?

for me i get this message when i have my Controller for Djing plugged in. If i open the app without it plugged in the app works fine.

I'm having the same issue on windows 11.  i tried logging out then back in twice and the same issue persists

@tommytranttt But that's where I'm having the issue currently lol

Tried everything multiple times. Issue persists. 

Win 11, latest app version.



Suggested posts