Help - Desktop (Linux, Windows, Web Player)

The Spotify Community
Reply
Music Lover
Posts: 2
Registered: ‎2012-03-29
Accepted Solution

loading on startup

I DO NOT want Spotify to load automatically when my computer starts.  I would like to just clik on the desktop icon when I want to listen, and otherwise not have Spotify come on at all.  Can anyone help me remove it from auto loading upon turning laptop on? thanks.

Solution!
Accepted by Richard (Moderator)
‎2015-08-28 12:16 AM
Singer
Posts: 305
Registered: ‎2012-02-16

Re: loading on startup

Hi Potter!

 

Welcome to the community!

 

This is actually a fairly simple thing to do.  First, open Spotify if it is not already open.  Then, from the Edit menu at the top of Spotify, select Preferences.  Scroll down just about to the bottom of the preferences screen, and you should see something like this:

 

 

Go ahead and select the "Don't open automatically" option, and then exit Spotify.  This should prevent Spotify from opening each time you start the computer. 

 

Hope this helps!

View solution in original post

Solution!
Accepted by hpguru (Community Legend)
‎2015-08-28 12:16 AM
Concert Regular
Posts: 5
Registered: ‎2012-08-26

Re: loading on startup

I FOUND THE CULPRIT!

 

The windows server for the third-party application "Spotimote" (android app) was causing this to happen, for me.

 

To remove spotimote you actually have to boot into safe mode (run msconfig > 'boot' tab > check 'safe mode' > OK) and remove the spotimote folder located at "C:\Program Files (x86)\spotimote" or "C:\Program Files\spotimote" for x32 machines.

 

View solution in original post

Solution!
Accepted by brink1 (Concert VIP)
‎2015-08-28 12:16 AM
Concert VIP
Posts: 6
Registered: ‎2015-07-05

Re: loading on startup

I'm running Windows 7 OS and had the same issue. I solved my problem by going to the Spotify icon (Shortcut) and right click and go to the bottom were is says properties.Click on properties then click on "open file location". Find a folder that says Users.Click and open Users folder. You sould see a folder that is your username. (xxxx-user). Click and open that folder. Find the file that says "pref". Click to open and you should get a pop-up that says "choose the program you want to use to open this file". Make sure the check box on the lower left says, "always use the selected program to open this kind of file" is unchecked (It already may be greyed out).Click on WordPad and you should see: ps.publish-playlist=0 and ps.publish-activity=0. Make both a number 3 and click save. Hopefully this will help.

View solution in original post


All Replies
Solution!
Accepted by Richard (Moderator)
‎2015-08-28 12:16 AM
Singer
Posts: 305
Registered: ‎2012-02-16

Re: loading on startup

Hi Potter!

 

Welcome to the community!

 

This is actually a fairly simple thing to do.  First, open Spotify if it is not already open.  Then, from the Edit menu at the top of Spotify, select Preferences.  Scroll down just about to the bottom of the preferences screen, and you should see something like this:

 

 

Go ahead and select the "Don't open automatically" option, and then exit Spotify.  This should prevent Spotify from opening each time you start the computer. 

 

Hope this helps!

Music Lover
Posts: 2
Registered: ‎2012-03-29

Re: loading on startup

hey, thanks so much!  I actually went to edit but I didn't scroll down there, I just looked a bit and didn't see anything that would help, duh.  thank you for responding.

Music Fan
Posts: 1
Registered: ‎2012-05-30

Re: loading on startup

I totally agree with you.  Loading on startup is so obnoxious.  Adobe does this also.  And here is the problem.  Many times the wireless network is not fully initialized.  So when startup applications try to make service calls that sit there until the timeouts occur.  It makes the boot up process take forever!!!!  I am glad spotify is nice enough to allow you to disable it.  But at the same time I think it is extremely bad etiquette to do it in the first place.  Just because Windows gives you opportunity to do something on startup doesn't mean you should poop on the system.  Most people are not smart enough to figure out how disable your default.  I bet the same people who are doing this are the same ones who say the most disresptful comments against Windows platform.

 

I am surprised Microsoft doesn't provide tools to its users to lock this down and prevent it in the first place.

Music Fan
Posts: 1
Registered: ‎2012-06-02

Re: loading on startup

That looks like the answer, but it doesn't work. I'm about to uninstall Spotify for the second time because of the auto-load issue. For me, it loads whether I have that setting on or off. Maybe it happens because I've never upgraded to the pay version; could it be nag-style advertising? It would be a shame if that was the reason because I won't spend money on Spotify until I know I can stop the autoload.

Music Fan
Posts: 1
Registered: ‎2012-06-23

Re: loading on startup

I totally agree... however my PC is a Pentium 4 2.8 Ghz dinosaur and auto loading on startup lags my booting sequence up horribly... good thiing you posted this question

Music Fan
Posts: 1
Registered: ‎2012-08-12

Re: loading on startup

This does not work for me. I have the paid version of spotify (premium) and the "Don't open automatically" option ticked, but it still opens on startup... I have tried all the simple solutions (msconfig, regedit, ccleaner etc...) but nothing seems to work. A solution to this would really be appreciated. And don't give me the simple solutions, I've tried them, they don't work... Hit me with the advanced solutions! 

Concert Regular
Posts: 5
Registered: ‎2012-08-26

Re: loading on startup

[ Edited ]

Same here, premium account, setting doesn't do anything. Tried it all. We either need a dirty fix or an update, what's up spotify engineers?

Seriously, don't be scared to suggest a 'difficult' method if you have it. This feature is broken, period.

 

 

SYSTEM INFO:

 

OS Name    Microsoft Windows 7 Home Premium
Version    6.1.7601 Service Pack 1 Build 7601
Other OS Description     Not Available
OS Manufacturer    Microsoft Corporation
System Name    GEEK-PC
System Manufacturer    SAMSUNG ELECTRONICS CO., LTD.
System Model    700Z3A/700Z4A/700Z5A/700Z5B
System Type    x64-based PC
Processor    Intel(R) Core(TM) i7-2675QM CPU @ 2.20GHz, 2201 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date    Phoenix Technologies Ltd. 13FD, 3/29/2012
SMBIOS Version    2.6
Windows Directory    C:\windows
System Directory    C:\windows\system32
Boot Device    \Device\HarddiskVolume1
Locale    United States
Hardware Abstraction Layer    Version = "6.1.7601.17514"
User Name    GeeK-PC\GeeK
Time Zone    Central Daylight Time
Installed Physical Memory (RAM)    8.00 GB
Total Physical Memory    7.92 GB
Available Physical Memory    5.49 GB
Total Virtual Memory    15.8 GB
Available Virtual Memory    13.1 GB
Page File Space    7.92 GB
Page File    C:\pagefile.sys

 

Community Legend
Posts: 8,110
Registered: ‎2012-02-06
You now have 30 Android solutions.
You're awesome! 100 Desktop Solutions is a great achievement.
Wow! Three years; you're practically a veteran.
One thousand kudos. That's a ton!

Re: loading on startup

You may also be able to remove this thing by using CCleaner program.

Google Play Music Pass for music streaming, user since February 2016, with decent 1M mobile network.
Concert Regular
Posts: 5
Registered: ‎2012-08-26

Re: loading on startup

[ Edited ]

Nope, here are my startup settings in ccleaner (latest version).

 

LINK TO FULL SIZE IMAGE

 

 

Announcements

Beta Test Spotify Desktop
Would you like to beta test Spotify Desktop?

If so, please log in or register.

More

Please bear in mind that the Community is not an official Spotify support service. It's a place where we all help each other, whether we work for Spotify or not. So please use your discretion when using the forum.