How to I stop spotify from starting at system startup

Spotify has set itself up so that it executes at system startup and causes my comuter to take forever to boot. I want to fire it up when I choose, not spofify. Also, is there an uninstall feature?

Status: Implemented
0 Likes
Comments
rad_ryan
Regular

There should be an option in Preferences.


Just click "Don't Open Automatically."

 

You should be able to uninstall the program through Add/Remove Programs in Control Panel, assuming you're using Windows. In Mac, just delete Spotify in the Applications folder.

David
Spotify Legend

Hello!

 

You can stop it starting up when you turn on your computer by heading into the Preferences menu (Edit > Preferences on a Windows Machine, or Spotify > Preferences on a Mac), scrolling to the bottom of that screen and clicking next to the "Don't Open Automatically" under the "System" tab.

 

In terms of Uninstalling, the usual uninstall methods work - Add / Remove Programs for Windows, for example.

David
Spotify Legend

...rad_ryan beat me ever so slightly there! 

bradavon
Garage Band

This is the "ideas and Feedback" forum, can this be moved?

lagrandebea
Regular

I have checked the "don't open automatically box" but it still opens automatically.

I've checked my starting folder and spotify is not in it.

I don't know what to do to stop it from opening automaticaly.

 

I dont want to get rid of Spotify, just open it when I want....

Can anyone help?

Thanks

:smileymad:

Power1aj
Regular

Please follow the guide below to stop programs from running at startup.

1. Open the System Preferences of your Mac.

2. Select accounts in the lower left.

3. Click Login Items to bring up a list of all applications that run when you startup.

4. Highlight the application you want to remove and press the "-" button at the bottom of the list. Note that the application will disappear and not run on your next reboot.

christypea
Concert VIP

I was getting irritated by this as well. I had unchecked everything I could find, but it was still starting up when I logged in. I ened up having to not only uncheck Spotify under Login Items (under System Preferences -> Users & Groups on my Mac), but hit the (-) button to remove it from the list altogether. Weird.

 

Thanks for the pointer to the list of Login Items, Power1aj!

David
Spotify Legend
Status changed to: Implemented