Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


[Android] Albums won't load

Status: Not Right Now






Samsung S9

Operating System

Android 10


For aboiut 6-8 weeks, I have been getting only a black loading screen in the app, when I select an album, playlist, etc. form a conducted search. I have already tried all the basic troubleshooting steps (deleting cache, clearing data, reinstalling app, WiFi vs. cellular, etc.). Clearing data/ reinstalling app work, although only for about one day when clearing data/ reinstalling app have to be repeated.

I have attached a screen to explain what I mean by black loading screen.

Hey there folks,


Thanks for bearing with us while we were looking into this!


Keep in mind that this can happen when loading pages containing a lot of content, for example multiple chapters in audiobooks.


However, we've passed your reports to the right teams who will be continuing to improve the functionality of the app. To make sure you don't miss the latest fixes and improvements, we'd recommend keeping your devices and app up to speed with the latest updates available.


In the meanwhile, we'll be setting this Ongoing Issue as Not Right Now. We'll also keep you posted here if we have any further info to share.


Thanks again!


Hello @matze_de,


I'd suggest you to try using another device, since the device you're using now might not work quite well at the time. I've had this issue myself as well and solved it by saving up some storage on my device.

Keep us posted!


I have the problem with two different smartphones... So that won't help 😞

After deleting app cache and content and and a new login to the App all is good. But just for a short time...

Memory on the smartphone isn't a problem, for sure.

Maybe cancelling the subscription is the only possibility. Can't believe that Spotify does noe offer ANY SUPPORT AT ALL...





Clean reinstall did the trick! I was not aware that the way you deinstall the app makes a difference. Thanks!

  1. Gleiche Problem Samsung galaxy S7 (neueste Updates installiert), wenn man Alben oder playlists öffnen will nur graues Cover und es tut sich dann weiter nichts. Dann kann man auch nicht mehr in die Einstellungen der app gehen, wird nichts angezeigt. Erst nach dem Neustart der app kann man wieder in die Optionen rein. Über webplayer keine Probleme.

Every album on whatever artist won’t open it’s not that the album is new it’s all of them and it’s really annoying at times because when new ones come out I have to search for all the songs individually and sometimes I don’t know what all the songs are I can play the album fine I just can’t click on it and see what songs are on it 😞








Operating System

(iOS 13.4.1)


My Question or Issue



Hey @Elle17, thanks for reaching out to the Community!


Let's see what's going on.

Can you let me know the current iOS version you're running on your iPhone 11? You can check this by going to Settings > General > About.


Also, send me a screenshot of the issue you're encountering so I can try and see if it happens on my end as well. You can also explain the part where you're not able to click and see the album and let me know what's happening in some more detail.


Looking forward to your reply!


Hey there @matze_de!


Thanks for reaching out to us on the Community! We're sorry to hear you're having trouble with the app and we'd love to help you.


Do you experience this when using Wi-Fi, 3/4G or both?


Does this happen with normal tracks and podcasts for example or only on specific artists and audio books?


If you're using an SD card on your devices, we'd recommend checking it for errors and making sure it's formatted as external memory.


We'll be on the lookout for your update. Give us a shout if you have any further questions.




and thanks for coming back to me. Following a hint from a friend of mine I found the chat function on your website and chatted with one of your employees. She said that my "cache was **bleep**ed up" and she did something to clean this up. Afterwards I was asked to cleanly deinstall and reinstall the app.


For now it works but as I wrote - deleting the apps cache and memory helped beforce...for one day.

In spite of that of course I want to answer your questions:


> Do you experience this when using Wi-Fi, 3/4G or both?




>Does this happen with normal tracks and podcasts for example or only on specific >artists and audio books?


Every artist.


>If you're using an SD card on your devices, we'd recommend checking it for errors
>and making sure it's formatted as external memory.


No SD card (Google Pixel 3 XL)


Keeping the fingers cross for the days to come...


Kind regards from germany,



The same Problem.


Galaxy S7.


Deleting an reinstall the app solves the Problem for 1 day. Than it returns..


Thanks for the support, Crassi - good to see that I'n not alone! 🙂


Same here - although the support did "something" the problem is already back. Can't stand it anymore, honestly...