Announcements

[Android] Can't access or play podcasts in Your Library

Status: Fixed

Hey folks,

 

We're receiving reports that trying to access or play the podcasts in Your Library will return an error message. 

 

We’ve passed the available info on to the relevant team so they can look into it. In the meantime, would you mind trying the following?

  1. Updating your Android device's operating system to the latest available version (ideally, Android 10)
  2. Performing a clean reinstall of the Spotify app

 

If following the steps doesn't do the trick, it'd be great if you'd provide us with the following info, if you haven’t already:

  • Device + operating system version
  • Exact Spotify version

 

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to say that this should now be fixed for everyone! Make sure your app is updated to the latest version.

 

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks!

Comments
Barndard

I am having the same issue. Samsung Galaxy S7. Reinstalling Spotify did not work.

Mario

Hey @Barndard,

 

Thanks for reaching out about this here.

 

Would you mind confirming the following?

 

  1. The exact Spotify version you're running (you'll find it by tapping Home > Settings > About)
  2. The exact version of your Android device's operating system

 

We'll pass the info to the folks who're looking into this and update you as soon as possible.

 

Wishing you a good one in the meantime!

karenakarena

Hi, I'm using an LG G4 phone running android 6.0 and spotify 8.5.55.1105. I get 'something went wrong' when I go to library>podcasts>episodes and 'an error occured' when I go to libray>podcasts>shows>'podcast title e.g. 'no such thing as a fish'. Screenshots attached.

 

Cheers

Screenshot_2020-04-27-13-55-12.pngScreenshot_2020-04-27-13-55-17.png

buk49

It worked perfectly up until last week

 

One Plus 2 (Android 6.0.1)
Spotify 8.5.55.1105


No screenshot for me. But the error looks exactly like I see others post.

Something went wrong, try again (but in my own language).

 

Hopefully it is resolved soon

toblirone

The version I'm running is 8.5.55.1105

MiloKuroshiro

Sure, I'm using the 8.5.55.1105 and there's no updates available for me. 

Freijadb

Same problem. Version: 8.5.55.1105

Screenshot_2020-04-30-15-51-02.png

Spozbucket

I have done a software update on my samsung galaxy j3, android version 5.1.1 I can't update any more than this.

 

I have reinstalled spotify to version 8.5.55.1105 and the problem persists. 

 

Screenshot_2020-04-30-15-39-40.png

Screenshot_2020-04-30-15-47-49.png

Jmartin319

Blackberry priv

Android 6.0.1

spotify: 8.5.55.1105

UPDATE: @Mario as much as I didnt want to do it, I downloaded an old apk (version 8.5.51.941) from the website uptodown.com. The most recent one I could find, circa 3/20/20, and that version fixed everything. Podcasts library fixed!

So much for having everything up to date. Will be turning off automatic updates, thank you.

 

I think it started after the last update 4/22/20, possibly the one before (not sure what the version and release date was before the current).

Tried a clean reinstall of spotify.

 

Workaround: The only way I can get podcasts to play is if I go find it in google chrome browser on my phone, then click on the "install app" button on the redirect page that appears when you click on an episode. It will play in the app that way, but you cant search through the library (you can swipe to the previous/ next track though).

 

Additionally, the podcast library wont even let me show downloaded podcasts (tried with airplane mode on too).

Spozbucket

Today I discovered that I can play some podcasts which may be helpful for people wanting to hear new uploads. 

 

On the home page there is a "your daily podcasts" playlist. Theach podcasts in this list are working for me.