[Android] Galaxy Watch's Spotify App Causes Control Glitches in the Android Phone App

Status: Not Right Now

Plan

Premium

 

Devices

Galaxy Watch (SM-R810) & Galaxy Note 10+

Operating System

Tizen 4.0.0.7 & Android 10/OneUI 2.5

 

My Question or Issue

Having the Spotify App installed on my Galaxy watch and using it as a remote to play tracks from my phone causes a couple of strange glitches in the phone app.  

 

The "now playing" track on the phone will be stuck on the first song played in that session (or whichever track was playing when the glitch decides to happen).   This also causes issues when trying to jump to a specific time in the track, because the time slider also does not display correctly.

 

The play/pause button, while still functioning correctly, will only display the "play" graphic, regardless of if the track is playing or not.

 

Spotify's persistent notification will also remain stuck on the same track, and the skip buttons do not always continue to work after this glitch happens.

 

Lastly, this glitch, after being triggered, causes the phone to not see Spotify as the currently playing media service, so apps such as YouTube will layer their audio on top of the currently playing Spotify track.  Normally, the phone would understand that Spotify is playing and pause it, but that does not occur when the glitch is present.

 

Note: this glitch did not happen with my Gear S3 which was used with the same phone, nor did it happen with any previous Galaxy phones (S7 Edge, Note 7, Note 8).  It started happening immediately after upgrading to the Galaxy Watch from the Gear S3.  OS updates on both the watch and phone have not changed this issue.  The Spotify app has gone through multiple updates and the issue has not been resolved, nor changed in nature.

 

Force closing the app or restarting the phone will temporarily fix this, and it will normally reappear after a few tracks have played.  Might be related to changing the playlist from the watch, but haven't been able to isolate a specific action that causes it.

 

Uninstalling the app removes this glitch completely. I did not experience it at all after removing it.  Tried re-adding it a month later, and it's back.  Definitely related to the watch app.

 

Really hoping for a fix, as the experience for me is not the same without the ability to control tracks from the watch.  Might have to move to a different platform if this can't be figured out.

 

 

 

 

 

 

Hello everyone,

 

This issue has been active for some time now and we’ve decided it’s best to mark it as Not Right Now.

 

We acknowledge that at the moment the Spotify experience for some of you using this watch model is not ideal and understand the frustration this must cause. We’ve passed your feedback on to Samsung and have been working with them on this, but we cannot provide a timeline or a guaranteed outcome.

 

If there are any developments, we’ll make sure to post them here.

Comments
Ivan

Hey there @Refracted

 

Thanks for posting on the Community about this.

 

The issue you experience might be related to an Ongoing Issue that we started investigating after the latest Tizen update. Check out this thread and add your vote by clicking on the +VOTE button. Make sure you follow the steps under Status Update as well. 

 

It'll also be useful to Subscribe via the three-dots menu in the top right corner next to the title. That'll make sure you stay up to date with any relevant updates about this.

 

Hope this helps. Let us know if you have any questions. 

Refracted

Hi Ivan, appreciate your reply.

 

I don't believe these issues are related.  The thread you have linked proposes that the Galaxy Active Watch 2 is unable to open Spotify after updating to Tizen 5.5.0.1.  My watch, the original Galaxy Watch (2018), is on a completely different version of Tizen - 4.0.0.7. 

 

Additionally, the issue I'm facing is with the Android Spotify app on my phone, while theirs is related to the app on their watch.  Not to mention, my issue is regarding the fact that songs do not display correctly, and Spotify doesn't recognize the app as playing media (as mentioned in the OP), while the linked thread discusses their app not being able to open (on the watch).    Furthermore, the user in the other thread is running iOS, which means these are two completely different versions of Spotify.  My issue is with the app on my phone.  The watch app is working correctly, but is causing glitches in the phone app.  Hopefully that makes things a bit more clear.

 

In summary, these are two completely separate issues.  I am hoping this can be flagged in order for Spotify to fix this for me, as the user experience is completely dampened by this.

Alex

Hi there @Refracted,

 

Thanks for the clarification.

 

In this case we'd recommend running a clean reinstall of the app on both your phone and the watch. This involves deleting the app cache. Check out this guide for the device specific steps. 

 

If that does not help, the next step would be to do a factory reset on the watch itself. As this will assure that it's running the latest firmware. 

 

Also let us know if you're using any other Bluetooth device like wireless headphones simultaneously when this happens.

 

Cheers.

car0bean
  • Yes! Having the exact same issues with my Spotify premium account on my Samsung S20+ and the Galaxy Watch 3. Stuck on the same track for days, play button lost all meaning, phone app randomly pauses itself... This only happened after I switched to this wearable from the Gear Fit. 
Macigade

Same happens to me. Galaxy watch 1. This needs a fix urgently

Jeremy

Hey there folks,

 

Thank you for your posts in this thread.

 

Can you confirm if you followed the steps that @Alex mentioned?

 

Also - can you let us know which version of the app you have?

 

We'll keep an eye out for your replies.

 

Cheers!

car0bean

Hi there! 

Yes, I did the clean uninstall on both devices and then reinstalled the apps. At first, this resolved this issues--until the phone app was closed and reopened again. Then the play status was frozen (not accurately indicating whether music/podcast was playing or not) and the "current" track displayed was the last track played while connected to the watch, regardless of what was actually playing on the phone. Forcing stop resolves it, but only temporarily; the problems resume once the watch connects to the app. I'm using version 8.5.86.854 on the phone and 2.5.39 on the watch. 

Jeremy

Hey there again @car0bean,

 

Thank you for your reply and confirmation.

 

If you have an SD card we suggest that you uninstall the app > turn off your phone > take out your SD card > turn on the phone again (without the SD card) > reinstall the app.

 

Keep us posted.

 

Cheers!

polpogs

Jeez, im having the same exact issue.

I just just got my watch 3 like 7 hours ago.

I dont think factory resetting this brand new watch will permanently resolve the issue.

**sad**

CarlosE

Hey there @polpogs,

 

Thanks for reaching out about this here in the Community!

 

Just to make sure, did you already follow the steps @Alex and @Jeremy suggested above?

 

If none of those worked, could you let us know if that happens while having any other Bluetooth devices connected to your phone, like wireless headphones or speakers?

 

We'd also like to know the Spotify version you're running on your devices.

 

Keep us posted. We'll be looking out for your reply.