Announcements

[Android] Galaxy Watch's Spotify App Causes Control Glitches in the Android Phone App

Plan

Premium

 

Devices

Galaxy Watch (SM-R810) & Galaxy Note 10+

Operating System

Tizen 4.0.0.7 & Android 10/OneUI 2.5

 

My Question or Issue

Having the Spotify App installed on my Galaxy watch and using it as a remote to play tracks from my phone causes a couple of strange glitches in the phone app.  

 

The "now playing" track on the phone will be stuck on the first song played in that session (or whichever track was playing when the glitch decides to happen).   This also causes issues when trying to jump to a specific time in the track, because the time slider also does not display correctly.

 

The play/pause button, while still functioning correctly, will only display the "play" graphic, regardless of if the track is playing or not.

 

Spotify's persistent notification will also remain stuck on the same track, and the skip buttons do not always continue to work after this glitch happens.

 

Lastly, this glitch, after being triggered, causes the phone to not see Spotify as the currently playing media service, so apps such as YouTube will layer their audio on top of the currently playing Spotify track.  Normally, the phone would understand that Spotify is playing and pause it, but that does not occur when the glitch is present.

 

Note: this glitch did not happen with my Gear S3 which was used with the same phone, nor did it happen with any previous Galaxy phones (S7 Edge, Note 7, Note 8).  It started happening immediately after upgrading to the Galaxy Watch from the Gear S3.  OS updates on both the watch and phone have not changed this issue.  The Spotify app has gone through multiple updates and the issue has not been resolved, nor changed in nature.

 

Force closing the app or restarting the phone will temporarily fix this, and it will normally reappear after a few tracks have played.  Might be related to changing the playlist from the watch, but haven't been able to isolate a specific action that causes it.

 

Uninstalling the app removes this glitch completely. I did not experience it at all after removing it.  Tried re-adding it a month later, and it's back.  Definitely related to the watch app.

 

Really hoping for a fix, as the experience for me is not the same without the ability to control tracks from the watch.  Might have to move to a different platform if this can't be figured out.

 

 

 

 

 

 

Hey there folks,

 

We really appreciate you sharing your info, we've passed them on with the right teams to look into.

 

If you're also having troubles with the Android app on your device when using your watch, make sure to add your +VOTE to this thread and leave the following details in a comment:

  • Device + OS version
  • Exact Spotify version
  • Tizen version and app version on the watch
  • Is the behavior always the same?
  • Can you recreate it with ease, or is it random?
  • Troubleshooting steps you've tried so far and their results
  • Does the issue occur when connecting to another device via Bluetooth?
  • Any screenrecordings of the issue would be also super helpful - just make sure that there's no private/sensitive info displayed.
We'll keep you updated here. Thanks!
Comments
Redderz
Visitor

• Device + OS version
Samsung S20 5G, Android 10

 

• Exact Spotify version
8.5.96.936

 

• Tizen version and app version on the watch
5.5.0.1

• Is the behavior always the same?
Yes, at random times spotify will pause audio.
At random times, the 'now playing' will show the wrong information, it'll be a song that was previously playing then it gets stuck on that song. The play/pause button does not work.
Media information of what song is playing and audio controls do not appear in the menu from the top of the screen when the issue is happening.
Doesn't seem to matter if I'm using my phone or my watch to control the music, and this problem persists whether I connect to a Bluetooth speaker or Bluetooth ear buds.
Issue happens whether using wi-fi or phone data.

 

• Can you recreate it with ease, or is it random?
Seems to be random.

 

• Troubleshooting steps you've tried so far and their results
I have tried signing out of all devices, uninstalling then reinstalling the spotify app on my phone and my watch, with no result.

 

• Does the issue occur when connecting to another device via Bluetooth?
Yes.

dah81
Newbie

Exact same issue as op.

 

Samsung Galaxy S10 Android 11 OneUI 3.0

Samsung Galaxy Watch 3 Tizen 5.5.0.1

 

Spotify phone version 8.5.96.936

Spotify watch version 2.5.39

 

I have multiple devices in my home connected to my Spotify premium account, not sure if it's confusing the Spotify account.

 

Phone, Windows laptop, Android Auto, smart tv and soundbar, multiple Google home devices, smart watch, etc.

 

The issues only seem to happen on my phone, and only when another device is playing.

 

So, for example, if my Google home is playing, my phone won't show it and I can't control it from my phone and my phone's "now playing" will be "stuck" the way the op described with my watch stuck the same way. Even when controlling from my phone, the now playing stays stuck on my phone and watch.

Screen recording of the issue. Notice the now playing at the bottom won't change even though I'm changing the song that's playing:

https://photos.app.goo.gl/jNkMGueF9aDisVQq6

girlssinging
Newbie

Thanks for setting out this problem in so much detail.  Exactly same things happening to me.  Spotify, please FIX.  Similar setup except for SM-R800, Android 9 and S9Plus.

Skylinegodzilla
Casual Listener

Samsung S8 Android

Galaxy watch: SM-R800

Tizen:4.0.0.7

Spotify: 8.5.96.936

 

I believe that this is the same issue that I've been having for a few years now.

 

When I listen to spotify on my phone it will sometimes keep playing on my phone after I turn off the bluetooth device (head phones or car stereo)

 

But more frustratingly it will screw up my controls for example when the glitch happens the now playing bar will be stuck display the playlist it was playing when the glitch happened. So if I switch to a different play list or a podcast the ui will be stuck. 

This is very frustrating because if i miss something that some one said in the podcast then there's no way to rewind a few seconds backwards and forget using the slider as like I said the ui gets stuck on what ever was playing at the time. So if it glitches on a song then I lision to a pod cast I can only scrub through the first 4 minutes(or however long the song is) of the podcast.

 

I have tried reinstalling everything, spotify on my phone and watch, doing a factory reset of my phone. Nothing. 

 

One thing I have notice this issue does not resolve it self when I close the app but when I close the app and then turn off bluetooth it fixes it until it glitches again.

 

Dickieblues
Visitor

Having the same issue - definitely something to do with using galaxy watch as a remote. Now playing stuck on wrong song - very strange.

 

Device + OS version : (PHONE) SM-F707B + Android 11

Exact Spotify version: 8.5.98.984

Tizen version and app version on the watch: (WATCH) SM-R820 / 5.5.0.1 + (SPOTIFY) 2.5.39

Is the behavior always the same? Y, after using watch as remote for Spotify on phone.

Can you recreate it with ease, or is it random? Y, happens every time short while after using watch app as remote.

Troubleshooting steps you've tried so far and their results

All advice tried (clean reinstall / reset blah blah blah...)

Does the issue occur when connecting to another device via Bluetooth?

Just to watch - have buds+ as well but don't think this is part of it?

Etkini
Newbie

Here's a solution to anyone having these problems - don't use the Spotify app on your watch, use the regular music one instead. You'll have all the same control features, without the annoying issues.

 

My girlfriend and I just upgraded to S21 Ultras and got Galaxy Watch 3s a couple days ago and were having these same exact issues with the Spotify app. After seeing how unhelpful the canned responses everyone has gotten here were, I decided to close all my apps and try the music app that comes on the watch. It works exactly as it should displaying the song name and artist as well as the picture that's on the Spotify phone app. I can skip, go back, adjust volume, etc. It also works with any other streaming service I've tried.

Make sure you close all the open apps on both your phone and your watch, or even restart them before trying this. If the Spotify app is open on your watch it will not work.

Ixnunc
Newbie

@Etkini, your suggestion worked perfectly, I'm uninstalling the spotify app from my watch and using the music app exclusively going forward. Thanks for the tip, and for anybody reading this, do what he suggested, it actually works

FwustratedUser
Visitor

Issue persists. Same story as everyone else; same frustration with paying a premium for partially-functioning services.

Uninstalled the watch app to no avail. Cleared cache to no avail. Clearing data finally did the trick.

alvsc
Newbie

It's been 4 months, you can develop a new app in that timeframe. This is NOT getting fixed, Spotify left Samsung Tizen development stagnant. As suggested I would just uninstall the Spotify Watch App and use the default Music player.

 

I am so disappointed in you Spotify, get your act together, hire some devs, move this issue to the top of your backlog.

sh1234
Newbie

after months of having these issues i found this solution from Samsung and it worked for me - it says to ensure the spotify app will not go to sleep

 

https://www.samsung.com/us/support/troubleshooting/TSG01200668/