Announcements

[Android] Galaxy Watch's Spotify App Causes Control Glitches in the Android Phone App

Plan

Premium

 

Devices

Galaxy Watch (SM-R810) & Galaxy Note 10+

Operating System

Tizen 4.0.0.7 & Android 10/OneUI 2.5

 

My Question or Issue

Having the Spotify App installed on my Galaxy watch and using it as a remote to play tracks from my phone causes a couple of strange glitches in the phone app.  

 

The "now playing" track on the phone will be stuck on the first song played in that session (or whichever track was playing when the glitch decides to happen).   This also causes issues when trying to jump to a specific time in the track, because the time slider also does not display correctly.

 

The play/pause button, while still functioning correctly, will only display the "play" graphic, regardless of if the track is playing or not.

 

Spotify's persistent notification will also remain stuck on the same track, and the skip buttons do not always continue to work after this glitch happens.

 

Lastly, this glitch, after being triggered, causes the phone to not see Spotify as the currently playing media service, so apps such as YouTube will layer their audio on top of the currently playing Spotify track.  Normally, the phone would understand that Spotify is playing and pause it, but that does not occur when the glitch is present.

 

Note: this glitch did not happen with my Gear S3 which was used with the same phone, nor did it happen with any previous Galaxy phones (S7 Edge, Note 7, Note 8).  It started happening immediately after upgrading to the Galaxy Watch from the Gear S3.  OS updates on both the watch and phone have not changed this issue.  The Spotify app has gone through multiple updates and the issue has not been resolved, nor changed in nature.

 

Force closing the app or restarting the phone will temporarily fix this, and it will normally reappear after a few tracks have played.  Might be related to changing the playlist from the watch, but haven't been able to isolate a specific action that causes it.

 

Uninstalling the app removes this glitch completely. I did not experience it at all after removing it.  Tried re-adding it a month later, and it's back.  Definitely related to the watch app.

 

Really hoping for a fix, as the experience for me is not the same without the ability to control tracks from the watch.  Might have to move to a different platform if this can't be figured out.

 

 

 

 

 

 

Hey there folks,

 

We really appreciate you sharing your info, we've passed them on with the right teams to look into.

 

If you're also having troubles with the Android app on your device when using your watch, make sure to add your +VOTE to this thread and leave the following details in a comment:

  • Device + OS version
  • Exact Spotify version
  • Tizen version and app version on the watch
  • Is the behavior always the same?
  • Can you recreate it with ease, or is it random?
  • Troubleshooting steps you've tried so far and their results
  • Does the issue occur when connecting to another device via Bluetooth?
  • Any screenrecordings of the issue would be also super helpful - just make sure that there's no private/sensitive info displayed.
We'll keep you updated here. Thanks!
Comments
Zawis
Newbie

Edit:

Issue appeared again just a second ago (it worked for a few hours though), so I give up lol. You can try to do what I have said below and I will update this comment tomorrow to say if the issue appears yet again in the morning or not. I still think the solution is to prevent Spotify app from spacing out or getting optimised, it would make the most sense.

 

~~~~~~~~

 

Going from what the most resent comment has said. That's not enough (at least it wasn't for me) since the phone will still stop running/ optimise Spotify when you're not using it (yes I have disabled optimization for the app as well as the plug in).

 

What you do have to do is lock the app and prevent android from wiping it out of your RAM at all times. This has has fixed the issue for me.

 

If an app goes to sleep or gets wiped out of RAM it simply isn't there for the watch to connect to. The glitch happens because the watch tries to connect to something that simply doesn't exist (a killed app or a hibernating app). And when it does it has jumbled up data. Similar issue happens to Spotify while using AutoAndroid (connecting your phone to your car). If you turn your phone off, Spotify gets put to sleep and AutoAndroid stops playing music.

 

For non tech people think about it this way: your brain is your control centre. You need a connection to it to walk. If the cord gets broken your brain cannot control your legs. How do you expect to walk when there's nothing controlling your legs? Same happens with Spotify on the watch and phone.

 

To fix this issue go to your recent apps (all apps running in the background) while Spotify is still running. Tap the Spotify logo or 3 dots depending on android device above the app card a small menu should pop up (screenshot provided). At the bottom of the menu you will have an option to lock the app or keep open. Tap it and a padlock should appear. This way when you clear your recent apps Spotify will remain open. It will remain in your phones RAM and constantly run meaning it won't clear the apps data when you aren't using it, it will be already running ready for the watch to send over its data. 

 

Screenshot_20210225-161639_One UI Home.jpg

 

This should fix the issue and I hope this makes sense. I've had a chat with someone who knows more about computing than me (I'm still learning) and that's what they have suggested which makes sense.

alvsc
Newbie

@Zawis

That is considered a bandaid fix.

Think of it from an end user's standpoint, you're basically making an excuse for a poor design and expect the user to configure their phone to have the Spotify app constantly run in the background? Just so to prevent the watch app & Spotify app to not bug out?

You gave an example of android auto, which is a great analogy but the difference here is android auto does not need to be constantly running in the background, the moment you unplug and that connection is lost it doesn't work but when you plug it back in it works perfectly again. The complaint here is not that the Spotify App does not work when Spotify is not running on the phone, the complaint is when that connection reestablishes, the Spotify watch and phone app bugs out and the music that is playing is not reflective of what is happening on the screen.

 

The Tizen music app works well, but lacks the Spotify features such as playlists. When you do not have Spotify open the Tizen music app does not work (which is fine), but when spotify is reopened the Tizen music app nor is the Spotify phone app frozen.

 

It's very apparent there is a bug/multiple bugs in their Spotify Watch app, and end users are now resorting to use the Tizen music app to control Spotify.

Zawis
Newbie

@alvsc 

 

Oh yeah I totally know that it's a bandaid fix. It's better than nothing though. Spotify should have some sort of safe switch that prevent the watch up communicating with the phone app as soon as it recognises the app is killed to prevent bugs like this. 

 

The AutoAndroid thing, I mean the Spotify app. As in its also a Spotify problem not AutoAndroid. Which I would say says a lot lol. I don't use it but when I talked with someone that does Spotify would stop playing a few minutes after they closed their case (the ones that turn your phone off automatically). The cable still connected and all but after a few minutes Spotify just stops. That's because the two apps loose connection when the Spotify app gets put to sleep.

 

What I have said is a temporarily fix (just like a Tizen music app) until they have a pernament solution, especially since there is a literal setting in the app designed for connections between devices so the app keeps running and allows for communication in the background. I definitely wasn't trying to defend spotify, just try to make Spotify usable so people who use the album feature often and prefer the Spotify app ove the Tizen music app, can continue using it until fixed but it seems the issue persisted in the end anyways haha. 

 

But yeah either way Spotify always has to run in the background for there to be a connection. You can't connect to something that isn't on (similar analogy to a computer that is set up to detect a specific button press on your keyboard to turn on or whatever setting you set up other than the physical power button, bios still has to run and keep waiting for a signal) but they should optimise it and fix the setting in the app itself that does just that but most definitely in a waay more optimised manner (only essential communication tools). I know that my example is very inefficient especially for devices with less RAM and smaller batteries. 

 

Sorry if it came of otherwise.

Rudo2
Visitor

I'm on a Galaxy S20 and a Active 2 wearable... Exactly the same happened to me and it's a huge frustration.. The issue can be resolved if spotify is uninstalled from the wearable but it defeats the purpose because I bought the watch to be able to control my music...

 

The watch is stuck on 1 track and the audio will change when you hit skip but the screen won't refresh and you have no control of the time frame of the song. 

 

Please resolve this issue. 

Natalie_osw
Newbie

I also cannot play music on my Galaxy watch 3. After I log in the message  “you are now streaming on your watch. Listen to music over Wi-Fi even without your phone” appears and then nothing happens.

iPhone 6, iOS 12.5.1, Spotify version: 8.6.4.1247, tizen version: 5.5.0.1

mbze430
Casual Listener

I am having the exact problem with my Galaxy Watch 3.  When my Watch 3 is connected to the phone this issue comes up.  Where Spotify plays a song, after the first song is done the phone's Spotify screen is frozen but it continues to play.  More importantly the biggest issue is that the control is completely out of sync.  If I put my Samsung Buds Pro into the mix they can't pause the music.  but double taps works.

 

 

Spotify Version 8.6.4.971

Samsung Galaxy S21+ UI3.1 (Android 11) 

Samsung Galaxy Watch 3 Tizen 5.5.0.1

LateForDinner
Newbie
  • Device + OS version - Note10+ - Android 11
  • Exact Spotify version - 8.6.2.774
  • Tizen version and app version on the watch - 5.5.0.1  -- 2.5.39
  • Is the behavior always the same? Yes. 
  • Can you recreate it with ease, or is it random? Random, but happens daily.
  • Troubleshooting steps you've tried so far and their results -- Force Stop the Spotify App on the Phone temp fixes it. Disconnecting the watch does not fix it. 
  • Does the issue occur when connecting to another device via Bluetooth? Happens when the watch is only connected as well as when other devices are connected.
  • Any screenrecordings of the issue would be also super helpful - just make sure that there's no private/sensitive info displayed.
NYCDAVID
Casual Listener

Same issue here.  Galaxy watch Active 2, Tizen 5.5.02 and Galaxy S20+ with Android 11.  For me, not only did the "Now Playing" track stay stuck on the 1st track played, but my controls from the notification area and lock screen went away, and my Galaxy Buds+ could no longer pause or skip tracks.  All other audio apps (audiobook player, Pandora) were fine.  I set the Spotify watch app back to Standalone mode, cleared the cache, and restarted the phone and everything worked as before.  I'd really like to be able to control Spotify from BOTH the watch and phone. 

HalsiCat83
Newbie

This issue is a biggie... It's draining my watch and phone batter in addition to all of the same issues expressed by other users on this thread. What is being done to correct this? As consumers, WE PAY a very hefty amount of money for these services and devices. If other streaming music platforms... such as Pandora... can make the seamless connection between watch and phone and other devices... Why can't Spotify? PLEASE GET IT TOGETHER. 

 

  • Device + OS version: Samsung Note8 - Android Version 9
  • Exact Spotify version: 8.6.8.1094
  • Tizen version and app version on the watch: Galaxy Watch3 - Tizen: 5.5.0.1; Spotify: 2.5.39
  • Is the behavior always the same? YES - gets "stuck" on a track... cannot use app on phone or watch. 
  • Can you recreate it with ease, or is it random? Easily recreated. Happens within a short time of resetting.
  • Troubleshooting steps you've tried so far and their results: uninstall/reinstall of app on watch, happens after a few songs. Nothing fixes it. 
  • Does the issue occur when connecting to another device via Bluetooth? yes... Happens when I get in to my car as well. Spotify gets stuck on a track. 
  • Any screenrecordings of the issue would be also super helpful - just make sure that there's no private/sensitive info displayed. - Too many to share. 
harryjones589
Newbie
  • Samsung Galaxy S21 Ultra - Android 11
  • Spotify Version: 8.6.8.1094
  • Galaxy Watch 3 (SM-R840) Tizen Version: 5.5.0.2
  • Behaviour:
    While I've always got my watch connected to my phone, I don't use it as a remote for Spotify unlike some other comments.
    I've experienced many issues with the Spotify app lately:
    • "Spotify is trying to play..." notifications while it's playing, meaning I have no control over my music if using it connected to Bluetooth in the car.
    • Songs playing normally, but the app showing it's the same song playing for hours
    • Songs showing as paused, but music is playing normally
    • Pressing play and getting a completely different song to what's showing, as well as it being what seems like a completely different queue. When this happens can only skip back a few songs and forward a few songs before it stops.
  • Recreation of the issue:
    For the most part it's seemingly random, but seems to happen when I've got my music downloaded.
  • Troubleshooting steps so far (pretty much in order)
    • Force stop the app - Works for a while
    • Cleared data & cache - Works for a while
    • Cleared data & cache, uninstalled, powered phone off for a few minutes, reinstalled - Works for a while
    • Uninstalled Spotify app on Galaxy Watch
    • The last issue above happened today - I deleted downloaded songs, closed the app in multi-tasking & started again which worked though closing normally in multi-tasking doesn't rectify these issues from my experience.
    • This is something else that came out of the last issue - Samsung are known for killing off apps to save battery, so I've added Spotify as a "Never sleeping app" to see if this solves any of the issues I'm seeing.
  • Does the issue occur when connecting to another device via Bluetooth?
    It doesn't exclusively happen when connecting to Bluetooth, the last issue in the list happened earlier when it wasn't connected to anything Bluetooth, I was away from my watch as it was on charge.
    One issue I have noted when connected to my car Bluetooth is since I've had my watch, if I get a notification on the watch, it makes the music stop for a split second but there's no hard and fast rule to this, it doesn't always happen. In the Galaxy Wearable app I've got it set to mute my phone when the watch is connected & my watch is always set to vibrate, so this shouldn't be happing - though this could be a Samsung side issue.
  • Screen Recordings (Listed issues 3 & 4):
    https://drive.google.com/file/d/1Lzlazd3bu5Jo8yVlw-98aQzFzgZbIHos/view?usp=sharing
    https://drive.google.com/file/d/1H3P3VzHUn3uZrM3amc_wl_F9lc27VnhY/view?usp=sharing
  • Screenshot (Listed issue 2):
    https://drive.google.com/file/d/151x1VJAAccfFbt2IsUlLXlfyyU6tNKW_/view?usp=sharing
    The screenshot above doesn't show the whole time this happened before I force closed the app, but this can be seen on my last.fm screenshot: https://drive.google.com/file/d/1oJEl1k2z2E2N0PubuWu3A1KIFiKy-iTp/view?usp=sharing
    https://drive.google.com/file/d/1sRNjbAI_Va80sGE5NBCUzRyJO2_-m_lS/view?usp=sharing

I hope some of this information can help provide users with a resolution to this issue

Thank you,

Harry