Announcements

Having trouble seeing your Wrapped stories? To fix this, update the Spotify app to the latest version.

Find more info on our community FAQ.

[Android] I play a song but no music can be heard

Status: Fixed

Good morning. I have a premium account. And today when I wanted to listen to a song I clicked on it, waited and no music came out but the song in the bar was still running. So I clicked on another song and the same thing happened. So I sped the song up and music could be heard. But when I tried speeding it up again you couldn't hear it. This is all in my phone, I'm not using bluetooth sprakers or anything. I really don't know what's wrong. It worked fine yesterday and I didn't change the settings between yesterday and today. Also I tried restarting my phone. And deleting the app and reinstalling it again but nothing! Please help I would like to fix this since it is quite troublesome.

 

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.

 

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks!

Comments
HNishida01
I tried that, but it didn't work.
joshr230

My music keeps stopping. I have it casting to my Google home speakers. It stops playing music without any message only to find out my phone is the device that it switched to. I have not done any troubleshooting since this is a new device and that won't apply. It has happened on my old device and done plenty of troubleshooting then with my network and speakers in casting to

Kidoe

Hi, i had a similar issue as described in this topic which i posted here:

 

Right now it seems i was able to solve the issue by deleting and reinstalling the app, by follwing the exact steps linked in the pinned status update. This included deleting the file com.spotify.music from my external SD card where i stored downloaded/offline music from Spotify. 

 

Current Spotify Verison: 8.5.89.901
Device: Huawei P10 / Modell-Nr. VTR-L09 / EMUI 9.1.0
OS: Android 9 (Pie)
I am using a SD card.
The issue happend with all audio, no matter if I used online or offline mode and with both WiFi and mobile data.

Mariana3091

 

versión de spotify: 8.5.96.936

marca: moto E4 plus, android 7.1.1

son con todas las canciones y podcast

sucede tanto en linea como fuera de linea

también sucede con WiFi y con datos móviles

los pasos: reinicio, desinstalación fácil y con la de más limpieza, configuración etc. y sigue igual

Marinádka

Hi,

this  happens to me sometimes and i will always solve it by restarting the Spotify app.

jmuellerbonn

Hi,

Exact Spotify version: 8.5.98.984

Device (make + model) + OS version: Fairphone 3, Android 10

Does it happen with specific songs only or randomly? No song is playable

Does this happen in online or offline mode? Both

Is it happening on WiFi or mobile data or both? Both

Troubleshooting steps you've tried so far: Clearing Cahe, Reinstall, Reboot phone, Changing WiFi

i do have a screen record of the strange beahviour, but here in the comments it is not allwoed to upload videos?

Ivan

Hey @jmuellerbonn

 

Thanks for providing us with the requested info. We've passed it on to the right folks.   

 

You can upload a video with your comment by using the Insert video option located above the comment editor. The icon looks like this:

 

Ivan_0-1612950267923.png

 

Try uploading the video recording you've made and let us know if it doesn't work. 

 

Thanks! 

Peter

Hey @jmuellerbonn,

 

Just as a follow-up to @Ivan's question, would you mind also letting us know if you have any devices connected (either via Bluetooth or Connect) when this issue occurs?

 

Once we have that info and the screen recording, we'll pass it on to the team investigating this.

 

Cheers!

jmuellerbonn

Hello all,
no, I have tried both with Bluetooth connections and without, with Headphones plugged in and without, the problem still persists.


I also have an Android tablet (Samsung) that runs Spotify with the same account without any problems. It also works perfectly on my laptop.

 

Video upload: when I click the above button, I can only insert a Youtube link... can I upload the video in another way?

jmuellerbonn

hi all,

 

thanks for the quick responses!

By the way, I was able to upload the video in another thread:

https://community.spotify.com/t5/Android/Playback-not-playing-time-not-running/m-p/5150193#M173840

Maybe that helps.

Thx.

Jörg