Announcements

[Android] I play a song but no music can be heard

Good morning. I have a premium account. And today when I wanted to listen to a song I clicked on it, waited and no music came out but the song in the bar was still running. So I clicked on another song and the same thing happened. So I sped the song up and music could be heard. But when I tried speeding it up again you couldn't hear it. This is all in my phone, I'm not using bluetooth sprakers or anything. I really don't know what's wrong. It worked fine yesterday and I didn't change the settings between yesterday and today. Also I tried restarting my phone. And deleting the app and reinstalling it again but nothing! Please help I would like to fix this since it is quite troublesome.

 

Hey everyone,

 

Thanks for your reports so far. We’ve passed your info on to the relevant team, who are currently looking into it.

 

If you're experiencing this, we'd first recommend going through the following steps:

  • Clearing the cache in the app Settings 
  • Making sure you have a good internet connection (try a different one if possible)
  • Deleting and reinstalling the app (use the exact steps here)
  • Rebooting your phone (turning it off and back on again after the reinstall)
  • Making sure that you're running the latest firmware on your device
  • Checking your available storage and clearing up space on your device (here are some tips)
  • Checking your SD Card for errors (try moving the data to your device's internal memory and remove the SD card)

In case the issue persists, let us know by adding your +VOTE and the following details in a comment below:

  • Exact Spotify version
  • Device (make + model) + OS version
  • Time & date the issue last happened (include timezone)
  • Are you using a SD Card?
  • Does it happen with specific songs only or randomly?
  • Does this happen in online or offline mode?
  • Is it happening on WiFi or mobile data or both?
  • Troubleshooting steps you've tried so far

It'd also be great if you could share a screen recording so that our tech folks can see what's happening on your end and get to the bottom of this.

 

Thanks again! We'll keep you up to speed here, so make sure to subscribe to this thread.

Comments
Visitor

I have tried all the normal things like clearing cache, uninstalling reinstalling, restarting phone, playing with the crossfade and the app sounds and nothing has worked the odd thing is the issue doesn't appear if the change of music is auto 

Newbie

Songs doesn't sound. When I play it there is no sound at all but the time continues normally. If II move the slide of the song's time, it sounds like normal. So I need to play the song, forward half of it and then going to the second five so I can actually heard it. 

This doesn't happen when I leave Spotify alone and it changes it automatically, just when I play it manually or I press the "next" button.

Plan

Premium

Country

México

 

Moderator
Moderator
Status changed to: Need more info

Hey folks,

 

We're seeing reports that there’s no audio when picking songs to play in the Android app, so we’ve merged a few threads together to look into this and keep you all in the loop.

 

If you're experiencing this, we'd first recommend going through the following steps:

  • Clearing the cache in the app Settings icon_settings.png
  • Making sure you have a good internet connection
  • Deleting and reinstalling the app (use the exact steps here)
  • Rebooting your phone (turning it off and back on again after the reinstall)
  • Making sure that you're running the latest firmware on your device
  • Checking your available storage and clearing up space on your device (here are some tips)
  • Checking your SD Card for errors (try moving the data to your device's internal memory and remove the SD card)

In case the issue persists, let us know by adding your +VOTE and the following details in a comment below:

  • Exact Spotify version
  • Device (make + model) + OS version
  • Does it happen with specific songs only or randomly?
  • Does this happen in online or offline mode?
  • Is it happening on WiFi or mobile data or both?
  • Troubleshooting steps you've tried so far

It'd also be great if you could share a screen recording so that our tech folks can see what's happening on your end and get to the bottom of this.

 

Once we have all the info, we will pass it on to the relevant team, who will look further into it.

 

Thanks! We'll be keeping an eye out for your replies.

Visitor

My spotify version is 8.5.71.723

My phone is a Vodafone N9 Lite
OS 8.1.0

the issue only occurs when i manually change to the next song every second song will play with no sound however i have noticed that this issue does not appear if the song change is automatic.  the issue occurs online and offline as well as data and WiFi. 
As for troubleshooting I have done utterly everything and the issue is still there the only thing that "fixes" it is by tapping the song again doing that resets the song so it play's with sound however i can't do that with playlist radio
       

Newbie

Complementing my last comment:

 

Device - Huawuei Y5 2018 with Android 8.1.0

Spotify version - 8.5.70.868 (the last one avaiable for me in the playstore)

 

The problem happens with every second song I select (from the list or with the "next" button) or every second time I choose the time in the progression bar.

 

It happens online and offline, data or Wi-Fi.

 

I've tried all of the steps you wrote in the last comment.

 

Newbie

Version 8.5.71.723

Android 6.0.1

Have tried every step on the list, nothing works.

This problem for me was synonymous with the newest update.

I had to plug in an empty SD just to convince the app to reinstall despite having over 3GB of internal memory where the app had previously sat for 2 years without problems until this week. 

This isn't a temperamental issue that varies depending on connection, settings, storage or data, it bluntly and simply isn't working properly and no amendment is changing this, it's every second song every time.

It might be of interest to note my headphones have control buttons on them - if I press pause and then press play on a silent track the song will restart, still in silence. Said track will still play silently whether the headphones are plugged in or not.

Moderator
Moderator
Status changed to: Under investigation

Hey everyone,

 

Thanks for your reports so far. We’ve passed your info on to the relevant team, who are currently looking into it.

 

If you're experiencing this, we'd first recommend going through the following steps:

  • Clearing the cache in the app Settings 
  • Making sure you have a good internet connection (try a different one if possible)
  • Deleting and reinstalling the app (use the exact steps here)
  • Rebooting your phone (turning it off and back on again after the reinstall)
  • Making sure that you're running the latest firmware on your device
  • Checking your available storage and clearing up space on your device (here are some tips)
  • Checking your SD Card for errors (try moving the data to your device's internal memory and remove the SD card)

In case the issue persists, let us know by adding your +VOTE and the following details in a comment below:

  • Exact Spotify version
  • Device (make + model) + OS version
  • Time & date the issue last happened (include timezone)
  • Are you using a SD Card?
  • Does it happen with specific songs only or randomly?
  • Does this happen in online or offline mode?
  • Is it happening on WiFi or mobile data or both?
  • Troubleshooting steps you've tried so far

It'd also be great if you could share a screen recording so that our tech folks can see what's happening on your end and get to the bottom of this.

 

Thanks again! We'll keep you up to speed here, so make sure to subscribe to this thread.

Moderator
Moderator

Thanks for sharing your details @-bcz4q_46v6k4 , @kokolatoso1 and @IcewaterPhoenix !

 

If you're still experiencing this issue, it'd be great if you could give us a rough time stamp and date when this happened, so our developers can have a look at the logs and see what's going on.

 

We'd really appreciate your help with this 🙂

Visitor

Plan

Premium

Country

Brazil

Device

(Samsung J410G)

Operating System

(Android 8.1.0)

 

My Question or Issue

So recently my spotify on  my smatphone has a problem very strange. I put on song to play and works fine so when the next song start (can be naturely on the first sonf finish, click on the next button, repeat the same song or advance the song) the song doest'n give me any sound, but for the next works fine, basicaly the song my spotify just works 1 ok - 1 - not 1 - ok 1 - not and it's very annoing.

 

I already try , reestart my phone , unistal and instal again (clearing my cache). My account works fine in another device (my computer). Can someone have a clue to what to fiz? Sorry for my english, seconde language :P. Thanks for advance.

PS: I'll try the spotify lite now.

Visitor

Plan

Free/Premium

Country canada

 

Device

(iPhone 8, Samsung Galaxy 9, Macbook Pro late 2016)

Operating System

(iOS 10, Android Oreo, Windows 10,etc.)

 

My Question or Issue

When i play the first music i can hear it fine but when the second one start i can't hear it until i reset the time bar. i am on a phone i think