[Android] Songs randomly stop playing

Thread: 380716

Status: Unresolved

Description:

When listening to music in either on- or offline mode, Spotify will stop playing after 1-2 songs.

 

Additional information:

When replying please make sure to read [Android] Troubleshooting Spotify and provide as much information and detail as possible.

 

--

 

When posting in this forum please make sure you have read these guidelines.

Hey folks, this should be fixed for you all. If you're having any further trouble with your Andoid please post in the Help boards. Thanks!

Status: Fixed
0 Likes
Comments
Newbie

I corrected the bug deleting Clean master. Hope that helps.

 

Casual Listener

I've just started getting this problem, and it's frequent and ubiquitous.

 

Android phone, latest version: It will randomly stop playing, usually within a few minutes after playing. I'm currently testing it on offline mode and I haven't been able to confirm if it stops randomly.

 

Mac client: It will randomly stop playing, usually within a few minutes after I start playing.

 

Sonos system: The system will quite regularly report having lost the stream from Spotify, stopping the song and moving on to the next one in my queue. This repeats. Every single song gets about a minute in and stops.

 

This only started yesterday morning (January 21st) when my Sonos alarm went off and started playing a Spotify playlist (6AM PST). It started doing this break-in-middle-of-song-go-forward routine. I went to work and throughout the day was unable to listen to my work playlist on my Mac. This morning my wake-up playlist did the same routine. I tried to listen to my (offline stored!) playlist off my Android phone while driving in the car this morning and it would not continuously play.

 

I've integrated your product thoroughly into my life, please fix!!! 😞

Casual Listener

Oh, I should also mention: aside from Sonos reporting the stream was broken, I'm getting NO error messages or notifications from the clients. It's as if the pause button was pressed.

Casual Listener

Update: native clients seem to be working. Sonos was not working at all on Friday and Saturday, and now this morning it's back to starting to play and then partway through saying the "connection to Spotify was lost".

 

Screen Shot 2015-01-25 at 6.09.36 AM.png

Casual Listener

Client on my Mac is doing it again, randomly pausing near the beginning of many songs, no feedback as to why.

 

Sonos tried to play my playlist of Adam Green this morning, would do about 10 seconds of each song before "connection to Spotify was lost".

 

Is anyone available to address this? Is this where I should be seeking support? Is there some sort of server status page I can look at and say "oh good they know something is wrong and are working on it"?

Regular

Would be nice to find an Answer !!!! or a link to an answer 

Newbie

 Could other people please try this.

 

I have found that my Samsung Note 4 keeps stopping but NOT if I use my the PC app to control it.

 

For those not familiar with the multiple device feature of Spotify, if you try to run it on more than one device, it will ask you if you want to play music on the local device or keep playing on the remote device.  

 

When controlling from my PC the music plays on my phone RELIABLY where as if use the app on the phone to advance tracks or pause, it would be luck to continue through one song.

 

If others can try this and report your results we may help the developers find the bug.

 

I have tried reinstalling, cleaning cache, looking at developer page etc. etc. but I think this is a bug based in the part of the software that is used to control remote devices.

Spotify
Spotify
Status changed to: Fixed

Hey folks, this should be fixed for you all. If you're having any further trouble with your Andoid please post in the Help boards. Thanks!