(Apple TV) TvOS 14 Multiple Audio Output not working



Country Brazil



Apple TV 4K 32GB

Operating System

TvOS 14 Beta 2

Spotify 1.10.32


Hello spotify people. 


I´m beta testing TvOS 14 betas 1 and 2 for another aplications and realized that on spotify, when i try to select multiple audio outputs with airplay, the sound only comes out on one destination. 


I have the apple tv pluged directly on my tv, and multiple airplay targets, speakers, airport express and other apple tv, selecting more than one target, only one, the last selected plays audio.


I have tryed  the same configuration with another apps like, youtube, twitch, movies and apple music and everything works fine. On TvOS 13 everything worked just fine also. 


I know is everything beta, but i wanted to report so you guys can make your magic, and everything will be ok for the release on september

Thanks in advance

PS. If you need a beta tester! 🙂


Hey folks,


Thanks for your patience while we looked into this issue.


We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.


If you're still having trouble, make sure to post a new thread in the relevant Help board here.




Hello everyone! I too had this problem and fixed it.

When you are on the airplay selection area on the Apple TV (hold down the tv icon on remote & a small menu opens up, scroll down to the airplay icon), change between tv speakers and the HomePod and eventually it starts to play. 
For me I first had the pod selected and no sound coming then I also selected tv speakers and it automatically switched to the pod and started playing. Might not work for everyone, but okay around with it and it might just work for you!

Status changed to: Under investigation

Thanks everyone for reporting this issue to us!


Rest assured that all the details provided here have been passed on to our developers, who are currently looking into it.


For now we recommend keeping your app up-to-date to ensure you're rocking the latest fixes 🙂


Also, don't forget to add your +VOTE and subscribe to this thread in order to be notified when we have more info.



Casual Listener

Anyone taking odds on when we will see this fixed?  Probably around the same time we get a scrubbing/fast forward feature on the AppleTV.  We’ll probably get a fully functional stories feature first 😅


Prove me wrong, iOS dev team.


Are their any updates yet? I would love to be able to use all my speakers with Spotify on Apple TV, but so far have been trying multiple things without succes. 

Thanks in advance!

I tried your workaround of pause/play * 2. Still no luck. I’m having the
same problem with the Pandora app on tvOS so it doesn’t seem isolated to
Spotify. No issue with Apple Music though.
Casual Listener

Don’t give them that excuse.  The fact that Pandora is having the same issue does NOT help to resolve the issue, it only gives Spotify more slack.  

Not giving an excuse so much as giving an opportunity to stop... and
collaborate, lol.

IMHO: I don’t think it’s only Spotify issue. I suspect (and hope I’m wrong)
this is an Apple ‘issue’ by design. An issue that affects more than one app
on their platform and it hasn’t been resolved yet after two months of GR
and a couple point releases leads me to believe this just might be
on Apple’s part.

Same bug here...

Gig Goer

Just to bem clear.
The bug was reported by @elrafar on '2020-07-09"


About 5 months!


Same issue for me with a Apple TV 4th gen tvOS 14.2 connected to a denon AVR, an airport express with wired speaker and a jbl portable link. It’s totally out of sync when using airplay from my iPhone to both Apple TV and jbl, especially after calibrating. When using Spotify from the Apple TV over both speakers, I only get sound from the JBL and airport, not the AVR. BBUTTT the weirdest thing is that it’s perfectly in sync playing over all speakers when using Apple Music, but who would want that?!?


Hey everyone,


Thanks for your patience with this one. 


Our developer team is currently testing out a fix for this. Could you let us know if the issue persists, once you make sure that you have the most recent version of the app running? 


We'll be keeping an eye our for your replies.

Related Issues