(Apple TV) TvOS 14 Multiple Audio Output not working

Plan

Premium

Country Brazil

 

Device

Apple TV 4K 32GB

Operating System

TvOS 14 Beta 2

Spotify 1.10.32

 

Hello spotify people. 

 

I´m beta testing TvOS 14 betas 1 and 2 for another aplications and realized that on spotify, when i try to select multiple audio outputs with airplay, the sound only comes out on one destination. 

 

I have the apple tv pluged directly on my tv, and multiple airplay targets, speakers, airport express and other apple tv, selecting more than one target, only one, the last selected plays audio.

 

I have tryed  the same configuration with another apps like, youtube, twitch, movies and apple music and everything works fine. On TvOS 13 everything worked just fine also. 

 

I know is everything beta, but i wanted to report so you guys can make your magic, and everything will be ok for the release on september

Thanks in advance

PS. If you need a beta tester! 🙂

 

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.

 

If you're still having trouble, make sure to post a new thread in the relevant Help board here.

 

Thanks!

Spencer269
Newbie

Hello everyone! I too had this problem and fixed it.

When you are on the airplay selection area on the Apple TV (hold down the tv icon on remote & a small menu opens up, scroll down to the airplay icon), change between tv speakers and the HomePod and eventually it starts to play. 
For me I first had the pod selected and no sound coming then I also selected tv speakers and it automatically switched to the pod and started playing. Might not work for everyone, but okay around with it and it might just work for you!

Comments
btz1
Gig Goer

I'm on version 2020.12.16.

I logged out, and when I login again, the first reproduction was silent. I had to play and pause 3x until the sound came out

spotmik
Casual Listener

I'm also on version 2020.12.16, no updates on App Store, and it doesn't work. Play/Pause trick doesn't work either. 

Ivan
Spotify Legend
Status changed to: Fixed

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.

 

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks! 

spotmik
Casual Listener

It's not fixed! I have installed latest version 1.16.3 - Released 16 Dec 2020. @Ivan Can you clarify which version should contain fix?

Adrian62
Visitor

I confirm it’s not working for me either. tvOS 14.3 and same spotify version as spotmik 1.16.3

@Ivan will you confirm which release that include the fix?

JoeH76
Regular

Not fixed! There’s no update in the App Store on tvOS yet. The latest version is 1.16.3. 

lerige
Regular

Seems fixed on my side on Apple TV (before the 4K version).

JoeH76
Regular
What version of Spotify are you using?
JoeH76
Regular

@Ivan why has there been no response from Spotify after you stated this bug is fixed with latest version but several have commented it’s not fixed? The latest version was released on 12/16/2020; well before you announced this was fixed.

PehrJ
Regular

I have the same issue. 

tvOS 14.3
Spotify ver. 1.16.3

Airplay to multiple devices works from other apps but not from Spotify.

Related Issues