Announcements

Audio Glitches During Crossfade on iPad

Plan

Premium

Country

USA

Device

iPad Air 3

Operating System

iOS 14.0.1

Spotify Version

8.6.6.1099

 

As of yesterday, I have been noticing audio glitches during crossfading.  It’s something like a pop or a click, and it always happens either at the very beginning of the crossfade or at the very end of the crossfade.  It can be especially loud after a song that is over ten minutes long.  This is a very annoying glitch and it takes away the enjoyment of listening to music on Spotify somewhat.

 

I appreciate you fixing it.

 

Hey there folks,

 

Thanks for your patience and reports!

 

Our teams have done their magic backstage and this should be fixed.

 

Make sure to try reinstalling the app thoroughly if you're having troubles. If it persists, make sure to let us know in the relevant Help board.

 

Have a lovely day 🙂

Comments
mbug90
Roadie

This is still an annoying issue.  Help me!

Katerina
Moderator
Moderator

Hey there @mbug90,

 

No worries, help's here!

 

Could you let us know if this is happening when you're using Local Files specifically?

 

If so, we're looking into this at the moment. In that case, we'd recommend heading over to this Ongoing Issue and following the steps in the Status Update.

 

However, if this doesn't happen with Local Files, it'd be helpful if you could let us know some additional info and include any troubleshooting steps you've tried and their outcome. If you haven't tried any, a thorough reinstallation of the app with the steps here is a good way to start.

 

Keep us posted! We'll be right here if you need more help.

 

Have a lovely day 🙂

 

mbug90
Roadie

It’s happening with music that is already available on Spotify.

 

I already tried...

 

Restarting my iPad

Disabling audio normalization

Disabling equalizer

Disabling automix

Logging out and into Spotify

Clearing the cache

 

None of the above worked.

Eni
Moderator
Moderator

Hey @mbug90

 

Thanks for getting back in touch and for letting us know that. 

 

Just to confirm, have you tried reinstalling the app following the steps @Katerina sent previously?

 

In case that it didn't make the difference, could you send us a screen recording where we can see the issue happening? 

 

We'll be waiting for your reply 🙂

mbug90
Roadie

A clean reinstall didn’t work.

 

Listen around 12 seconds after the next song starts.  You’ll hear a pop.

Eni
Moderator
Moderator

Hi @mbug90

 

Thanks for the info you sent. 

 

Could you let us know if you're an Alpha or Beta tester?

 

On another note, would you mind letting us know if this is also happening on a different device?

 

We'll be on the lookout for your reply!

mbug90
Roadie
I am not a tester at all. Just a user.

I don't have another device to test it on.
x3n
Spotify
Spotify

Hi @mbug90,

 

Thanks for your reply.

Is this happening to your Local Files only? Have you tested it with songs from our library?

Please keep us posted! We're always happy to help out 🙂

mbug90
Roadie

It's happening with songs in your library.

Jeremy
Moderator
Moderator

Hey there @mbug90,

 

Thank you for your reply.

 

Can you let us know if this happens on one specific device or multiple devices?

It would also be great if you can log in with another account - such as a friend's or a family member's to see if the issue persist.

 

We'll keep an eye out for your reply.

 

Take care!