Announcements

Autoplay not working

Status: Fixed

Hey folks,

 

We're receiving reports that Autoplay isn't working.

 

If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.

 

We'll be keeping everyone up to speed here, so make sure to Subscribe to this thread. 

 

Thanks! 

 

 

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.

 

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks!

Comments
rtaylor119

Plan: Family

Device: iPhone 7

OS: iOS 14.2

Spotify version: 8.6.56.1456

Autoplay not working after fresh install

alexperez97

@Mihail, thanks for your quick reply. I'm not sure about Podcasts, my issues happens on general songs. I have tried what you said and the issue persists, I reinstalled Spotify on my laptop but it didn't solved the problem. Here are the screenshots you asked for, in this case I looked for this song and as you can see is the only one in queue playing on and on.

 

Steps to reproduce it:

-Look for a song using the search bar

-Tap/click on that song

-When that song ends or if you click on next the same song keeps playing

Screen Shot 2021-08-25 at 15.21.30.pngScreen Shot 2021-08-25 at 15.21.41.png

tmizutani

Hey everyone who's having this problem.

 

Try to do this:

1 - Keep the Autoplat flag on

2 - Change the status of the "gapless flag", e.g if it's on, turn it off, if it's off, turn it on.

3 - play the last song of any playlist (you can skip to the last seconds)

4 - change the status of "gapless flag" again

5 - repeat step 3 and see if it works

 

I did and it work for me and I'm extremely happy right now. 

 

To the devs: you probably changed some flags in the code and this is messing with everything... Maybe because of this ambiguous flag name

 

 

 

 

 

 

 

 

Mac_Holgate

Same issue. Google pixel 5 on family plan, OS Android 11

Mihail
Status changed to: Fixed

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.

 

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks!

Thethomasdahl

How can they say this has been fixed when nothing has changed.  Spotify still autoplays every time I finish a phone call or a Zoom meeting even if it was not playing before hand.

 

This is a really annoying BUG

DJDanDan

Plan

Premium

Country

Norway

Device

Iphone 8 IOS 14.7.1

 

The autoplay isn’t working and when I play a song it only plays 10 seconds in and then stops. I can literally not listen to music, and it’s extremely annoying at this point. I’ve tried to update, log out, restart the app, restart my phone and nothing works. Please fix this.

 

@Mihail

discy

Seems you got enough votes, no?

alexperez97

For some reason it's working for me know, you have to 'play' disabling both, Shuffle and Repeat options, look for a song, wait until it finishes and Boom, the autoplay is working. Thank you guys!

josephd60

Auto play is not fixed. I have a Sonos system, and after the playback, the playlist ends. It’s a Spotify issue, even though Spotify will

blame Sonos. 
With the exception of Pandora, I have used every other streaming service. IE: Apple Music, Amazon Music, and YouTube music. And auto play has zero issues when streaming  from my Sonos system, it is only Spotify (Play 5). I even went so far is connecting from a line-in with Sonos, and auto play does not work. Hopefully a fix comes soon.   From what I am seeing, there is already a thread here regarding this issue. And it dates back from 2 years ago. It seems it’s not important enough to Spotify to fix auto play on Sonos.