[BUG][ANDROID]Storage usage reported incorrectly

I am having exactly the same issue as that was originally reported here

 

Have spotify cache installed to the SD card that is in the phone and spotify is reporting it to internal memory as well as SD card for downloaded data. 

 

I have tried to formatting the SD (it's new), reinstalling, only downloading extreme quality, none of which fixes the issue. 

 

This is before downloading any music

 

Before downloadingBefore downloadingBefore DownloadingBefore Downloading

This is after downloading music. 

 

After DownloadingAfter DownloadingAfter DownloadingAfter DownloadingAfter DownloadingAfter Downloading

 

 

Hey folks,

 

Thanks for the reports.

 

We don't have a time frame for a fix, but we can confirm the tech team are looking into this. Hopefully we'll have an update for you all soon. 

 

If you're new to this thread, make sure you leave your vote in the top right corner of the page.

 

Thanks,

Chris

Comments
Casual Listener

I've tried this on my home Wi-Fi and my work Wi-Fi which are about 45 minutes from each other and it does exactly the same thing. There is a bug in the software that is reporting downloads to both memory locations. 

Roadie

 

That's odd. Let's try something else.

 

Can you remove your offline devices and reinstall the app once again? After that, make sure you have the SD card storage option activate and create a test playlist with 10 songs and download it for Offline Mode using WiFi.

 

Let us know if it's saved in both your SD card and internal memory again.

 

Have a nice day 🙂

Casual Listener

removed all offline devices via the website. 

un installed the app same as the instructions. Reformatted the SD card. Re installed. Selected the SD card as the storage location. 

Created a playlist with 10 songs, downloaded them as suggested

 

still doing exactly the same thing

 

Screenshot_20170529-162604.pngScreenshot_20170529-162633.pngScreenshot_20170529-162925.png

Roadie

Thanks for trying @jamesslane.

 

We'd like to make sure of something before we can report this to our team. If it's possible, can you try downloading songs from a different mobile device while logging into your Premium account? 

 

Let us know if the issue persists after this. 

 

 

Casual Listener

I can go one better on that. I've uninstalled Spotify from my tablet as per the intructions. Inserted a different SD card. Reformatted the card. Reinstalled spotify & as you can see from the screen shots below it's doing exactly the same thing as my phone. 

 

Screenshot_20170530-162507.pngScreenshot_20170530-162510.pngScreenshot_20170530-162542.pngScreenshot_20170530-162655.pngScreenshot_20170530-162907.pngScreenshot_20170530-162923.png

 

There has got to be a bug in the software surely?

Roadie

Thanks for all the info you've given us so far. 

 

We'd like to try one final step just to make sure. Can you try logging on your devices using a different Premium account (perhaps one from a friend or a relative)? Then, try downloading some songs again and check if the issue is still persisting.

 

Finally, can you let us know exactly when did this start happening? Was it after a specific update or event? 

 

We'll look forward to your response.

Casual Listener

I've tried a different account and it's still doing the same thing.

It's been happening since I installed spotify onto my devices. I got spotify after getting an s8 and installed onto my tablet too where it's doing the same thing again

Casual Listener

Interestingly, overnight my tablet has updated to android 7.0 and after following the uninstall instructions and formatting the card it's still doing the exact same thing. 

Spotify
Spotify
Status changed to: Under investigation

Hey guys! 

 

We've reported this to the right folks, thanks for your patience and sending over that info.

 

Stay tuned for any updates 🙂 

Spotify Legend
Status changed to: Under investigation

Hey guys!

Thanks for all your reports here. Our team are investigating this backstage and hope to have an update soon. If you're having trouble we'd suggest a clean reinstallation. This has helped many users get back to normal.

If you're still having issues, can you let us know the following;

 

- Device

- Version of Android

- Version of Spotify

 

Thanks for bearing with us 🙂