[BUG][Gear S3][Android 5.0.1] Spotify launches on the phone any time Gear S3 connects to the phone

Hello,

 

I'm writing this after Spotify Support asked me to do as there might be other people experiencing the same (or similar) problem.

 

I own a Samsung Galaxy S4 (Android version 5.0.1) and Samsung Gear S3 (Tizen version 3.0.0.1). Spotify is installed on both of my devices. I also use Spotify widget on my Gear S3, for easy access to the app.

 

The problem is when my watch connects to the phone, Spotify launches immediately on my phone. This also happens when I scroll (or turn the widget wheel?) between widgets on Gear S3, without interacting with the Spotify widget. This is becoming kind of annoying because I have to close Spotify before using my phone. I also need to charge my phone more frequently if I don't realize Spotify is launched on my phone. 

 

Keep in mind that this issue might be specific to Android version 5. After contacting Spotify Support, they asked me to try to recreate the problem on another phone, with an Android version higher than the previous one. I tried it using LG V20 (Android version 6, if I recall correctly now), and there was no problem at that time.

 

Thank you for reading!

 

Hey @emreorta and @GamerJ,

 

We're going to close this thread now. If your hear back from Samsung and there's anything you'd like us to look into, just give us a shout. 🙂 

 

Leo 

Comments
Spotify
Spotify
Status changed to: Need more info

Hey @emreorta!

 

That's odd. Just to confirm, have you tried reinstalling the app on both devices? If so, let us know the exact Spotify version you're running on both. Also, has this always happened, or did it start after any specific update or event?

 

We look forward for your reply :)

emreorta
Casual Listener

Hey @William_13,

 

Thank you for your reply!

 

I've reinstalled the app on both devices before, nothing changed. This has always happened since the very first that I started to use my Gear S3.

 

Here are the OS and Spotify versions:

- Phone: Samsung Galaxy S4, Android version 5.0.1, Spotify version 8.4.28.875

- Watch: Samsung Gear S3, Tizen version 3.0.0.1, Spotify version 1.1.39

 

Let me know if you need anything else.

Alfredo
Roadie

Hey @emreorta, thanks for all the info!

 

Looks like we might need to have this issue reported to our Tech team.

 

Before we do so, could you try using a different Spotify account to test it out?

 

Keep us posted.

emreorta
Casual Listener

Hey @Alfredo,

 

People at the Spotify Support provided me a test account before writing here, and same problem happened that time too. 

Alfredo
Roadie

Thanks!

 

We've sent a report about this on to the right folks. Fingers crossed, we'll have an update soon.

 

Stay tuned.

Community Manager
Community Manager
Status changed to: Under investigation

Thanks for the info @emreorta.

 

We can confirm the tech team are looking into this. We'll let you know more once we have some news.

 

Stay tuned!

GamerJ
Newbie

I also have this issue with my Gear S3.

My Gear also got Tizien 3.0.0.1 but this already happend with the old Tizen version. My Android device is a Galaxy S7 edge with Android 7.0.

The App will also be started on the phone when your Gear is losing bluetooth connection to the phone and when you put the gear on the charger. That's really annoying.

I noticed that this issue is only happening when the App is in remote mode. In streaming mode everthing is fine.

 

But there is also an issue in the streaming mode. When you have the automatic Wifi activation activatet on your watch, Wifi will be activatet when you open the app. But when you close the App the Wifi wont be deactivated. You have to deactivate it manually.

 

Dont know if i should create a new thread for it :) Hope this is ok. 

emreorta
Casual Listener

@GamerJ, thank you for mentioning about the remote mode and older Tizen version. I totally forgot about them. I use the app only in remote mode, so I really can't say anything about streaming mode if that even matters now. I used the app before Tizen 3.0.0.1 too, and the same problem kept happening back then.

 

To all the mods, thank you for taking your time and putting some effort on this issue!

Community Manager
Community Manager

Hey @emreorta & @GamerJ,

 

Thanks for all the info. Could you both try to disable the Auto Open Apps feature on your smartwatches?

 

To do this, just head to Settings > Device > scroll down > tap Auto open apps to turn it off.

 

Let us know if that helps!

emreorta
Casual Listener

Hey @Chris,

 

I checked and it's already disabled. I turned it on and off, however, the same problem still occurs.