Blends not working

Status: Fixed

We're seeing posts that existing Blend playlists can't be accessed anymore and that folks are also unable to accept new Blend invitations.  Reports also mention that the app just goes back to the Home page or gets a loading screen after clicking on the invite button.  This is happening on both iOS and Android devices.

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

The initial cause for blends not working has been resolved.

 

We're seeing a mix of several different reports here, so we'd recommend that raise them in separate threads so they can be looked at on their own merit.

 

Thanks!

Comments
al-eh-and-ra

Plan

Premium

Country

USA

Device

(iPhone 7 and Web Browser + iPhone X)

Operating System

(iOS 14.6)

 

My Question or Issue

Just earlier today a friend and I tried to create a Blend playlist. We've been trying to load it on both our phones since roughly an hour ago. When I clicked the link, and pressed join, the app opened on a black screen with the three dots. I've tried refreshing the app, login out and back in, and resetting my device... nothing seems to be helping the playlist show. It does appear on our "Made for You" pages, but when you click on it you get the three dots again. 

Would appreciate any and all help with this issue! 

Lake011

This is happening to me too. I think it is because we made the playlist during the time the app went down.

OakinSyphon

Plan

Premium

Country

US

Device

iPhone XR

Operating System

iOS 15

 

My Question or Issue

I sent a link to a friend to generate a blend for us today and while it seemed to have worked, neither of us are able to open the blend.  After loading for a while, the app just says that it encountered an error.  We've tried sending new links and those don't work either.  I can't delete the playlist or anything either because it's a Spotify-generated playlist.  Anyone know what to do about this?

Alex

Hey @OakinSyphon,

 

Thanks for the post.

 

Sorry to hear that you're having such an experience with Blend.

 

We'd recommend running a clean reinstall of the app. Please follow the steps from this Spotify Guide exactly, as this will assure that all app data is cleared completely, before reinstalling. 

 

Also, make sure that Battery optimization is not enabled for Spotify from the system app settings, as well as that the app is granted all permissions. These settings could be hindering the performance of the app.

 

Both you and your friend can go through these steps just in case.

 

After that opening the Blend playlist if it's still visible in your library. If that's the case you should be able to click the 3-dot menu > Leave blend, which will delete the playlist.

 

Keep us posted on how you get on with this.

 

Cheers.

 

MafeG

Hi folks,

 

Thank you for posting on the Community. 

 

Please try deleting the playlist and creating it again. You can do it by going to Your Library/Made for You section on your phone, then tap and hold over the playlist, a menu will appear and select the option to stop following it.

 

The other person also needs to do the same from their own account, this way the playlist will be removed.

 

After that, try to create a new one and check how it behaves.

 

Let us know how this goes.

al-eh-and-ra

Hi MafeG, 

 

Thank you for your suggestion! My friend and I gave it a shot but we ran into one major problem. The Blend, as we see it, exists only within the Made For You page, and was never registered as a playlist, really (because it doesn't show within either of our libraries). It has no likes. We can't delete it by tap-and-hold. It does nothing. 

 

Do you have any other suggestions about how to go about deleting the husk that appears now so we can try to create a new one from scratch? 

 

Thank you in advance for your help! 

Kiril
Status changed to: Under investigation

Hey folks,

 

Thanks for reporting this issue to us.

 

We’ve passed your info on to the relevant team, who are currently looking into it.

 

First up, it's well worth running a clean reinstall to get rid of any cached files that might be causing trouble. 

If you’re experiencing this issue after reinstalling, then please make sure to click +VOTE and Subscribe to the thread to be notified of any developments.

 

Could you also make sure to provide us with the following info, if you haven’t already:

  • device + OS version
  • exact Spotify version
  • country
  • your subscription type
  • a list of the troubleshooting steps tried

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.

Kaybee3

My blend isn't refreshing. Help please?

IanF89

Plan

Premium

Country

Canada

Device

Huawei P30 Pro

Operating System

Android 10

 

Problem

Like with @al-eh-and-ra's problem, our Blend exists only within the Made For You page, and was never registered as a playlist. We can't delete it by tap-and-hold. It does nothing.  However, we were able to create other Blends with a mutual friend several days ago, without any problem. Clean-reinstalling the app didn't improve the situation.

Lake011

Plan

Student Premium

Country

United States

 

I am also having the exact same situation as @al-eh-and-ra and @IanF89. Our blend only is in the Made For You page. I cannot delete it. It says Playlist not found after a while of waiting for it to load. I made a few Blend playlists with other friends that same morning and that was the only one that doesn't work.