[Bug] Connect Reports Incorrect Playing Track

Description:

Spotify Connect on iOS often reports incorrect playing track.

 

Device Information:

iPhone 4S 16GB Spotify 0.9.1.230

iPad 3 16GB Spotify 0.9.1.230

Pioneer A1 (XW-SMA1-K)

 

To reproduce:

This doesn't reproduce 100% of the time, but it appears to happen for me at least a few times an evening.

 

Open Spotify on iPhone or iPad.

Start playback.

Transfer playback to another device using Spotify connect. 

Navigate away from Spotify on iPhone or iPad. 

Once a couple of tracks have played, navigate back to Spotify on iPhone, the track which is reported to be playing on iPhone is incorrect and doesn't update until another track is manually selected. When this happens even going to the now playing screen displays the old track. 

 

Workaround:

Manually selecting another song forces it to go into sync again.

 

Additional information:

Clean reinstalled on both devices, made no difference.

Tried connecting to a different router incase signal strength in our house was causing an issue, made no difference.

Also happens between a Spotify app and a Connect speaker, it appears it can report any track on a playlist is playing (which is incorrect). Manually selecting a new song whilst the speaker is transitioning between songs seems to cause the issue too.

 

Screenshots:

 

What iPhone shows:

 

connect bug 2.JPG

 

What iPad shows:

connect bug 1.JPG

 

Hey folks, a fix for this has already rolled out. If you're having issues with Spotify Connect and your iOS device please start another thread in the iOS Help board. Thanks everyone!

Status: Fixed
0 Likes

Related Issues

Comments
Peter__
Community Legend

Appears to be solved in the most recent app update. :) 

 

Updated first post. 

Whistler
Music Fan

Unfortunately this problem still exists. At least between iphone / pioneer vsx-s510 av-receiver. Not only it displays the wrong song, it also frequently plays the wrong song 

Peter__
Community Legend

I can confirm, this does happen between my iOS devices and my new Pioneer Connect enabled speaker, yet to see it happen on android but I will play with it tonight. 

 

Moving this over into bugs. 

Community Manager
Community Manager

@Whistler @Peter__ Is this still happening for you guys on the latest Spotify iOS update?

Peter__
Community Legend
Will test this evening :).
Whistler
Music Fan

Hi Meredith, 

 

No, this bug seems to have been solved. Allthough i still have a lot of issues with the connect feature, but maybe i should save them for another thread. 

Peter__
Community Legend
Can confirm, this bug appears to be resolved.
Joe
Community Legend

Still happens on android - 1.1.1.116.

A_Be_Cgn
Newbie

I have a similar problem. Both devices Android with version 1.3.0.423. If I add a title to the queue and it is played, the playing device shows the right title, however the connected (not playing, controlling) shows the next title in the list, after the queued track. After the queued track its finished, both devices show the correct title again (the remote device shows it for the second time). Looks to me like a rather specific issue.

elhabilmorgan
Newbie

 

hello,

 

a terrible track bug: Pumping on your stereo-Supergrass, now is C'est la vie-B witched.

Supergrass – Pumping On Your Stereo

 

 

UF.

 

EH.