Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Can't click on a song to play in a Spotify Play Button for albums and playlists

Status: Won't Fix

For spotify play buttons the big play button on the album cover will open up the app and start playing the song, but as of Friday (7/7/17) clicking on an individual song in an album or playlist does nothing.  It will no longer open the app nor play the song.  On mobile web as well, previews will not play, so it feels like the click handlers are broken or non-existent on the song rows. 

 

Note this has nothing to do with my specific embed, it is a global problem reproducible from the example in spotify play button documentation https://developer.spotify.com/technologies/widgets/spotify-play-button.

 

Thanks!!

Hey folks,

 

We're going to close this thread up now.

 

The team are aware of things, however we're afraid we don't have an exact timeline for a fix.
If we have any further info to share on this in the future, we'll be in touch here.

Many thanks,

/M

Comments
Hubo
Status changed to: Need more info

Hey @rickpern! Thanks for your report!

That's odd. Let's get to the bottom of this. Could you let me know your browser and OS versions? I'd love to take a closer look.

 

Have a great day! 🙂

pickadicka

I am experiencing the same thing as of a week or two back. When embedding the Play Button only the upper part of the frame are working properly. You cannot select tracks by clicking from the list anymore. MacOS 10.12.5, Safari 10.1.1, Firefox 54.0.1, Chrome 59.0.3071.115.  Thanks!

Alfredo
Status changed to: Under investigation

Hey everyone!

 

We've reported the issue with embedded playlists not allowing us to choose any song.

 

About the app not launching when you hit play on the embedded playlist, we couldn't replicate it on our end. Let's try reinstalling Spotify. Also, head to the Spotify Settings > Start up and Window Behaviour, and make sure you allow Spotify to be opened from the web.

 

Keep us posted.

rickpern

@Alfredo the play button works fine opening the app, just not when clicking on any of the songs.  Thanks for reporting the issue!! 

 

@Hubo i don't believe it is browser or device specific, i did some cross-browser testing on OSX latest Chrome, Safari, and Firefox as well as Safari on iOS 10.  Thanks for looking into it!

Chris

Thanks for keeping us in the loop, @rickpern.

 

We can confirm that the right team are looking into this. We'll update you here as soon as we hear back from them. 

 

Stay tuned!

pickadicka

@rickpern@Hubo@Alfredo and @Chris It seems that clicking on the songs in a playlist works again. I have tried Safari, Chrome and Firefox on MacOS.

Good job, thanks!

 

Love, M

frazze1

I have this problem too. If there was a misunderstanding, here's an example:

https://developer.spotify.com/technologies/widgets/spotify-play-button/

On this "Spotify Play Button" page, I pasted the following uri:s into the field under "Get the Code":

spotify:album:6vQMbwthchxuSioACn2hcE

spotify:user:frazze:playlist:5WHDd6tl6QCPOtleYP5s7Q

spotify:track:5cxRbfQWrT4NZ2msbtSx4H

 

For the album and the playlist, the preview player opens Spotify and it starts playing. However, for the track, it won't play. It just opens the album page where the track is from, without playing the track.

 

frazze1

I should have said that my problem is related to the OP. As for playing individual tracks on an embedded album or playlist, I now discovered something really strange. For this album

spotify:album:1WHbPhjPCBhjo49DpKvYbL

it plays the first song, "So Easy", no matter what song I click on in the preview player on https://developer.spotify.com/technologies/widgets/spotify-play-button/. But for this album

spotify:album:7lzl1Qfv4NqSmypuKmF07l

everything seems to work fine.

 

Hopefully this will help you solve the issue...!

Jack

Hey everyone, thanks for your recent reports!

 

We appreciate your detailed explanation of this, @frazze1. That new development that you mentioned is rather strange. Have you noticed this happening with any other albums specifically, or have you just noticed it on that particular Röyksopp album?

 

If you could let us know specifically what device you're using, that'd be great.

 

Thanks,

Inzpyrd

 My problem of being unable to control Spotify on chromecast audio was solved by a reinstall of Spotify. Despite all updates installed. Frustrating but happy now.