Help Wizard

Step 1


Can't log into my account on the app

I must've changed my password at least 5 times and STILL can't get into my account. It just comes up with a message saying "Username or Password Incorrect." I have tried logging in with facebook, used every variation of my email, username and password and continually get the same message. Any solutions?

Hey folks,

Please can you uninstall the existing app on your device, and then download the latest official version from
If that still doesn't work we'd recommend reaching out to Support, so that they can take a closer look backstage.

Samsung S8+

Latest Android 

Spotify won't log into the app but online is fine 

Uninstalled 8 x

Reset Pw 8 x

Resetting my phone didn't work either 


Samsung Galaxy S5 7.1.2 (LOS-Resurrection Remix)

Not letting my log in.

Was working before.

Im using the offical app off the playstore.

Allows me to reset but doesnt let me log in.


Hey folks!


If you head to your Spotify app on Android and go to Settings > About Spotify, the installed version should be the 8.4.43.


An older version might be the cause of this issue, so please remove the app on your phones and download the latest official version here. Touching this link on Android should take you to the app store to download Spotify.


Try this out and should be an easy fix.



Tried that it still doesn't work.

Thanks for keeping us posted, @sickyman_678!


Just to make sure, could you try clearing your device's caché/cookies, and reinstalling the app? 


Let us know if this helps. 


Same here. Worked 10 hrs the play button but nothing happens (no sound). Uninstalled the app and reinstalled and logged in with my credentials..all I'm met with is "sorry something went wrong" in the "home" page of the app. I'm logged into the app but there is no content.


Same problem, cant logging in the app


Correct password, correct mail but I can't log ... How can this be possible ? The app always says that I'm wrong but I'm not. Is there a way to solve this ?


I cannot login to the app in my phone. help!


Same problem. Please do something.