Help Wizard

Step 1


Can't play songs from search

Status: Closed

Device: Windows Phone Nokia Lumia 830


Operating System Version: Windows 8.1 Update 2


Spotify Version: 5.1.5529.26509


Description : I can't  play music if I use the search function. Nothing happens if I press a song from the list. But if I choose song from a playlist or album the song will start palying normally. I have tried reinstalling the spotify app twice, but the problem continues. The problem started last week.


To reproduce:

  1. Log in to Spotify app (with spotify credentials)
  2.  Write song or artist name in the search function
  3.  Try to play a song from the list of songs provided.

Workaround: N/A



Additional information: N/A




The same symptomps on a lumia 920 with Spotify v. (marketplace doesn't show any updates available). Maybe one in 20 songs plays from the search results, but from any album the songs will play, and mostly from playlists, too. If I tap a song in the search results, the previous song stops, but the new song never turns green nor does it start to play. Sometimes, but only sometimes, if I return to spotify later, the non-playing song is displayed at the bottom as the current song, but the play/pause button doesn't do anything.

Status changed to: Closed

Hey guys!


Thanks for the feedback on this issue. It's all very much appreciated.


We're actually looking into similar reports of this at the moment. Thankfully, we should have a n update to this shortly, so watch this space.


Thanks again for the comments!




The problem that I had with Spotify not playing songs with the search function seems to have been solved. I don't now what happed but the problem did dissapear after I changed my spotify password.


I'm having the same issue on my iPad. I can normally search 1 song and add it to a playlist before it freezes, but after that it just locks up. Then I have to shut Spotify down and open it again for every song I want to add from search.

Status changed to: Closed

Hey @jaykingiv


Could you try a soft reset by holding the home + power button for a few seconds? Let us know how you get on.