Can't view any menus in the Web Player on Chromebook








My Question or Issue

The Web Player is not working and when I go on it, it shows a button saying play on spotify but when I click it it pops up on the same page.




Hey there folks,


We haven't heard back from you in a bit regarding this.


Since this should be fixed after updating your device's Chrome OS, we'll close this Ongoing Issue as Fixed.


If you're having troubles with a similar issue on a Chromebook or a device running another OS, let us know in the relevant Help Board and we'll be happy to lend a hand there.


Have a lovely day 🙂

Related Issues

Casual Listener

Just got back on and it was fixed



I have an HP Chromebook with Chrome OS with this issue. It was fine one day and the next time I opened it it was like this.


Same here with an Asus chromebit


I had this issue earlier, but after about an hour, I refreshed the page and it was back to the regular web player. I'm on Chromebook Linux. Spotify has been working fine for me since I refreshed after some time. Might just be a waiting game.


Mine has just now started to work.


I'm not sure mine is the same issue, but in web player on chrome on a pc, i press play, multiple tracks skip and no music plays.  It tries to play an add which skips.  This has been happening since late last week.  


I'm having this issue.


  • Exact device this is happening on (model)
    • Asus ROG G771JW
    • HP Pavilion x360 Convertible
  • Operating system and version
    • Windows 7 - 64-bit - On the Asus ROG
    • Windows 10 Home, version 1803 (not enough memory to update) - HP Pavilion
  • Browser you're using (Chrome, Firefox, etc)
    • Firefox 74.0 - On Both Windows 10 & 7
    • Opera 67.0 - On Windows 7


I will add it seems to be tentatively working again on Firefox on Windows 10 on my HP Pavilion but Still not working on my Asus ROG on Windows 7 in either browser.



I'm using a Dell Chromebook and mine doesn't work if you go through and then click "Launch Web Player."


However, I tried going directly to and that works just fine.


Same problem here. Few hours ago it worked fine, now refreshed the page and it doesn't work.


Lenovo Idepad330, Win 10, Opera 67




The same Linux + Opera