Can't view any menus in the Web Player on Chromebook








My Question or Issue

The Web Player is not working and when I go on it, it shows a button saying play on spotify but when I click it it pops up on the same page.




Hey there folks,


We haven't heard back from you in a bit regarding this.


Since this should be fixed after updating your device's Chrome OS, we'll close this Ongoing Issue as Fixed.


If you're having troubles with a similar issue on a Chromebook or a device running another OS, let us know in the relevant Help Board and we'll be happy to lend a hand there.


Have a lovely day 🙂

Related Issues



Just noting that this issue is not solely relating to chormebooks /chrome os. 

I am running windows 7 and using Opera web broswer and this issue is still occuring



Looks like it's working again on my HP Chromebook 11 G4!


Still not working on my Win 10 PC with Chrome.   


I can't loggin on Firefox or Googel Crome Web Player. Why? Due to the intrusive advertising, I don't like to use the app.

Status changed to: Under investigation

Hey folks!


We've heard back from out tech team and we have some updates.


This should be working now after updating your Chrome OS, so give that a try and let us know how it goes. 


If after updating the issue still persists, you can send us the following info:

  • Exact device (model)
  • Operating system and version
  • Browser you're using (Chrome, Firefox, etc)

We'll keep an eye out for your replies.





It's still not working, and I d'ont have any available update for Chrome OS. I use an ACER R13 Chromebook, Chrome OS Version 79.0.3945.123, Borwser Chrome.

Thanks for your help : I am in France stuck in my home due to COVID-19, i neeeeed music


Update: Updating Chrome Browser fixed the issue



Login on the Web-Player page is not working. Once I logged in via Facebook, Spotify throws me back to the main Web-Player page, shows me that I need to login to play music and I am not able to play any songs. Once I try to log in again, the cycle continues. Clearing cache etc. does not fix the issue.


- WIndwos Desktop PC

- Windows 10

- Firefox, Chrome, Edge, any browser really...




As several people have already pointed out, this is not specific to Chrome OS. It's a bug that affects multiple browsers.


I'm using Chromium  on Linux here, and I'm seeing the bug right now.


Still experiencing the problem -- Vivaldi 2.9.1705.41 or Chromium 80.0.3987.87 running on Linux Mint 19.3. Works fine on Firefox 74.0.

It's kinda funny 😄

Sunday: player working OK

Monday: those dummy tiles

Tuesday: working OK

Wednesday: dummy tiles


I'm now working from home on same PC, and web player is working again. Not sure if Spotify fixed something or this has something to do with home network vs. work network.  That said, spotify worked on my work network forever before this.