Help Wizard

Step 1


Chosen song not playing in Google Alarm

Hey everyone,


We're receiving reports from users that the alarm clock is not playing the selected song as an alarm. The Google alarm has no sound.


If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.


We'll be keeping everyone up to speed here, so make sure to subscribe to this thread!

Hey folks,


Thanks for your patience while we looked into this issue.


We’re happy to say that this should now be fixed for everyone! Just make sure your app is updated to the latest version.


If you're still having trouble, make sure to post a new thread in the relevant help board here.







Samsung S8+

Operating System



My Question or Issue

  1. A couple of days ago my google alarms suddenly stopped working with spotify. The alarm will beep a few times and then dismiss itself. I have cleared the cache of both apps, deleted them and then reinstalled. I even went as far as go delete all the alarms and remake them, but that didn't help. I have been fiddling with this for the last day and a half and still nothing. Is there a way to fix this???

I have exactly the same problem, think it might have to do with permissions, what your app can do with the phone. Hopefully there will be a new patch soon.


This issue has been going on since the update on August 24th.

The Alarm Clock app wont play the song I selected as an alarm. It'll vibrate for 2 seconds and say I missed the Alarm. This happens even with Spotify open an the songs downloaded. The Clock app also crashes when trying to connect to Spotify.

The Google Alarm Clock works fine with downloaded mp4 or when connected to other music streaming apps.

Please fix, this bug has caused me ( and many other users according to the Google Clock app store page) to miss many appointments.




(Moto G6 2018)

Operating System

(Android 9)



Hi folks,


Thank you for posting on the Community.


As @Salmage said, it's possible this issue has something to do with the app permissions. However, the best way to start troubleshooting an issue is by running a clean reinstall of the app, this one is more thorough than a regular reinstall and helps you have an app free of old files. 


If the reinstall doesn't work, please let us know the make, model and OS version of your phones, as well as the Spotify version.


Keep us posted.


Google Pixel 4a, Android 11. I have tested enabling all permissions and clearing the cache/storage. Neither fixed the problem.


However, downgrading to Spotify version fixes the problem. And then re-installing the latest version ( causes the issue to re-appear. Obviously a bug was introduced between these two versions, and it's not a just a coincidence that half a dozen people start having issues the day was released.


If I set an alarm right after one that has just gone off, the second one will always work. So in order to reliably reproduce the issue, you have to either:

  • Set an alarm for >10 min after the previous alarm / time Spotify was used from the Google clock app, or
  • Set an alarm for any time (ex. 1 min from now), but then before the alarm goes off, force stop Spotify (and you can re-open Spotify after stopping it before the alarm goes off, and the alarm still won't work)

From Android's system logs, I can get the full stack trace of both Spotify crashing, and Google Clock app crashing in response to what it receives from Spotify, but I can't post it here without my reply getting marked as spam. The short version is that first a Spotify thread crashes:


EventSender: Error while synchronizing dropped events file content
EventSender: /data/user/0/ open failed: ENOENT (No such file or directory)


And then the Google Clock app process crashes:


AndroidRuntime: Process:, PID: 25051

AndroidRuntime: java.lang.NullPointerException: Attempt to read from field 'int' on a null object reference


Hi @SPedro7, thanks for posting. I've seen a few reports of this here in the community and have also experienced it with my own alarms a couple times before I realized I hadn't simply slept through the alarm haha.


Before we go further, would you mind trying a clean reinstall just to make sure that doesn't resolve the issue. Please keep in mind this has a few extra steps compared to a standard reinstallation, and you'll find full instructions at the included link. Please let us know how that goes! 

The clean reinstall didn't work for me, it keeps crashing. I'm using a Moto G8 Power with Android 11

Me and my girlfriend have the same issue. 

I am running a Google pixel 3A and she is running a pixel 4A.

Mine is running android 11 with the latest patch of 5 august and the Spotify app version We both noticed the issue thursday morning. 


I have the same issue, been an issue within the last week, tried digging a bit deeper.

It seems the issue is that when Spotify starts the first time from suspension or forced quit it crashes, successive starts work. 

It means it may work if you just test it out, but in the morning the alarm will  not work again.


To reproduce:
- Force closing Spotify, go into alarm, edit the alarm, select Spotify tab > Spotify will crash

- Repeating directly without force close Spotify and it will work, until Spotify is suspended or closed again


Temporary workaround:

Adding two alarms with a minute between will help (first will crash, second will work)


I'm on a Google Pixel 3 with latest updates to the OS Android 11

Spotify version:




I just tried this workaround, both alarms set up with a minute in between, both times the phone vibrates for a second or two, then stops. This happens both on my Archos Hello 10 on Android 8 and Samsung Galaxy Note 9 on Android 10.


Both spotify versions are