[Connect] Can't play songs saved to Your Library on Connect devices

Hey folks,

 

We’re receiving reports that it's not possible to play certain songs on Connect devices.

 

First, we'd recommend trying a clean reinstall of the app on your device by following the steps here.

 

If after that you’re still experiencing the issue, could you provide us with the following info:

  • device you're connecting from + OS version
  • exact Spotify version
  • external device you're connecting to + version
  • which songs is this happening with?

Once we have that, we will pass it on to the relevant team, who will look further into it.

 

Thanks! Keep us posted :)

Hey folks,

 

Thanks for your continued patience while we've been looking into this.

 

Based on your reports so far, it seems that users are experiencing two different issues/scenarios:

  1. Playing any song saved to Your Library (albums, playlists, etc) doesn't work
  2. Playing songs from playlists saved in Your Library works, but not albums.

If you're not experiencing either of these two issues, could you reply to us with clarifications about the exact issue you're experiencing?

 

If your issue resembles one of the above-mentioned scenarios, could you provide some more info, specifically:

 

  • For Scenario 2:
    • Is the playlist which you're able to cast music from saved to Your Library and/or downloaded?
  • For both scenarios:
    • Does this issue also apply to songs which are saved in the Liked Songs playlist?
    • Does removing a liked song/album/playlist and re-adding it to Your Library resolve the issue?
    • Does this also occur for downloaded songs/albums/playlists, and if so, are they also saved to Your Library?

Thanks! We'll continue to pass on this information to the right teams so that they can work towards a fix.

Related Issues

Comments
Moderator
Moderator
Status changed to: Need more info

Hey folks,

 

We’re receiving reports that it's not possible to play certain songs on Connect devices.

 

First, we'd recommend trying a clean reinstall of the app on your device by following the steps here.

 

If after that you’re still experiencing the issue, could you provide us with the following info:

  • device you're connecting from + OS version
  • exact Spotify version
  • external device you're connecting to + version
  • which songs is this happening with?

Once we have that, we will pass it on to the relevant team, who will look further into it.

 

Thanks! Keep us posted :)

fiskie
Casual Listener

Hi,

After following all the given steps, I still can't play properly through Chromecast.

This only happens with albums in my library (not necessarily downloaded). It keeps happening after removing and re-adding the albums to the library. When I look up the album through the normal Spotify search function it works correctly, so it seems to be library related.

 

  • device you're connecting from + OS version
    • OnePlus 7 Pro on Android 9 (OxygenOS 9.5.11.GM21BA)
  • exact Spotify version
    • Spotify version 8.5.23.686
  • external device you're connecting to + version
    • Chromecast Audio (version 1.40.156414 stable, also tried it on preview firmware version 1.42.168007 which does not work either)
  • which songs is this happening with?
    • Not specific songs, just all albums I try to cast from library. Playlists work fine, also searching from general search works fine.

I really hope this will be fixed soon because this is the only way I really use Spotify a lot.

SynnoNym
Music Fan

I can confirm fiskie's information. What i can add: i can play every song from an album stored in the library if i like not just the album but the songs of it too with the heart icon. if i start streaming to my device, every song that is not liked disappears from the waiting list. the liked ones are played.

 

  • device you're connecting from + OS version
    • Pixel 3, Android 10 (Build Number QP1A.190711.020)
  • exact Spotify version
    • Spotify version 8.5.23.686 -  if i downgrade to 8.5.18.932 the problem disappears
  • external device you're connecting to + version
    • Chromecast Audio, Google Home, Google Home Mini, Spotify Web Player (if i connect to the web player from my phone through spotify connect, the problem appears too)
  • which songs is this happening with?
    • all Albums stored in library - but only if opened through library. if i press the three dots and choose "go to album" or look it up through the search i can connect and stream the album, even if it is stored in the library at the moment.
sjhasler
Casual Listener

Hi. There is clearly two separate issues then. I am totally unable to connect to Chromecast Audio. From LG V20. The connection sound happens after a delay, and then it gives up connecting. Please don't ask me to reinstall, this doesn't work. I have had issues like this on a semi regular basis for over a year, but in the last week, it hasn't worked at all. When it did work, the app was very sluggish amd would disconnect with a "you Spotify account is being used.." Yada yada.

 

How have you guys not replicated this issue?

 

Many thanks.

PinballFreak
Regular

Pixel 2XL Android 9

Spotify 8.5.23.686

Chromecast Audio

 

Been having this problem for almost a year. Anything played from Library will not connect to Chromecast Audio (the connection beep is heard, but status remains Connecting...)

 

The disconnection also happens randomly, when I'm not even near my phone, the music will stop and I will get the "the music has stopped as your Spotify account is being used on another device" message. 

 

Sometimes when I can miraculously connect, simply skipping to the next track will also disconnect and give me that awful "other device" message.

 

This makes Spotify completely unusable. I use the app exclusively with my Chromecast Audio units. I know this is a Spotify issue as other apps have no problem connecting. 

 

Spotify, please please fix this, if we have your attention, please do not let this issue go uncorrected.

vittau
Regular

Same problem, already tried reinstalling the app.

 

Phone: Xiaomi Redmi Note 7;

Spotify: 8.5.23.686;

External device: Chromecast Audio;

Song: Whenever a play a song from one of my saved artists page. If I play from the playlists page it works.

MartinNZ
Regular

@Peter It is encouranging this issue has now received some attention. It needs it. An early resolution is desirable.

 

Android version:  9 - baseband version g955fxxu5dsfb August 2019 security patch

Handset: Samsung Galaxy s8+

Spotify version: 8.5.23.686

Subscription: Premium - Family

Connecting to: Chromecast audio devices version 1.42.172094. i have 2 neither will connect as of almost 2 weeks ago 

 

Clean reinstall made no difference which is frustrating as the stock answer seems to be oh just reinstall it. Didn't work. Time I'll never get back.

 

On occasion some will play, for example. Release Radar Playlist plays (which is also downloaded). As soon as i select a downloaded album the message says "the music has stopped as your spotify account is being used on a different device" and it reverts to playing on "this phone. An example of one downloaded Album that wont play is FSOE 615 - Future Sound of Egypt Episode 615 - Aly & Fila

 

When attempting to connect the connection "bleep" is heard and connecting displays on handset. Then reverts back to playing on phone. Other apps seem to cast just fine.

 

I can also confirm this "seems" to be library related and specifically with chromecast devices. I download my favourite albums to use in my car via bluetooth, which is working without any problems. Casting to chromecast is however completely broken, even with reinstall, restarting all devices etc. It does appear to be build 686 related.

 

Other apps cast just fine without issue which leads me to beleive it's a spotify issue. was first noticed around 9 Sept. Which I beleive is when the 686 build was released on play store.

 

borrie51
Casual Listener

Hi,

 

Back again. Started Spotify this morning. Same problem again, trying to connect to my chromecast, beep, silence :-(.

So, deleted the album (I was playing an album from the library, not downloaded, on my S6 Android) using my desktop, searched the album again on my mobile, started playing an it works fine. Build 686. 

Moderator
Moderator
Status changed to: Under investigation

Hey folks,

Thanks for reporting this issue to us.

We’ve passed your info on to the relevant team, who are currently looking into it.

If you’re experiencing this issue, make sure to click + VOTE.

Could you make sure to provide us with the following info, if you haven’t already:

  • device + OS version
  • exact Spotify version
  • any other info relevant to the issue?

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.

JackHyde
Visitor

@Peter, I'm glad this is getting done attention because it had gotten so much worse over the past couple of weeks. 

Device: AT&T Galaxy S9 on current update of Android 9 with August 1 security patch

Spotify Version: 8.5.23.686

External Device: Chromecast Audio, Chromecast, Roku Ultra (direct), and groups of home smart speakers; all devices current on updates

It seems to be more time dependant than song dependant. I will have short periods of time when casting over wifi will work but then it will stop working at any time. I can still use wifi to control receiver and cast YouTube during these times, so not a wifi or casting issue. Sometimes my wife can also cast Spotify while mine isn't working, but she has had down times as well. It seems to be the worst during what may be peak hours (evenings after work, during dinner, weekend mornings, etc.), but that may just be that I notice it because I want to use it at home then. The other evening, on top of not connecting, Spotify would not display any of my online casting devices that didn't have Spotify direct. The cast devices will give the audible cue that they are connect, but a connection is never established. I have far more down times where I can't cast than I have times that it works. This started to become much worse starting a few weeks ago around the time there was an update that caused Spotify on my phone to lose connection with all downloaded offline songs. I performed the disconnect offline devices step and uninstalled/reinstalled the app. After doing this and redownloading all of my music, the problem has persisted.