Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

[Connect] Can't play songs saved to Your Library on Connect devices

Status: Fixed

Hey folks,

 

We’re receiving reports that it's not possible to play certain songs on Connect devices.

 

First, we'd recommend trying a clean reinstall of the app on your device by following the steps here.

 

If after that you’re still experiencing the issue, could you provide us with the following info:

  • device you're connecting from + OS version
  • exact Spotify version
  • external device you're connecting to + version
  • which songs is this happening with?

Once we have that, we will pass it on to the relevant team, who will look further into it.

 

Thanks! Keep us posted 🙂

Hey folks,

Thanks for your patience while we looked into this issue.

We’re happy to say that this should now be fixed for everyone!

 

Make sure you to perform a clean reinstall of the app to ensure the changes are reflected in the app.

 

Thanks!

Comments
arc1969

@SuperrCoco .    I considered Deezer, but ruled them out as they don't have a "High" quality option on the Family plan like Tidal does  (may not be of interest to you).   The Deezer forum has been asking for the option for ages but Deezer don't seem to be doing anything about it (seems a lot like Spotify actually)

 

 

Bullhead242

Echoing the "how is this still an actual problem?"

 

A large part of the reason I purchased a spotify subscription, to begin with, was the ability to stream to several devices around my home. I had been using Google Play's library, which continues to work perfectly, but switching to Spotify gave me more options. I even purchased an additional Chromecast audio to use with a new set of speakers in my bedroom. 

 

And now that I've switched services, spent money on additional devices, and changed my listening habits, it all just stops working, with no sense of the problem, explanation about why it stopped, and no apparent urgency behind addressing the issue I'm running out of reasons why I should continue to pay for a service that absolutely does not deliver what it's promised. 

 

From my perspective, this is a pretty massive failure and it seems I'm not alone. 

PinballFreak

What is also a massive failure is how uninterested Spotify is in resolving this issue. It's appalling, to be honest.

bxbxbxbx

ėI went online and contacted Spotify directly about thisnfor the second time yesterday, and asked them to refund my latest subscription fee as the havent fixed the issue.

 

The support person dithered around; asked me to tell them about the issue again (I directed them to this thread); asked me TO SEND THEM A VIDEO OF THE ISSUE (!); then disconnected me without resolving the problem. They have not contacted me about it again since.

 

I have had enough. I am moving to Tidal. I will never use Spotify again and will only speak of them in terms of their horrible technical support and atrocious customer service. 

 

This type of behaviour is reminiscent of many businesses who get so big they think that the customer needs them more than they need the customer. 6 months of continued poor service and faulty product; enough is enough. 

 

 

SuperrCoco
You said everything. Nothing more to add.
grosseout

my player won't play certain songs that i;ve played before

PaulMac

Scenario 2 issues for me happening on both Samsung S7 and Hauwwei P30 Pro.

 

Albums saved or downloaded to my library don't respond via Spotify connect that is linked to my Sky Q box. All songs connect OK from playlists whether or not they've been saved to my library.

 

For saved and downloads albums that won't play via Spotify connect I need to click on the 3 dots then select 'view album'. At that point they play ok

 

Would be great if this could be fixed 🙂 

nifkin

Come on @Peter: the same issue across multiple  and makes of  phone and Spotify Connect device. Please can you get this fixed. 

schmil42

Nvm, deleting my previous comment as still not working. Back to Sonos app it goes... 😞

e95jn

I am having this problem on all my devices quit some time. I have used at least 3 Android device with different OS versions all behaving the same.

 

I can play music from playlists that are added to my library no matter if it is downloaded or not. I cannot play albums via Chromecast unless I manually add them to the play cue. On Spotify connect device I am able to play one song from albums without adding them to the cue but the next song of the album will not play (unless I add i to the cue).

 

I believe this problem is much more common than looking at the Votes here. You have already had the time you need to solve this problem and I do not believe you need more bug reports. You already know the problem and your software team are able to recreate it. Your are simply not putting resources on solving it which is sad!