Help Wizard

Step 1


[Connect] Can't play songs saved to Your Library on Connect devices

Hey folks,


We’re receiving reports that it's not possible to play certain songs on Connect devices.


First, we'd recommend trying a clean reinstall of the app on your device by following the steps here.


If after that you’re still experiencing the issue, could you provide us with the following info:

  • device you're connecting from + OS version
  • exact Spotify version
  • external device you're connecting to + version
  • which songs is this happening with?

Once we have that, we will pass it on to the relevant team, who will look further into it.


Thanks! Keep us posted 🙂

Hey folks,

Thanks for your patience while we looked into this issue.

We’re happy to say that this should now be fixed for everyone!


Make sure you to perform a clean reinstall of the app to ensure the changes are reflected in the app.





Same issue here,  been happening for days, sometimes an album can't be cast from my library (keeps on "connecting") but going to the album page and casting from there works perfect.


  • device you're connecting from + OS version
    • Xiaomi MI6 - MIUI Global 10.4.1
  • exact Spotify version
    • Spotify version
  • external device you're connecting to + version
    • Chromecast Audio (version 1.42.172094)
  • which songs is this happening with?
    • Not specific songs, just some albums I try to cast from library. Playlists work fine, also searching from general search works fine.



I've been talking to SpotifyCares on Facebook wasting a lot of time as they are completely useless. Really is one of the worst customer support experiences I've had.


Anyways I've boiled at least my problem down to this:


* Casting any song from my library doesn't work on Android.

* Applies both trying to cast to Chromecast as well as casting to Spotify desktop from the Android app

* Casting songs not in the library works

* Uninstall, remove offline devices, reinstall (or logout, remove offline devices, login) temporarily fixes the issue, but it comes back again

* Casting from web player does not have this issue or at least I've not been able to reproduce it there


Would wish Spotify engineering team was a bit more involved here and give some status.


Personally, I'm seconds away to switching to YouTube Music. Hey, for a family account it's 15% cheaper and does the same thing except Google seems to have managed to implement casting reliably.


Nokia 6.1, Android 9


Chromecast 1.36.159268

Unable to play (certain) Albums


Please take more care on quality after every sprint, it's devOPS, not only dev.


Casting from web player or desktop works without any issues. Casting from library on Android doesn't work to Chromecast, web or desktop. Funny thing is if I start on desktop/web cast to phone, then cast from phone to Chromecast it works.


This morning I did a clean reinstall Spotify on my Win10 laptop and Samsung S7 phone running Android 8.0.0. The problem is still there. On the webplayer it works without a problem.


Then I tried to this to test it: 

  1. I tried to play this album from my library:
  2. The first song played, but it stopped after that song, and it was impossible to make it play the next song.
  3. Then I removed the album from my library
  4. Then I tried to play the first song again. It finished .... and ..... it went on to play the next song without a problem!

Spotify: Get your s**t together - this is NOT what I am paying for! This make me feel I am playing something from the net in 2001, not 2019!




just about everything described in this thread applies to me as well:


  • Uninstalled & wiped all data and settings, reinstalled, did not fix the issue
  • Difficulties connecting my Android device to Chromecast -- it may connect and play initially, but disconnects without any explanation when I switch to another song and refuses to reconnect to the device after that
  • Searching individual song with the search function, hitting play (plays on the phone) and then connecting to a device seems to work
  • I get the sense that the albums being/not being in my library somehow alters the behavior
  • I like to add new albums to my library and my primary way of playing music is via the library / albums -view -- I look for the album I want and select a track from it


Here's my gear:

  • Oneplus 6T, OxygenOS 9.0.16
  • Spotify
  • Chromecast Audio, Cast firmware version 1.42.172094


In it's current state Spotify is so annoying with Chromecast that it's practically unusable. Please fix soonish or I have to switch over to some other service.


Best regards,


Antti Siiskonen


Spotify :686 version

Pixel 3 on Android 10 and Huawei 10 Tablet Android 9

Using Chromecast Audio / Home Mini


I am paying since years but can't listen anymore to my loudspeakers. 

From any device it is not connecting. If i deinstall spotify, start my device and reinstall spotify it works once. Sometimes, sometimes still not connecting.

Telling Home mini to play over Spotify works. Not from Phone/Tablet. 

I alos wondered why Album Songs just stopping playing after the first song. I can not listen to albums, that i noticed sometimes. 

If i get it working for one music session the day after it will not connect again. 


Currently i am listening over HOME via BT streaming from phone to chromecast audio.... Terrible qlty...   





  • Samsung S9+, Android 9
  • Spotify
  • Streaming to Google Speaker and also YAMAHA Home Theater and Sony Android TV all failed. Can't know their version.
  • Songs can't streaming: too many, sometimes random

Already tried delete cache, remove download songs, uninstall/ reinstall Spotify on phone but still doesn't work.

Sometimes stream successfully but phone and other device will play the song at the same time, latter Google Spearker will say "sorry Spotify being played in other device" or YAMAHA home theater will stopped after the song is played. Sony TV only shows Spotify Logo screen but doesn't work at all.


Select target streaming device from the app will show "connecting" but never connect.


Use voice command to ask Google Speaker to play the same song will work.


See also my post from yesterday


Today i got the update - the problem still exists in this version too.