Announcements
We’re experiencing issues with Premium subscriptions and redeeming gift Cards. This is being actively investigated. Subscribe to this thread here for updates.

[Connect] “Listen on other device” not working on iOS 14

Tried every single suggestion listed so far and nothing has helped.

 

That said, I have more data that might help the debug.

 

1) All iOS (2 iphones and 1 ipad) devices in my house have the same problem connecting to local speakers

2) Both accounts on my duo account have the issue

3) My desktop spotify app works fine, which is also on the home network (futhermore this being an IOS problem)

4) When my desktop app plays something, then the local speakers actually show up on the iOS devices.  Then eventually vanish.

Hi folks,

 

Thanks for your comments with the requested details. 

 

We've reported this with the right teams so that they can take a closer look.

 

If you're also experiencing troubles to connect to devices in the same network on an iOS 14 device, make sure to add your +VOTE if you haven't already to this Ongoing Issue.

 

We'd first recommend trying some basic troubleshooting:

  • A thorough app reinstallation
  • Switch both your devices to a different network (both will need to be on the same)
  • Double-check if the issue occurs when both devices are connected to the home wifi network (making sure no device is connected through hotspot).
  • Your devices are running the latest software versions and Spotify version available
  • Try toggling on/off Show local devices only from the app's Settings > Devices

If after that you’re still having trouble, could you provide us with the following info:

  • Device + exact operating system version 
  • Exact Spotify version
  • Type, brand and model of the speakers or device that you're trying to Connect
  • Are you seeing Spotify listed in your device's Privacy > Local Network settings?
  • Troubleshooting steps you've tried so far
  • Any additional helpful details, like a screenshot or recording of what's happening - just make sure that there's no private or sensitive info displayed

We'll keep you updated here so we'd also recommend subscribing to this thread to stay up to speed.

 

Thanks!

Comments
thebestmix
Newbie

Plan

Premium

Country

USA

Device

iPhone 7 Plus

Operating System

iOS 14

 

Prior to updating to iOS 14, I enjoyed the ability to use my iPhone as a “remote” to control the Spotify app on my LG TV (WebOS).  I would connect my TV to my iPhone’s mobile hotspot via WiFi, then start playing a song on my iPhone and choose which device I wanted it to play on, and it would work flawlessly.

 

Currently, there are no other devices that show up when I try to do this, and when I select “Open Settings” on the page in the Spotify app where my TV should be showing up, “local network” is not among the selections that I can “allow Spotify to access”.

 

When I go to “Privacy - Local Network” in iOS, Spotify is not listed with “Apps that have requested permission”.

 

Your help is appreciated, as using the app to control my TV which is connected to my sound system is so much easier than navigating the Spotify app on my TV with my TV remote.

Hubo
Rock Star 16
Rock Star 16

Hey @thebestmix, the calvary's here!


Let's get you back listening on your speakers! Alright, could you try to log out and log back in on the Spotify app? That might help here. If that didn't help, could you send over a screenshot of what the settings for the Spotify app look like? I'd love to get to the bottom of this! 💫

 

Have a good one,

Hubo

thebestmix
Newbie

Thank you for your reply.

 

I logged out, then back in on both my iPhone and my TV, and it still doesn’t work.  I can’t attach a screenshot from my phone because it says “file type .jpeg is not supported” and I don’t know how to change the type of file it creates when I take a screenshot.

 

The only options on the Spotify settings menu are:

 

Microphone

Siri & Search

Notifications

Background App Refresh

Cellular Data

 

If you can tell me how to work around the file type error, I’ll be glad to attach a screenshot.

Hubo
Rock Star 16
Rock Star 16

Hey @thebestmix, thanks for keeping me posted!

No worries, that's all the information I need! Could you try a quick reinstall of the Spotify app with these steps? That might help here. Let me know if you get the Local Network option after that!

 

Hope you're having a great day! 💫

thebestmix
Newbie

Thank you for your suggestion. Unfortunately, even after uninstalling and reinstalling the app, all of the options are the same. 

carlks
Newbie

Same issue here on iOS 14 with all of my Sonos speakers. Can't do Spotify Connect so I have to do AirPlay for now.

chiguire
Newbie

Tried to uninstall and reinstall the app as instructed here, no luck. There's a button that I suppose tries to invoke the permission dialog, but it just redirects me to the settings. Spotify does not appear in the list of Privacy -> Local Network

Hubo
Rock Star 16
Rock Star 16

Hey everyone! Thanks for getting back to me here!

I'd like to get to the bottom of this. Could you guys try to login with another account and see if that makes the 'Local Network'-permission appear? Also, does the same thing happen on other devices (e.g. from family) Keep me posted!

Have a good one,

Hubo

thebestmix
Newbie

Unfortunately I only have one Spotify account, so I can’t run that test.  I did try opening Spotify on my laptop and using my iPhone as a remote to see if it was just related to my LG TV, but I still have the same issue. 

I strongly suspect that there is a glitch in the iPhone app where it does not address the new iOS “Local Network” requirements.

Niggla
Visitor

Same here. Worked fine before last iOS update.

Have tried turning network permissions on and off, but makes no difference.

 

It’s like Spotify or iOS isn’t paying attention to the network settings.

 

I now have to use the Sonos app to play Spotify, but the experience is not as good and I can’t use my Apple Watch to control what I am playing, which is exactly what I used to do.

 

 Can Spotify or Apple please fix this