[Connect] “Listen on other device” not working on iOS 14

Tried every single suggestion listed so far and nothing has helped.


That said, I have more data that might help the debug.


1) All iOS (2 iphones and 1 ipad) devices in my house have the same problem connecting to local speakers

2) Both accounts on my duo account have the issue

3) My desktop spotify app works fine, which is also on the home network (futhermore this being an IOS problem)

4) When my desktop app plays something, then the local speakers actually show up on the iOS devices.  Then eventually vanish.

Hi folks,


Thanks for your comments with the requested details. 


We've reported this with the right teams so that they can take a closer look.


If you're also experiencing troubles to connect to devices in the same network on an iOS 14 device, make sure to add your +VOTE if you haven't already to this Ongoing Issue.


We'd first recommend trying some basic troubleshooting:

  • A thorough app reinstallation
  • Switch both your devices to a different network (both will need to be on the same)
  • Double-check if the issue occurs when both devices are connected to the home wifi network (making sure no device is connected through hotspot).
  • Your devices are running the latest software versions and Spotify version available
  • Try toggling on/off Show local devices only from the app's Settings > Devices

If after that you’re still having trouble, could you provide us with the following info:

  • Device + exact operating system version 
  • Exact Spotify version
  • Type, brand and model of the speakers or device that you're trying to Connect
  • Are you seeing Spotify listed in your device's Privacy > Local Network settings?
  • Troubleshooting steps you've tried so far
  • Any additional helpful details, like a screenshot or recording of what's happening - just make sure that there's no private or sensitive info displayed

We'll keep you updated here so we'd also recommend subscribing to this thread to stay up to speed.




All of my devices have been connecting via mobile hotspot from the beginning. It worked perfectly until iOS 14.


I get excited every time I see a pending Spotify update hoping it will fix the issue, but so far it has not.


Hi @thebestmix,


Thanks for the reply!


In that case, can you tell us if you can try connecting to another network, to see if the issue comes from the general connectivity or the hotspot itself?




Hi, I had the same issue and the proposed steps didn’t quite solve it even after reinstalling Spotify several times until I turned off and on my iPhone as part of the process.


After following the below steps in order, Spotify was able to see my Sonos speakers.


1.- Log out from Spotify.

2.- Uninstall Spotify.

3.- Turn off iPhone.

4.- Turn iPhone back on.

5.- Install Spotify and Log in.

6.- Go to settings within Spotify and enable Local Files.

7.- Accept Local Network permissions pop up.


If you already had the Local Files option enabled and still didn’t get the Local Network permissions pop up, I guess you might want to trying disabling it and following the steps I mentioned above to see if that helps.


Not applicable

Same issues here. The devices menu on iOS 14.2 on my iPhone 12 Pro does what it wants. Switching to complete other devices than the tapped one, switching back playback to iPhone is completely broken.


The iPad app (iPadOS 14.2) and the mac app (macOS 11) are working smooth as expected and the iOS App did until iOS 14. Network Access is allowed.

Spotify, please fix this. Reinstallting the app and blank new setup of the iPhone did not solve the issues.


Thanks in advance.

Rock Star 16
Rock Star 16

Hey @user-removed, thanks for letting me know about this!


Let's dive a bit further into this. Could you send over a screen recording of what's happening here? Also, what is the exact version of Spotify you're using? Keep me posted!


Have a great day,


Not applicable


I have a screen recording attached here

But you won't see many of my unsuccessful attempts to click on a device, because the app just doesn't react at all. App version is






Hi there @user-removed,


Thanks for the video and the info.


Have you tried what @nachbecerra had suggested above? 


Let us know if that works for your.

Not applicable

Hi Alex,

yes of course, I tried also these steps. No success.

Regards Mathias


Hey @user-removed,

Thanks for the quick reply.


Can you try connecting your phone and some of the other smart devices to a Mobile hotspot and check whether you can switch between devices then?


If that doesn't make a difference, try creating a new test account with another email address and play some tunes from there. This will help us determine if the issue is account related.


We need to go through these troubleshooting steps to exhaust all possible solutions, since this is something affecting only a portion of iPhone users and we weren't able to reproduce it on our side so far.


We'll be on the lookout for your reply 🙂

Not applicable


thanks for your reply.

I have now tested two more scenarios:

Switch from WiFi to 5G - No success, same behaviour of the device menu

Created a new account **bleep** and switched the devices - No success, same behaviour of the device menu