[Connect] “Listen on other device” not working on iOS 14

Status: Fixed

Tried every single suggestion listed so far and nothing has helped.

 

That said, I have more data that might help the debug.

 

1) All iOS (2 iphones and 1 ipad) devices in my house have the same problem connecting to local speakers

2) Both accounts on my duo account have the issue

3) My desktop spotify app works fine, which is also on the home network (futhermore this being an IOS problem)

4) When my desktop app plays something, then the local speakers actually show up on the iOS devices.  Then eventually vanish.

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to see that the original issue reported in this thread seems be fixed, judging by your reports. Just make sure your app and your OS is updated to the latest version.

 

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks!

Comments
Niggla

Have played a little more with this and noticed a truplay update for my Play:1 speaker which I have done.

 

Not sure that made any difference.

 

But what I have noticed is that sometimes for a split second some of my other network devices are listed and then quickly disappear including my Denon AV amplifier and my Google speaker within the device list in the Spotify app.

 

Weirdly my echo dot is always listed 

 

If I choose to use Bluetooth or AirPlay my Denon AV amplifier is listed along with my Apple TV.

 

So why does the Spotify app briefly see some of my network devices?

 

Got to be a glitch with how the app is taking to iOS 

Hubo

Hey all!

 

Thanks for keeping me posted here. This information is very useful to get to the bottom of the issue here. Could you all let me know the following as well:

  • Spotify app version
  • iOS version
  • A screenshot of the options Spotify in the Settings app (Settings > Spotify)

That helps the right folks take a closer look at this issue.

 

Thanks for bearing with me here, have a good one!

Hubo

thebestmix

My Spotify version is 8.5.78.928, iOS version 14.0.

carlks

Spotify version 8.5.78

iOS: 14.0.1

 

I have the "Local Network" setting on for Spotify. It is working since I can see Google Cast devices and my PC (running spotify). Only Spotify connect for my Sonos devices are not working.

chiguire

After updating to iOS 14.0.1 Spotify properly displayed the dialog to allow the app to access the local network.

Hubo

Hey all! Thanks for keeping me posted here!

It sounds like iOS 14.0.1 has fixed this issue for a few folks. Could you guys try to update to iOS 14.0.1 and see if that fixes it for you? Let me know if that works!

Thanks, have a good one,

Hubo

thebestmix

I updated to 14.0.1 today, but unfortunately it is still not displaying the local network permission dialogue.

Niggla

I was already on 14.0.1 iOS and it wasn’t working.

 

However; as of yesterday all back to normal and working as expected.

 

App version I have is 8.5.78.928

 

So happy this is working again!  I can now see all network devices listed including my Sonos speaker 

carlks

Can you share the step you did to get it to work? I’m on the latest iOS and Spotify app. I have the local network setting on but none of Sonos are showing up. 

thanks!

Hubo

Hey @thebestmix, thanks for keeping me in loop!

 

Let's see, could you try to reinstall the Spotify app once more, now that you've updated your iOS version? Let me know if the setting appears after that.

 

Have a good one,

Hubo