[Connect] “Listen on other device” not working on iOS 14

Status: Fixed

Tried every single suggestion listed so far and nothing has helped.

 

That said, I have more data that might help the debug.

 

1) All iOS (2 iphones and 1 ipad) devices in my house have the same problem connecting to local speakers

2) Both accounts on my duo account have the issue

3) My desktop spotify app works fine, which is also on the home network (futhermore this being an IOS problem)

4) When my desktop app plays something, then the local speakers actually show up on the iOS devices.  Then eventually vanish.

Hey folks,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to see that the original issue reported in this thread seems be fixed, judging by your reports. Just make sure your app and your OS is updated to the latest version.

 

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks!

Comments
thebestmix

Thank you for the suggestion. I did as you suggested and deleted the app and reinstalled it, but the only prompt I got was regarding notifications.

 

I then opened the app on my TV, but I could not find it in the device menu on my phone app.

 

I have also previously tried to connect to Spotify when it was open on my Roku as well as my Windows laptop, but I could not.

Supersim4
Yeah I’ve reinstalled updated everything to the most it can be and still don’t have the extra volume slider
coy

spotify.jpgweeks with the issue of IOS 14 doesn't see yamaha Spotify connect, event uninstalling wit all steps didn't work.

Definitively issue its IOS privacy local network functionality

I got work closing the session of my user , sig in again and finally iphone ask me Spotify want to access local network, accept allow and problem was finally resolved.  

thebestmix

I agree that it is an iOS 14 privacy settings issue.  


Unfortunately, I have tried everything including uninstalling and reinstalling Spotify after updating to iOS 14.0.1, as well as logging out then back in, but nothing I have done results in the app prompting for local network permissions.

 

It is a shame because I really enjoyed the ability to queue songs on my app and have them play on my TV over my sound system. It’s a whole lot easier than using the buttons on my TV remote.  

 

Hopefully someone at Spotify will see this soon and be able to figure out what is going on.

Andermatt
Hi
I did have the same issue. No improvements after updating IOS and re-installing spotify.
Luckily the old trick - turn the phone off and on again - helped. I got the pop up asking for permission.
Hope this helps.
Hubo

Hey all!

 

Thanks for keeping me posted! Let’s see what I can suggest. If you have the latest iOS version, tried to reinstall the Spotify app and still don’t see the Local Network option, could you let me know the exact iOS and Spotify versions you’re using?

 

Let me know!

 

Have a good one,

Hubo

Chuck-25
Hi, exactly the same problem for me with iOS 14, spotify connect on Sonos speakers
Decaf2

Same issue here. Only see airplay and Bluetooth devices. Used to see my Sony receiver and Echos. Tried reinstalling Spotify. Tried Restating phone. Ask tried toggling local network access. Nothing worked. Clearly a problem between Spotify and the new iOS network privacy settings. Please fix this!

 

iOS14.2

Spotify 8.5.83.1426

 

 

chrissibunni

Same issue here too! Before the recent iOS update my iPhone (XR) was working just fine serving as a (remote) control for my iPad when I play Spotify. After the installation of the update, the iPhone no longer function as the remote! So I have to now control the music from my iPad 😞

iOS: 14.2
Spotify: 8.5.85. 836

Alex

Hi there folks, 

 

Thanks for sharing your info with the Community!

 

Could you try connecting your devices to a different network? If you mobile data plan allows it, start a Mobile hotspot and connect your devices to it. 

 

Let me know if you can see them in the Connect menu this way.

 

Cheers.