Connect doesn't work on Naim Uniti2

Status: Fixed

Connect doesn't work on my Naim Uniti2 streamer. I have a Family Premium account. Works fine on Ipad, Android, iMAC - but not on my Naim Uniti2.

After de-activation and re-activation of Spotify source on the Uniti I got error message "Cannot connect to Spotify Server". If I reset the Uniti to factory settings that message doesn't appear but App can't connect to the Uniti. In the App you can see Uniti in device menu but connecting always fails without any error message.

Reset of streamer, router, Ipad hasn't solved the issue.


Any advice welcome

Thanks for letting us know @SteveBi


We're glad you were able to sort things out. Give us a shout whenever you need help 🙂 


Take care.

Status changed to: Fixed

Hi @SteveBi! Thanks for writing on the Community.


Can you let us know the operating system and Spotify version of your device? I'd also be really helpful if you could send us the firmware version of your reciever.


We'll see what we can suggest.


I'm using Spotify App version on my Ipad with iOS 10.1.1.

My Naim Uniti2 runs
- Firmware 4.4.00
- BSL-Version 2.3.0
- 3D APP 13731.68
- 3D BSL 2559.2
- 3D CNE 13731.68

Two days ago I could manage to run Spotify on the Uniti after re-installation of firmware on the streamer.
Worked for one day only - then the same error occurred again:
1. Streamer shows error "can't connect to Spotify server"
Tried following: switched streamer on and off - no success; de-activated and re-activated source in streamer source menu - no success
2. after reset to factory setting streamer shows "Ready - connect Spotify app" - but no connection from app is possible (Spotify app sees streamer but connection attempt fails without any error message)

Hope that helps to find the problem.

Best regards


Thanks for getting back to us with that info @SteveBi


In this case, can you try a different connection? Make sure your device is connected to Internet through Wifi or Ethernet. Then, try one time more. 


Let us know if that makes any difference. We'll be here for you 🙂




Hey @SteveBi!


We haven't heard back from you in a while. Did @Sophia's recommendations help?


Keep us posted. 

Hey all,

finally a change in the DNS settings of my router FritzBox solved the problem.
Original setting in FritzBox was "use assigned server of Internet provider".
I switch to "use other server" and entered the Google DNS addresses:
Preferred Server:
Alternative Server

Best regards

Status changed to: Fixed

Thanks for letting us know @SteveBi


We're glad you were able to sort things out. Give us a shout whenever you need help 🙂 


Take care.


how was this resolved?