Help Wizard

Step 1


Connection Issues for users with the ISP Windstream



I've been trying to get into my Spotify web player on my work PC.  (Work PC - hence the web player and not the desktop app) 

The entire screen shows as white with all of the menu options mashed to the left just under my profile picture.

I have cleared the cache.  I have tried on a few different browsers.  Other co workers do not have the same issue.  Help.


 < thread title updated for clarity >

Hey folks,

Thanks for all the reports.


We can confirm this has now been fixed. 


If anyone's still having trouble, we'd recommend a quick reinstall for the desktop app, or a clearing of browser cache/cookies for the web player. 


Thanks for bearing with us,



I've downloaded the spotify app threw microsoft store, but recently images won't display anymore. I've tried uninstalling and reinstalling, changed my proxy, and some other stuff. Any solutions?



I'm using windows 10


Hey, @MicoWazzle -


Does disabling Hardware Acceleration fix the issue? Go to Edit > Preferences > Compatibility and uncheck Enable hardware acceleration.


Tell me how it goes 🙂



Spotify premium user here. I've also had this issue past 3-4 days. Over my wifi network, no images show up! But if I use the android app over my mobile network, it works just fine.

Even when I try to browse the spotify website, it doesn't display images. I'm also on Windows 10, and I'm not using a proxy. Disabling hardware acceleration made no difference too.


Hey @methodair06


That's weird!


Have you tried deleting cookies as well? Sometimes faulty page information gets saved in cookies.


Let me know what happens! 🙂


Yes sir.  Tried that as well.  No luck.


Across all of my devices Spotify won’t load images, including codes that correspond to sharing a song. Across these devices I am using the same account and I need a fix to this issue. After various attempts to reinstall the application, relogging into the application, and restarting the corresponding device nothing has proven to show substantial results. I humbly ask for help.


I have turned hardware acceleration off and it did not fix the issue.




Another thing I could suggest is wiping the DNS cache. However, this needs you to open Command Prompt with Administrator rights, that's often not really possible at work.

DNS records' lifespan is usually about 24 hours maximum before they get renewed.


However, if you can use Admin rights for Command prompt, do it and enter this

ipconfig /flushdns

and hit Enter.


It's possible to erase DNS cache for browsers too. See this OpenDNS article.


Keep me posted. 🙂


Mine has been like this exactly for the last 5 days.... I can't seem to figure anything out. It works fine on my phone's app for Spotify but not on my Web Player...

I've attached a picture of what it looks like


@Sebasty, I'll see if I can get one of the IT people to help me out.  50/50 shot with that lol.


@Greenteamachine, that's exactly what mine looks like