Cortana doesnt play song requests

Plan

Premium

Country

USA

Device

PC

Operating System

Windows 10

 

My Question or Issue

I didn't have any issues having Cortana to tell Spotify to playback songs in the past. Just recently, on all my Win10 PC's (version 1903) when I tell Cortana to play a song, it identifies the song, then says "And now, playing.... on Spotify", then launches the Spotify UWP app (and even the Win32 version on a couple of my other PCs).. but the app just sits there doing nothing.

It looks like Cortana is sending a playback request to Spotify and even launches the Spotify app... but that's it. I have thrown everything and the kitchen sink at this issue..  It doesn't seem like the issue has anything to do with the Spotify apps. It's either Cortana's back-end service or Spotify's Cortana app link connector.

I already tried everything suggested in the below link:

https://community.spotify.com/t5/Desktop-Windows/Spotify-Doesn-t-Respond-to-Cortana-s-Requests/m-p/4...

 

I even changed my Spotify password.  So... what more do I have to do (besides all the items discussed in the link above)?

 

Hey there folks,

 

We really appreciate your patience so far!

 

As we've mentioned, our tech teams are aware and doing their magic backstage. If you're experiencing issues with Cortana playing a requested song when using a desktop device, we'd suggest adding your +VOTE and subscribing to this thread. 

 

We'll keep you updated if we have any updates regarding a fix to pass on. In the meanwhile, make sure to keep the app updated to the latest version by following the steps here, thanks!

Related Issues

Comments
MKANET2
Casual Listener

Update:  I have tried re-linking Cortana and Spotify on both ends, removing Spotify UWP app completely, changing my Spotify password, rebooting.  ReInstalling Spotify.  My language settings are set for English.  There isn't anything left for me to do.

 

So... how do I fix this?

routinetraffics
Visitor

I've tried about 4 different processes to try to fix this... made a new account even, unlinked everything, reinstalled several times, relinked, reboted, re-installed, relinked again...

Nothing ever works.

The artist I request cortana shows, but never plays... I can control spotify action through saying "cortana stop" "cortana play" but that only works for songs i manually select in spotify.

This is very frustrating given I got used to this functionality, and now nothing I can do will fix it. What is going on spotify?!?

knifeabuser
Casual Listener

Yeah, the same problem, nothing left to do but leave spotify

MKANET2
Casual Listener

Update:  I have some encouraging news.  I just reported this issue with Spotify's tech support.  Since they realized the issue is reproducible, they escalated the issue to their specialty team.  They will contact me after they confirm the issue on their end.  I will post here as soon as I have more news.

Gord2
Visitor

Yeah developers fix this problem!! It would be nice to use Spotify with Cortana!

NukeDukem
Visitor

Same exact problem. Spotify opens, but doesn't play the song at all. Latest Win10 version and latest UWP spotify app that is linked correctly. I've tried reinstalling cortana and spotify to no avail. I hope this gets fixed soon.

MKANET2
Casual Listener

I just emailed the Spotify "specialty team" again requesting a work-around/fix ...and the possibility of getting a monthly credit for all the users that are affected by this issue.  More soon!

mdmanbe
Visitor

Im having this exact problem also - have tried all the fixes online and nothing works, please update us if you hear anything back from your email

 

Many Thanks

purplehaze65
Regular

I'll keep it short

Devs, how hard can it be to find out where "the chain of command" is "broken", doesn't the event log monitor and log Cortanas' "activities"?

And if not, why not, if yes, you might try to check it out

 

If this tip helps you find the cause of this bug and fix the problem, you owe me much more than one lousy month of free premium ;-)

Just messing with you (Devs), but please could you explain why the event log doesn't provide the info you need to fix this annoyance

mkanet
Newbie
Guys, I received a not-so-encouraging response from the Spotify "specialty team". They deliberately ignored my direct question if the developers have already reproduced the issue internally or not. Nor did they answer my question if Spotify devs working with Microsoft developers about this or not. They just gave a generic uncommitted response.

The good news is everyone who has this issue can get a monthly credit until the issue is fixed. Just email: support@spotify.com and refer to the below reference ID (and this forum thread).

ref:_00DD0pxIW._5002o2Dcd8e:ref