Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Crossfade option isn't working on the desktop app.

Status: Fixed

We've received reports that the Crossfade feature isn't working correctly on the desktop app. No matter how many seconds are being added, it won't work and after returning to the settings page, it's set to a random amount of seconds.


Hey everyone,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to inform you that this should now be fixed! Just make sure your app is updated to the latest version.

 

If you still don't see the change, try the following:

  1. Open Spotify, turn the Crossfade off and then restart Spotify.
  2. Turn the Crossfader back on and change the value.

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks!

Comments
zgoessman

Plan - Premium

Country - US

 

Device

iPhone 8

Operating System

Windows 10, etc. 

 

My Question or Issue

Is there a way to add crossfade on your own playlists? I've tried adjusting the advanced settings bar to 8 and it just resets itself to an outrageous negative number or positive number. I've uninstalled and reinstalled the app and it's still the same issue (if it's an actual issue). Any help is appreciated! 

 

 

Alex

Hey @zgoessman,

 

Thanks for reaching out about this in the Community!

 

Crossfade should be to crossfade between songs in your playlists. Normally, you should see a difference if you change the crossfade slider between 0 and 12. Also make sure that the setting "Allow smooth transition between songs in playlist" is also enabled.

 

Can you test if you hear the difference when you set the crossfade slider to 0 and then to 12? This way we can check if the setting is working at all.

 

Also, let us know if crossfade is not working properly on only one device or all your devices.

 

Looking forward to your reply.

 

alexandra_michelle

I started having the same issue recently on the Desktop app for Windows (pictures attached). When I try to set crossfade to 6 seconds and then play through a playlist, the songs do not crossfade at all. When I navigate back to Settings > Show Advanced Settings, crossfade is enabled but there is always a random number instead of the number I selected (281681 seconds, -134523 seconds, 585873 seconds, etc.) 

abigailmmilne

I am also experiencing the same issue on my desktop and iPad. Each time I try to set the crossfade, it pops back to an outrageous number. What is the solve for locking the time chosen between 0-12 seconds?

zgoessman

Hi Alex, 

 

Thank you so much for your reply back here! I can confirm that the crossfade works on my iphone ios device and just not on my desktop (currently the latest windows). It just resets itself when I try to move the crossfade bar when exiting the advance settings. When testing it as well, it's clear that it didn't update when listening to my playlist. Thank you! 

zgoessman
Exactly the same issue here. Thank you for the example @alexandra_michelle !
pjPug

Crossfade stopped working less than a week ago.

 

When I try to set it to 6 seconds (or whatever) and leave the Settings page, then go back to Settings, the value has mysteriously changed from 6 seconds to some random large number like 111196, sometimes negative, sometimes positive. When I play a playlist, it behaves as if the setting is turned off.

 

Windows 11

Spotify version:
1.1.79.763.gc2965cdf

 

Crossfade works correctly on my Galaxy 7 Android phone.

Nyx_Xaos

Same issue here, as reported in another thread! https://community.spotify.com/t5/Desktop-Windows/Crossfade-Broken/td-p/5345707

 

 

RadioD-Ave

Spotify for Windows
1.1.79.763.gc2965cdf

 

THIS IS REAL. Also true on Windows Desktop. Please fix, thanx, it won't fix itself. T e last update broke it (above version).

RadioD-Ave

edit for my other post (sorry): Windows 10 Desktop too, not just 11. Thanks