Announcements

Crossfade option isn't working on the desktop app.

Status: Fixed

We've received reports that the Crossfade feature isn't working correctly on the desktop app. No matter how many seconds are being added, it won't work and after returning to the settings page, it's set to a random amount of seconds.


Hey everyone,

 

Thanks for your patience while we looked into this issue.

 

We’re happy to inform you that this should now be fixed! Just make sure your app is updated to the latest version.

 

If you still don't see the change, try the following:

  1. Open Spotify, turn the Crossfade off and then restart Spotify.
  2. Turn the Crossfader back on and change the value.

If you're still having trouble, make sure to post a new thread in the relevant help board here.

 

Thanks!

Comments
Fishies1

Setting the playback to 12 seconds is working for me, and another user as well @Alex 

 

Plan: Premium

Country: Canada

 

Device: Macbook Pro 14-inch 2021

Operating System: macOS 12.2.1

Spotify Version: 

Spotify for macOS (Apple Silicon)
1.1.79.763.gc2965cdf

 

I tried modifying my crossfade amount today from 8 to 9 seconds in my settings and then it didn't work when I played music. Upon return to my settings I saw the crossfade was -74553 seconds.

 

I would turn off crossfade and back on, and the number would stay at 9 seconds, but as soon as I close the advanced settings tab or go back to my music, it would reset to another huge number like -1843424 seconds.

 

Playback and crossfade only seems to work on my iPhone running spotify but not on my laptop. This happened to another friend in the situation, we rely on playback for building playlists for fitness classes.

 

Things I have tried:

  1. Downgrade to the last released version of Spotify (I was on the current version when this started)
  2. Restart Spotify
  3. Restart Macbook

 

I haven't tried clearing the cache yet or doing a more full reset than what I listed above.

 

Screen Shot 2022-02-21 at 9.14.25 PM.png
Kiril
Status changed to: Under investigation

Hey folks,

 

Thanks for reporting this issue to us.

 

We’ve passed your info on to the relevant team, who are currently looking into it.

 

If you’re experiencing this issue, make sure to click +VOTE and Subscribe to the thread to be notified of any developments.

 

Could you also make sure to provide us with the following info, if you haven’t already:

  • device + operating system version
  • exact Spotify version

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.

Scooterman5

Crossfade option isn’t working on my Windows based desktop app just started the past several days you can change the setting from 0 to 12 seconds but then as soon as you exit out of it it reverts back to some crazy long negative number. I logged out and log back in uninstalled the app and reinstalled it and while intermittently it seems to work on certain playlists it always reverts back to the negative number and won’t consistently work for me at all. 

nicknf123

This happened to me last night too!! It was really frustrating. I tried restarting my mac, un-installing Spotify, and re-installing Spotify...nothing worked. I had to play the music from my phone, in which the crossfade worked. 

chan_robertson

My entire studio uses crossfades for our workout classes 5x a day and it stopped working for all of us over the weekend. No amount of installing/uninstalling, rebooting helps. Just resets to an insane positive or negative number and has no crossfade. Please help!

Fishies1

Hey @chan_robertson,

 

Try the work-around of using a mobile device to actually play the music. As long as that's plugged in and playing, you can use your laptop as a remote to change songs, fast-forward/rewind etc. and the playback function should work via iPhone/Android. That's the experience my studio has had thus far. It worked just fine for me this morning in my class.

Just make sure not to start your playlist via laptop because then it won't work.

chan_robertson

@Fishies1 - Thanks for that! I'm glad there is a temporary workaround for now, but I would still like for something as simple as the crossfade to work correctly. We have a robust sound system that we run off a desktop and is much easier  for us than everyone using our phones. I'll let my team know about this in the meantime, but hoping Spotify can fix it sooner than later!

Fishies1

@chan_robertson Agreed, let's hope it gets resolved quickly. Seems like already a good amount of traction and it's affecting many users.

Kate_Schwartzkopf

I work for a World Wide Indoor Cycling Brand where all of our studios utilize Spotify to curate our playlists for class. This has been an ongoing issue since last week 2/15/22. Same as everyone else is saying I set our crossfade to a number let's say "12 seconds" then I go to play the songs and there is no crossfade, I click back into advanced settings and there is a long negative number like "-0343058305803". I have tried speaking with @SpotifyCares on twitter and they have said "our team is investigating' there seems to be no end in site and this directly impacts our business as our classes rely on this crossfade so there is not an awkward silence between songs. I've been a loyal Spotify Premium user for years and currently have a Family account with 6 users the lack of answers is almost as deafening as the awkward silence between songs.😡

 

Crossfade set to 12 seconds in advanced settings.Crossfade set to 12 seconds in advanced settings.Crossfade automatically changes to this.Crossfade automatically changes to this.

RadioD-Ave
In the interim (I'm sure they'll fix this when they figure it out), I have
found that if I set crossfade to 12, then toggle crossfade off and back on
again, that is stays at 12 seconds. No other setting works, in my brief
experiment.