Help Wizard

Step 1


Daily Mix doesn't remove an artist

hello there, I've repeatedly pressed the "remove this artist from your mix" when listening to my daily mix, yet it never does. I always get the confirmation of "Your mix is now free of Gucci Mane." 


However, I keep noticing that his music still shows up in my mix. This has been going on for a little bit now, and it's not a super big deal, but it's still annoying to have to dislike his music every single time, and also that it just never gets rid of his music. a fix would be nice, for this is quite annoying

Hey folks, 


Thanks for bearing with us. We can confirm this is currently expected behaviour for Daily Mix. 


Selecting Don't play [artist name] should exclude the artist from your Mix, but it won't exclude releases which feature another artist.


For example, you could ask your Daily Mix to not play songs by Artist 1, but a release from Artist 1 ft. Artist 2 will still be eligible for your Mix. 


We hope this clears up any confusion! 


I also have this, or similar issue: if I remove a song or artist ahead of time in the daily mix list, by the time I get to that part of the list, the song has come back. It happens more often than not, possibly every time.


I am having the same issue. My account must have been hacked, because my daily mix 1 is filled with Russian techno artists that I never listen to and I can’t get rid of it. Talked to a representative via online chat and they reset my account to 6 months ago (before the hack) and the artists are still making up my entire daily mix 1 playlist. It is impossible to delete them. 

This is so frustrating. I'll continue to push them into helping us.

Now my problem is Mix 1 seems ok, but the other mixes are still polluted with the hackers preferences. Why's this?


Now my MIX 1 seems clean, but the others are still weird hacker-mixes.


Try log out and log in 



Hey folks,


Sorry for the delay in getting back to you.

@Gizbar and @Mikus8806 - if you're experiencing this issue after you believe someone else has accessed your account, we'd initially recommend making sure you've checked out the FAQ page here, for the next steps we'd recommend taking. This is to be sure your account's secure.


Your Daily Mix evolves gradually with your listening, but a particular mix will display a fresh queue of tracks within a day of when you last listened to it. If you're still seeing tracks in there from when your account was accessed, to DISLIKE a track, then click/tap in the Now Playing view while it plays so it won’t crop up in your mix again. You’ll also get the option to remove all songs by that artist from your mixes, so please make sure you're also tapping this.


If you're then having the same issue as outlined here - where 'Don't play this artist' isn't working, can we please check:
- Does that artist itself still come up after banning, or is it only collab tracks with the artist you're seeing?

- Does reinstalling help:

If we could gather this info from anyone experiencing this, we'd really appreciate it 🙂

Apologies for all the info here, but we'd just like to make sure we're able to help everyone the best we can 🙂

Our tech folks are still looking into things, and we'll pass your reports along to them - so please do get back to us with this info!




Hi all,


We're just bumping this thread to request info from those who're still experiencing the issue outlined in the original post, here.


If you're still noticing 'Don't play this artist' not working for you, let us know:

- Does that artist itself still come up after banning, or is it only collab tracks with the artist you're seeing?

- Does reinstalling help?


Once we have that, we'll pass it onto the devs, who can investigate further 🙂

Hi there.
So after a reinstall, I am still encountering this issue. I'd imagine that
it would cut out collaboration tracks as well, but in this case it was a
song by an artist himself. I have removed song's by Zaytoven before, and
right before I started to write this, I ran into one of his songs on my
Daily Mix 1.
Hope this helps out!