[Desktop] Gapless Playback and Crossfade Broken

Thread652210651942624336652790

Status: Under Investigation 

Description:

Multiple reports of gapless playback and crossfade not working on Desktop version 0.9.7.16.g4b197456

 

To reproduce:

  1. Start Spotify
  2. Play a playlist with gapless playback enabled (crossfade off). Reports gapless playback does not happen. 
  3. Play a playlist with crossfade enabled. Reports crossfading does not happen.

 

Workaround:

It has been suggested this issue only occurs with gapless playback on and crossfade set to 12 seconds. If this is the case reducing crossfade to below 12 seconds and restarting the client may fix it. 

 

Additional information:

Crossfade (and gapless) may not function correctly on local files, so when testing please use Spotify tracks. 

 

If you are having either of these issues please can you post below:

-- Version of Spotify you're using
-- Whether the tracks are local files
-- If you are having issues with gapless or crossfade, and your settings for both
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

 

Thanks!

 

Updates:

2014-02-27: This bug should be fixed in v0.9.8 which will be rolling out shortly. (Link to Richard's Post)

 

When posting in this forum please make sure you have read these guidelines.

This was fixed in the 0.9.8 Desktop release. 

Comments
nip3o
Newbie

- Version of Spotify you're using: 0.9.7.16.g4b197456


-- Whether the tracks are local files: No, only streamed tracks.


-- If you are having issues with gapless or crossfade, and your settings for both:

Gapless playback (crossfade not tested). Can be worked-around by opening settings, disabling gapless playback, closing settings, opening settings again, enabling gapless playback. This definitely seems to be an issue of settings not being correctly loaded on start rather than an error with the gapless playback function itself.


-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks):

BT – Skylarking [Mix Cut] - Original Mix

Hazem Beltagui – We Are [Mix Cut] - Original Mix

 

(the same applies to the whole Armin Van Buuren – A State Of Trance 2013 (Mixed Version))

VollStrecker
Newbie

I have the same problem with Version 0.9.7.16.g4b197456
If disable Crossfade and enable it again if will work fine, but after a restart I will get the problem again. Please public an update which fix that issue.

 

mcmanaman2000
Casual Listener

After 53 messages and 38 days, NOBODY gives an answer. Spotify staff, what are you waiting for? We are mostly premium users, and as a pay costumers we deserve a solution that seems, never comes.

kevienfox
Casual Listener

Hi, sometimes crossfade tracks not working, I have to uncheck and check again, sometimes is the same ... not working 😕 you need to fix in the next update

RenseH
Casual Listener

-- Version of Spotify you're using

0.9.7.16.g4b197456


-- Whether the tracks are local files

No


-- If you are having issues with gapless or crossfade, and your settings for both

Mostly crossfade problem.


-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

Yellow Claw – Shotgun - Quintino Remix

Showtek – Booyah - Party Favor Remix

Richard
Roadie

Hey guys, sorry that we've left you hanging for a while here. I'm just popping my head back in to say that we haven't forgotten about this.

 

The fix for this issue should be rolling out soon with the 0.9.8 release (some of you might have been lucky enough to get this already).

 

If you don't have that yet, hang in there! It'll be with you soon.

 

Give us a shout if you have any more questions.

Mattg101
Casual Listener

Great to hear this! Thanks much.

SanyaIV
Music Fan

@Richard wrote:

Hey guys, sorry that we've left you hanging for a while here. I'm just popping my head back in to say that we haven't forgotten about this.

 

The fix for this issue should be rolling out soon with the 0.9.8 release (some of you might have been lucky enough to get this already).

 

If you don't have that yet, hang in there! It'll be with you soon.

 

Give us a shout if you have any more questions.



Hopefully it's an updated version of 0.9.8 from the 0.9.8 version that I tested around the time this thread was created, this issue was not fixed then so yeah it's hopefully an updated version of 0.9.8.

 

By the way, any ETA for the full rollout or any way to manually trigger the update?

rytymu
Gig Goer

Awesome!  Does this include cached files too?  

 

What about for the Android platform (particularly for cached music, and bluetooth playback)?

CWM0120
Newbie

Version: 0.9.7.16.g4b197456 (Windows)

The tracks are not local files.

I do not use crossfade because the playlist I am listening to is a continuous mix (Armin van Buuren's A State of Trance Year Mix 2013).

Does not transition smoothly between majority of the songs in the playlist, an example of this is with these two URIs: Dash Berlin – Steal You Away [Mix Cut] - Original Mix into Hardwell – Apollo [Mix Cut] - Dash Berlin 4AM Mix.

I'm sure that you've heard this many times, but there isn't anything more annoying than trying to listen to music (specifically a continuous mix) and having gaps in between the songs. Please fix this! Spotify is awesome and I don't have anywhere else I'd like to listen to music from, so keep a loyal customer happy!