[Desktop] Gapless Playback and Crossfade Broken

Thread652210651942624336652790

Status: Under Investigation 

Description:

Multiple reports of gapless playback and crossfade not working on Desktop version 0.9.7.16.g4b197456

 

To reproduce:

  1. Start Spotify
  2. Play a playlist with gapless playback enabled (crossfade off). Reports gapless playback does not happen. 
  3. Play a playlist with crossfade enabled. Reports crossfading does not happen.

 

Workaround:

It has been suggested this issue only occurs with gapless playback on and crossfade set to 12 seconds. If this is the case reducing crossfade to below 12 seconds and restarting the client may fix it. 

 

Additional information:

Crossfade (and gapless) may not function correctly on local files, so when testing please use Spotify tracks. 

 

If you are having either of these issues please can you post below:

-- Version of Spotify you're using
-- Whether the tracks are local files
-- If you are having issues with gapless or crossfade, and your settings for both
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

 

Thanks!

 

Updates:

2014-02-27: This bug should be fixed in v0.9.8 which will be rolling out shortly. (Link to Richard's Post)

 

When posting in this forum please make sure you have read these guidelines.

This was fixed in the 0.9.8 Desktop release. 

Comments
Lorenzo_NGG
Roadie

- 0.9.7.16.g4b197456

- No local files (Just streaming Pink Floyd's The Wall)

- Yes

- Pink Floyd – Empty Spaces - 2011 - Remaster and Pink Floyd – Young Lust - 2011 - Remaster

 

PauLarsen
Regular

-- Version of Spotify you're using: I first tried in 0.9.6.81.gd359a796. Now I have 0.9.7.16.g4b197456 and I still have the problem
-- Whether the tracks are local files: The tracks are from a playlist which is NOT synced offline
-- Whether you also have crossfade selected in Preferences: Cross fade is OFF
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks):

    - Pink Floyd – The Thin Ice - 2011 - Remaster

    - Pink Floyd – Another Brick In The Wall, Pt. 1 - 2011 - Remaster

SanyaIV
Music Fan

-- Version of Spotify you're using

Version 0.9.8.150.g59287e0c
-- Whether the tracks are local files

No
-- If you are having issues with gapless or crossfade, and your settings for both

Both,

Gapless playback ticked in

Crossfade tracks ticked in and set at 6 seconds
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

All tracks for me but for the sake of report I just listened to September – La La La (Never Give It Up) - Radio Version and went to Maddie Wilson – Just a Boy and no crossfade or gapless playback.

 

The reported workaround does not work for me.

 

A "workaround" that works for me is disabling and re-enabling Gapless playback & Crossfade tracks maybe 10 times, note that Gapless playback & Crossfade tracks will stop working again after restarting Spotify (it's possible it might stop working after a while without a restart too, haven't really checked that)

 

As you might have noticed I'm using 0.9.8 however something that is worth noting is that I did not recieve this update through Spotify, I got it from another person (files signed by Spotify so I trust it) and I extracted the contents to \%appdata%\Roaming\Spotify\

 

Another thing worth noting is that the reason I did the "forced update" was because of this issue, so I had this same issue in 0.9.7 too, tried a clean re-install but that changed nothing.

 

(I also noticed that I can't change the settings in 0.9.8, they simply don't stick.. I don't know why, but that prohibits me from trying different configurations. I was going to try if "Enable hardware acceleration" affected the crossfade issue but now I can't, anyone that knows which file the "Enable hardware acceleration" option is stored in? Can't find it in perfs file)

 

This issue is extremely annoying for someone like me (read: someone who is easily annoyed by things that don't work and I can't seem to fix myself (read: I want to take a knife and stab my ears everytime a track changes...)) Is it possible to revert to like 0.9.6 or something like that without having Spotify auto-updating? I can't find any options for auto-updating?

 

Edit: Found a download for 0.9.6.81 will try that and report back the results.

Edit 2: Installed Spotify 0.9.6.81 and set up my preferences, deleted the update files that spotify made (also blocked spotify.exe and spotifyhelper.exe from creating those files again through my security suit) and the results are: Gapless playback & Crossfade tracks is working, even after restart, will monitor this thread to see when Spotify fixes this so that I know when I can update again.

cnicolae
Casual Listener

-- Version of Spotify you're using | 0.9.7.16.g4b197456
-- Whether the tracks are local files | no, all are being streamed
-- If you are having issues with gapless or crossfade, and your settings for both | gapless issues
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks) | all ASOT podcasts. Example: Armin van Buuren ASOT Radio – A State Of Trance Episode 570 or Armin van Buuren ASOT Radio – A State Of Trance Episode 569 (Live Broadcast from Privilege, Ibiza)

ghostkey
Regular

Version: was using 9.7.16 gapless not working, tried 9.6.81 gapless still didn't work, now I'm using 9.6.72 which works just fine

Tracks were streamed and playlist(all from Spotify, didn't try local files)

Problems with gapless, never use crossfade.

All tracks had problems

 

As mentioned above, I tried the last two updates, gapless didn't work in either, but 9.6.72 did the trick.  I tried to do the create a read only text file trick but that didn't work, so my choices are: leave spotify on all the time; find a way trick it into not updating, which I'm totally up for doing until this gets fixed;if it doesn't get fixed fairly soon cancel account.

vits
Newbie

I have problem with gapless playback:

- version 0.9.7.16.g4b197456

- premium streaming

- gapless on, crossfade off

- Pink Floyd – Breathe (In The Air) [2011 - Remaster] Pink Floyd – On The Run - 2011 - Remaster

peaceloveandfas
Casual Listener

Hi

 

I'm having the gapless playback issue.

I was asked to post here from another thread.

 

--  (Version 0.9.7.16.g4b197456)   program on Mac (OS10.9.1) 

-- Whether the tracks are not local files

-- Crossfade is not selected in Preferences

-- The Spotify URIs are...   Deft – Loqux & Past  to  Kris Wadsworth – Mainline - Jimmy Edgar Remix   (And all of that album)

 

What is being done to sort this?

 

 

Thanks

 

Deej510
Newbie

Having same issues.

 

-- Version of Spotify you're using

Desktop version 0.9.7.16.g4b197456 and latest version of mobile spotify app, both have issues
-- Whether the tracks are local files

Tracks are in offline mode.
-- If you are having issues with gapless or crossfade, and your settings for both

gapless
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

Armin Van Buuren – A State Of Trance Year Mix 2013 (Mixed by Armin van Buuren)

Booyabobby
Regular

-- Version of Spotify you're using
0,9.7.16.g4b197456

 

-- Whether the tracks are local files
Both local and non local tracks

 

-- If you are having issues with gapless or crossfade, and your settings for both
Having issues with both gapless and crossfades. Crossfade set to 8s

 

-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)
All tracks in my playlists.  But here are two examples.  Kamelot – March Of Mephisto   &  Nightwish – Sahara

Songogram
Newbie

-- Version of Spotify you're using

0.9.7.16.g4b197456
-- Whether the tracks are local files

Local and Streaming tracks
-- If you are having issues with gapless or crossfade, and your settings for both

Just gapless, tried switching on and off about a dozen times.
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

Attack Attack [US] – Hot Grills, and High Tops

 

Attack Attack [US] – Stick Stickly

 

Thought it was initally a problem with the way the tracks were encoded, but it isn't. Am going to try downgrading to older versions as others have done to see if it resolves the problem.

 

Come on guys, this has been a solved problem with media players for 10 years or so.