[Desktop] Gapless Playback and Crossfade Broken

Thread652210651942624336652790

Status: Under Investigation 

Description:

Multiple reports of gapless playback and crossfade not working on Desktop version 0.9.7.16.g4b197456

 

To reproduce:

  1. Start Spotify
  2. Play a playlist with gapless playback enabled (crossfade off). Reports gapless playback does not happen. 
  3. Play a playlist with crossfade enabled. Reports crossfading does not happen.

 

Workaround:

It has been suggested this issue only occurs with gapless playback on and crossfade set to 12 seconds. If this is the case reducing crossfade to below 12 seconds and restarting the client may fix it. 

 

Additional information:

Crossfade (and gapless) may not function correctly on local files, so when testing please use Spotify tracks. 

 

If you are having either of these issues please can you post below:

-- Version of Spotify you're using
-- Whether the tracks are local files
-- If you are having issues with gapless or crossfade, and your settings for both
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

 

Thanks!

 

Updates:

2014-02-27: This bug should be fixed in v0.9.8 which will be rolling out shortly. (Link to Richard's Post)

 

When posting in this forum please make sure you have read these guidelines.

This was fixed in the 0.9.8 Desktop release. 

Related Issues

Comments
Community Legend

@miskidomleka wrote:

@MattSuda wrote:

If you guys were actually paying attention... Richard (Spotify employee) posted this last week:

 


@Richard wrote:

Hey guys, sorry that we've left you hanging for a while here. I'm just popping my head back in to say that we haven't forgotten about this.

 

The fix for this issue should be rolling out soon with the 0.9.8 release (some of you might have been lucky enough to get this already).

 

If you don't have that yet, hang in there! It'll be with you soon.

 

Give us a shout if you have any more questions.


A fix is coming so please be patient.


Your comment about "not paying attention" is borderline insulting. First, it is Spotify's job to provide clear information, it is not our (users') job to search all over the community and/or other sources for any informaton that maybe someone posted somewhere, Second, if the fix was ready last Thursday (Richard: "some of you might have been lucky enough to get this already"), why I still don't have it? What is it with this stupid Spotify policy of gradual rollouts, when some people get fixed versions while other are two versions back?

I apologize for that comment.

 

Richard's post was in this thread, but not clearly visible as someone would have to do a lot of searching to find it.

 

The 0.9.8 update was rolled out to a small percentage of users to test changes and gather feedback before it goes out to everyone.

 

Spotify's reasoning for this is that it's better for a few people to expereince problems first, fix those problems, and then roll it out to everyone so they won't have those same problems.

The beta phase is basically a quality control check to make sure Spotify didn't leave any bugs or problems with the program.

 

I am part of the 0.9.8 beta test and I did not get the fix for gapless playback yet. It was not ready last Thursday.

 

I have no idea when 0.9.8 will be rolled out to everyone, but hopefully soon.

Community Legend

Yes, the unchecking and rechecking gapless playback box works, but you have to do this every time you exit and restart the desktop app.

 

An official update that fixes this should be coming within the next few months.

 

Sorry... it's a little ways away, but a fix is coming. 

 

The fix will be rolling out with the new desktop design.

user-removed
Not applicable

@zxplod wrote:

THIS WORKED FOR ME!!!  [URL removed]

 

Edit by MattSuda:

Sorry, you are not allowed to post download links on the forums. By the way, yes, that installer will get you an earlier buggy version of the new beta, but that version does not have the crossfade fix. The crossfade fix is in the newest beta release that just came out.


I'm actually using the same procedure, I hope the publisher of the installer will update it to the latest 296 build. 

Music Fan

Oh dear, not more...   sadly have 'upgraded' to 0.9.8.296, and among the myriad other things I dislike about this release, I'm finding that the gapless playback now isn't gapless.  This is not something I've ever encountered in the previous releases of Spotify, so am pretty miffed.

I'm streaming online spotify tracks, and between each track there is now a short gap, despite my gapless playback option selected in the preferences.

I'm on Windows Vista Home Edition on one machine, and windows 7 professional on another, and it's happening on both.

 

A week ago I loved Spotify, now I'm on the verge of leaving.  How long until the next release when everything is nice again and back to the way it was ?

 

Roadie
@gurtlover That's pretty weird, for most people the previous version (0.9.7.x) was NOT gapless unles a special trick was used, and 0.9.8.296 fixed the problem. Did you try that trick, which is disabling and enabling gapless?
Newbie

If you are having either of these issues please can you post below:

-- Version of Spotify you're using
-- Whether the tracks are local files
-- If you are having issues with gapless or crossfade, and your settings for both
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

 

i have Problems too. I tested it with different versions. Even the newest has this crossfade problem.

 

The Crossfade works fine when it has to play the Spotifysongs. The Some of the local files are working but most of them not. Its very annoying... spotify is really great but this problem makes me think about uninstalling Spotify and change to another similar programm.

 

I think its happening with gapless and crossfade.

 

– 1t - Royal - Badoxa Pro Feat. G-Amado (Zouk Music)

Ray G – Dalé com Fé

Regular

Yep, but only with local files (I read Spotify doesn't support gapless playback with local files yet). Since Spotify doesn't have all the mixes I like available for streaming, I'm still using local files from a CD or iTunes.

 

The faster this problem is solved, the better in my opinion!

Newbie

@Peter wrote:

Thread652210651942624336652790

Status: Under Investigation 

Description:

Multiple reports of gapless playback and crossfade not working on Desktop version 0.9.7.16.g4b197456

 

To reproduce:

  1. Start Spotify
  2. Play a playlist with gapless playback enabled (crossfade off). Reports gapless playback does not happen. 
  3. Play a playlist with crossfade enabled. Reports crossfading does not happen.

 

Workaround:

It has been suggested this issue only occurs with gapless playback on and crossfade set to 12 seconds. If this is the case reducing crossfade to below 12 seconds and restarting the client may fix it. 

 

Additional information:

Crossfade (and gapless) may not function correctly on local files, so when testing please use Spotify tracks. 

 

If you are having either of these issues please can you post below:

-- Version of Spotify you're using
-- Whether the tracks are local files
-- If you are having issues with gapless or crossfade, and your settings for both
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

 

Thanks!

 

Updates:

2014-02-27: This bug should be fixed in v0.9.8 which will be rolling out shortly. (Link to Richard's Post)

 

When posting in this forum please make sure you have read these guidel

 

Newbie

Same issue for me after update today 2015-05-28. Workaround does not  work. Both local and streamed files. Version 1.0.6.80.g2a.... There is no longer a gapless alternative.