[Desktop] Gapless Playback and Crossfade Broken

Thread652210651942624336652790

Status: Under Investigation 

Description:

Multiple reports of gapless playback and crossfade not working on Desktop version 0.9.7.16.g4b197456

 

To reproduce:

  1. Start Spotify
  2. Play a playlist with gapless playback enabled (crossfade off). Reports gapless playback does not happen. 
  3. Play a playlist with crossfade enabled. Reports crossfading does not happen.

 

Workaround:

It has been suggested this issue only occurs with gapless playback on and crossfade set to 12 seconds. If this is the case reducing crossfade to below 12 seconds and restarting the client may fix it. 

 

Additional information:

Crossfade (and gapless) may not function correctly on local files, so when testing please use Spotify tracks. 

 

If you are having either of these issues please can you post below:

-- Version of Spotify you're using
-- Whether the tracks are local files
-- If you are having issues with gapless or crossfade, and your settings for both
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

 

Thanks!

 

Updates:

2014-02-27: This bug should be fixed in v0.9.8 which will be rolling out shortly. (Link to Richard's Post)

 

When posting in this forum please make sure you have read these guidelines.

This was fixed in the 0.9.8 Desktop release. 

Related Issues

Comments