[Desktop] Gapless Playback and Crossfade Broken

Thread652210651942624336652790

Status: Under Investigation 

Description:

Multiple reports of gapless playback and crossfade not working on Desktop version 0.9.7.16.g4b197456

 

To reproduce:

  1. Start Spotify
  2. Play a playlist with gapless playback enabled (crossfade off). Reports gapless playback does not happen. 
  3. Play a playlist with crossfade enabled. Reports crossfading does not happen.

 

Workaround:

It has been suggested this issue only occurs with gapless playback on and crossfade set to 12 seconds. If this is the case reducing crossfade to below 12 seconds and restarting the client may fix it. 

 

Additional information:

Crossfade (and gapless) may not function correctly on local files, so when testing please use Spotify tracks. 

 

If you are having either of these issues please can you post below:

-- Version of Spotify you're using
-- Whether the tracks are local files
-- If you are having issues with gapless or crossfade, and your settings for both
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

 

Thanks!

 

Updates:

2014-02-27: This bug should be fixed in v0.9.8 which will be rolling out shortly. (Link to Richard's Post)

 

When posting in this forum please make sure you have read these guidelines.

This was fixed in the 0.9.8 Desktop release. 

Comments
avatar230
Regular

-- Version of Spotify you're using

0.9.7.16.g4b197456
-- Whether the tracks are local files

Streaming tracks
-- If you are having issues with gapless or crossfade, and your settings for both

Gapless; but I don't use crossfade at all and haven't tried enabling it
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

Miles Davis – Springsville - Mono Version to Miles Davis – The Maids of Cadiz - Mono Version

 

I've confirmed that those tracks do play gaplessly correctly on the iOS app, so it's not an encode problem. This is isolated to the desktop client.

corne
Casual Listener
chrisamin
Newbie

-- Version of Spotify you're using

0.9.7.16.g4b197456  on OS X


-- Whether the tracks are local files

Streaming tracks


-- If you are having issues with gapless or crossfade, and your settings for both

I have gapless enabled and crossfade disabled. Gapless doesn't work on some tracks but does on others.


-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

 

Gapless doesn't work going from:

Okkervil River – Black Sheep Boy

to

Okkervil River – For Real

but *does* work from

Okkervil River – For Real

to

Okkervil River – In A Radio Song

djbnyc
Regular

I use version 0.9.7.16.g4b187456

It is not a local file in that it is a Spotify file. How else do I know it is local?

Crossfade is not selected.

Gapless is selected.

All then tracs have gaps. For exampleRichard Wagner – Wagner: Die Walküre: Act III v. Zweite Szene: Wo ist Brunnhild'

djbnyc
Regular
djbnyc
Regular

IS SPOTIFY GOING TO CORRECT THIS BUG???

DO THEY KNOW ABOUT IT????

If not, how can we tell them. 

 

This is a deal breaker.

Peter__
Community Legend
Spotify are aware of this bug (hence why its open in the bugs section on the community). 😉
SanyaIV
Music Fan

Would you perhaps know how long it usually takes for Spotify to release a fix for issues like this?

Peter__
Community Legend
It often depends on the root cause of the issue. Unfortunately as to when it will be fixed, I know as much as you guys do.
pittdj
Casual Listener

Mac OS X 10.7.5
Spotify Version: 0.9.7.16.g4b197456

Gothenburg-Aarhus Philharmonic – Symphonic Variations, Op. 92

spotify:track:65Dayj4yOiFA791byA4kqR
spotify:track:1tcjqDrjqS2K49fTVrSDXv
spotify:track:1t9k7USfWD27rdsKY42blt

 

Galess - Tticked

Crossfade - Unticked.

 

The gapless setting has no effect.

 

This seems to be a Mac issue, the same version of Spotify on Windows 7 did play seamlessly.