[Desktop] Gapless Playback and Crossfade Broken

Thread652210651942624336652790

Status: Under Investigation 

Description:

Multiple reports of gapless playback and crossfade not working on Desktop version 0.9.7.16.g4b197456

 

To reproduce:

  1. Start Spotify
  2. Play a playlist with gapless playback enabled (crossfade off). Reports gapless playback does not happen. 
  3. Play a playlist with crossfade enabled. Reports crossfading does not happen.

 

Workaround:

It has been suggested this issue only occurs with gapless playback on and crossfade set to 12 seconds. If this is the case reducing crossfade to below 12 seconds and restarting the client may fix it. 

 

Additional information:

Crossfade (and gapless) may not function correctly on local files, so when testing please use Spotify tracks. 

 

If you are having either of these issues please can you post below:

-- Version of Spotify you're using
-- Whether the tracks are local files
-- If you are having issues with gapless or crossfade, and your settings for both
-- The Spotify URIs of two tracks you've experienced this with (to find the URIs, right-click the tracks)

 

Thanks!

 

Updates:

2014-02-27: This bug should be fixed in v0.9.8 which will be rolling out shortly. (Link to Richard's Post)

 

When posting in this forum please make sure you have read these guidelines.

This was fixed in the 0.9.8 Desktop release. 

Comments
djbnyc
Regular

Too  bad. 

This is information is more useful to those who hopefully are fixing this bug than to me! 

 

Good toknow, though.

Richard
Roadie

Hey guys,

 

Just posting to let you all know that this hasn't been forgotten about. We're still looking into what's going on here.

 

Hopefully we'll have some good news to share soon. Thanks for bearing with us for now, and keep the reports coming in!

 

Thanks.

SanyaIV
Music Fan

@Richard wrote:

Hey guys,

 

Just posting to let you all know that this hasn't been forgotten about. We're still looking into what's going on here.

 

Hopefully we'll have some good news to share soon. Thanks for bearing with us for now, and keep the reports coming in!

 

Thanks.



Updates like these are very much appreciated! Thumbs up! ❤️

llatsni
Casual Listener

Same issue

 

OS X 10.9.1

Spotify 0.9.7.16.g4b197456

z1mme
Newbie

Spotify: 0.9.7.16.g4b197456

OS X: 10.9.1

 

I can only get gapless playback and/or crossfade to work if I re-enable either of the features.

A restart of spotify "disables" the features even if they're still enabled in preferences.

Gonzonp
Music Fan

Same here, version of Spotify: 0.9.7.16.g4b197456; W7 Home Premium 64bits. I have problems with crossfade not working,  so if I set it up it works, but once I restart spotify it doesn't work anymore. Tried to change to 11 seconds, but doesn't help, so hopefully it works soon!

 

Thanks 🙂

middguy
Casual Listener

I can confirm this as well - I created a forum post before finding this thread - sorry for the duplicate!

 

OSX: 10.7.5

Spotify version: 0.9.7.16.g4b197456

 

Like z1mme said, try unchecking and rechecking the "Gapless playback" box when you start up Spotify - that made it work for me!

Gonzonp
Music Fan

What midguy said, it also worked for me, but rechecking the boxes everytime you start spotify it's not something we should need to do in order for it to work. But yes, it could be a temporary solution to the problem.

cnicolae
Casual Listener

If this doesn't get fixed before my next billing in period of March 1st, I will cancel my premium subscription.

 

I can't pay money for a service that's broken and doesn't work 😞

BandBRadio
Casual Listener

Every update seems to screw up something that worked fine before...

Doesn't seem to matter how many seconds it is set for for me.

My work around is just go to settings and click Crossfade off then click it on again.