Help Wizard

Step 1


[Desktop] Local files with special characters or non-English letters in their name not working






Desktop Windows

Operating System

Windows 10


My Question or Issue

The local files scan seems to be broken (again) on the Spotify Windows desktop app (so not the Microsoft store version, the version downloaded from the Spotify website).


I tried to add some new local files a few hours ago and it wouldn't work so I removed the local-files.bnk file because I found countless messages on this forum mentioning this exact problem with this solution. However that did not work and worse, some files went missing in the process after the fresh scan.


So I completely uninstalled Spotify and reinstalled it from the website. Everything worked, however, after waiting for it to finish updating the local files, a new version was download by the client. So I installed it and... the same local files disappeared again. So I guess something is crashing regarding local files indexing in the latest version ( while it was not in the version still delivered from the website (


However that is not the first time I encounter this kind of problem (and it seems that a lot of people encounters them periodically, judging from the messages here) and it's sad to see that something as simple as files indexing (which should be the basics for a music player) gets broken so often on a stable release channel 😕 . Not being able to merge the local files with the online ones is starting to become really annoying...

Hey folks,


Thanks for your patience while we looked into this issue.


We’re happy to say that this should now be fixed for everyone with the latest version of the app! Just make sure your app is updated.


If you're still having trouble, make sure to post a new thread in the relevant help board here.




In case anyone is interested and ends up here, as a quick fix, I disabled the auto update using these steps:


At least now I'm on a version which indexes my local files properly ( but that does not solve the problem on the latest version.

  1. I have the same issue. At first I thought this would affect certain files randomly but I noticed that this only counts for files that have a special character in their title or their artists name. It worked fine for over a year so I don't know why this is happening now.

I think you may be onto something: I didn't check exactly (and won't check now because I got it working with the older version like I said before :p), but I think that the missing titles also had some Japanese characters inside them. I'm not sure it was affected by the artist name but for the track title, I checked about 10-15 titles which disappeared and they had Japanese characters inside them.


I have precisely this issue. Any artist or album title (tracks seem fine) where there is a special character or diacritic is greyed out.


This only started with the latest update from last week.


Prior to that, the same files worked perfectly - in some cases, for 3 or 4 years, but in other cases for a few weeks or months.


All are mp3 format, so there's no difference in file type.


I tried uninstalling, redownloading the installer from the Spotify website, and reinstalling it, and it hasn't fixed it.


This looks significantly like a bug.

I've had nearly the same experience, but in my case the song titles are the issue. If there are any Japanese characters, or even apostrophes in the title, the song will be greyed out. Yet if the title is in english, the song can be played regardless of the characters in the artist/album fields. I've also noticed that a song with a # in the title plays normally, and another song with an @ plays normally too.

All my local files were working normally as recently as a few weeks ago.

How do you get a previous version of the program to install, though?

I'm also having this issue since the last update, and it seems largely related to songs with Spanish, French and Japanese words --although there are some without any of those that are also greyed out.

Funnily enough, if I open the mp3 in Audacity, copy the content into a new file and export it as a new mp3, Spotify recognizes it as a new local file and plays it fine. But then, upon closing and reopening the program, the song is greyed out again.

Seriously, this is getting ridiculous at this point.

Yeah it's annoying to see that Spotify seems to be the only player on the market to struggle that hard to index music files... x)


Anyway, about the old version, I download a fresh installer from the Spotify website and it did not install the latest version. Maybe that changed recently, but when I did it I kept the old version by blocking the updates (I linked the post that explains how to do that in the first reply).


As for the old version, I could try to post the setup I used here but:

1- I don't know if this setup is the plain old version setup or if it is just a binary that downloads whatever latest version is available online (in which case posting this won't change a thing)

2- I don't know if doing that is authorized here and besides, I'm not sure anyone here would trust a random stranger posting a binary executable file on the internet x)


But anyway, if downloading it from the website does not work, and if you would like to try with the installer I kept locally, I guess I can upload it there. Just tell me if you need 🙂


I'm also having this issue.
But if the problem is caused by special characters, would changing file name/artist name manually to English in each file work?








Operating System

Windows 10


My Question or Issue

After the recent update Spotify hasn't been able to recognize my local files that have special characters. For example ō , any Japanese character, ∞, etc. This only applies to the song titles as the artist names do not affect the reading. Only my songs with normal English characters can be read.