[Desktop Mac] Crashing immediately after app opens

After a system reboot my Spotify client stopped working.

> Desktop, Mac

> macOS Sierra 10.12.6

> Spotify: 1.0.91.183.g259b84fa


Issue:

1. Click Spotify icon in Applications directory

2. Spotify flashes an empty black window for ~half a second and immediately crashes with no error message

 

> I tried deleting all the cached and supporting files like I've seen in several other threads.
> Tried reinstalling the application, but the issue still persists.
> The weird thing is when I tried to launch it from the terminal to view the console logs it launced and works just fine! The command I used:

/Applications/Spotify.app/Contents/MacOS/Spotify &

 

Does anyone know how to fix this issue?

 

Hey all,

 

Be sure to keep the app up-to-date. Try a clean reinstallation of the app if you're having issues and let us know if there is anything we can do.

 

Have a nice day!

Comments
Moderator
Moderator
Status changed to: Under investigation

Hey all,

 

Thanks for bearing with us.


Our tech folks are currently looking into this.

 

In the meantime, it'd be helpful if you could you let us know the output you see when trying the following: 

  1. Make sure the desktop client is closed. 
  2. Open Terminal
  3. Paste in /Applications/Spotify.app/Contents/MacOS/Spotify --show-console

We'll make sure to pass this on to the right folks, thanks!

daeatenone
Casual Listener

My terminal output:

 

Last login: Tue Nov 27 09:37:41 on ttys006

/Applications/Spotify.app/Contents/MacOS/Spotify ; exit;

Jonahs-MBP:~ jonahkim$ /Applications/Spotify.app/Contents/MacOS/Spotify ; exit;

2018-11-27 09:38:02.350 Spotify[35693:35956678] SPMediaKeyTap startWatchingMediaKeys

2018-11-27 09:38:02.350 Spotify[35693:35956678] SPMediaKeyTap stopWatchingMediaKeys

 

daeatenone
Casual Listener

Any news on this @Katerina?

Moderator
Moderator

Hey there @daeatenone,

 

Apologies for the confusion!

 

If possible, could you try the following steps instead:

  1. Make sure the Spotify desktop app is closed. 
  2. Open Terminal.
  3. Paste the following: /Applications/Spotify.app/Contents/MacOS/Spotify --show-console
  4. Leave a comment with the output you see.

We'll then make sure to pass it on to our tech folks. Thanks again!

daeatenone
Casual Listener

@Katerina See output here: https://pastebin.com/Jksp1JGX

 

(I couldn't post it via the community because it's 100,000+ characters long)

Jemi
Spotify Legend

Hey @daeatenone

 

We'd like to ask you to try something for us if you don't mind. Can you run the following command: defaults write com.spotify.client SPIgnoreMediaKeys YES

 

Keep in mind that this will temporarily stop your media keys from working. After you've run this, can you check if the Spotify client still crashes?

 

Once you've tested this, and to get your media key functionality to return, please run: defaults delete com.spotify.client SPIgnoreMediaKeys

 

Let us know the results and we'll investigate further. 

 

Thanks!

absmn
Newbie

Hi there,

Similar problem here.

  • Desktop, Mac
  • MacOS 10.14.3 (Mojave)
  • Spotify 1.0.98.78.gb45d2a6b

Output when I try to run Spotify with the --show-console command via Terminal:

 

<systemtime> W [collection_local_bans_file.cpp:51] bans: could not read local bans file: /Users/macusername/Library/Application Support/Spotify/Users/spotifyusername-user/local_bans.pb
libc++abi.dylib: terminating with uncaught exception of type std::length_error: vector

Abort trap: 6

 

Using Finder, I discovered that the file local_bans.pb does not exist in the specified folder.

 

In my case, this problem started after updating to 1.0.98.78.gb45d2a6b. The previous version (1.0.96.181.gf6bc1b6b) works fine.

 

RedDodgerAZ
Regular

[0127/100042.433895:ERROR:gl_implementation.cc(281)] Failed to load /Applications/Spotify.app/Contents/Frameworks/Chromium Embedded Framework.framework/Libraries/libswiftshader_libGLESv2.dylib: dlopen(/Applications/Spotify.app/Contents/Frameworks/Chromium Embedded Framework.framework/Libraries/libswiftshader_libGLESv2.dylib, 1): no suitable image found. Did find:
/Applications/Spotify.app/Contents/Frameworks/Chromium Embedded Framework.framework/Libraries/libswiftshader_libGLESv2.dylib: file system sandbox blocked stat()
[0127/100042.440067:ERROR:viz_main_impl.cc(184)] Exiting GPU process due to errors during initialization
Spotify(55140,0x700009af5000) malloc: *** error for object 0x7ffe56ed1140: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6

Jemi
Spotify Legend

Hey folks, 

 

Thanks for the info so far. There's a newer Spotify version available (1.0.99). Reinstall the app and let us know if the issue persists.

 

@RedDodgerAZ could you let us know your device and OS as well?

 

Thanks!

RedDodgerAZ
Regular

 Used AppCleaner to uninstall the app and I did reinstall (v1.0.98). All is well now.

 

I am using iMac v10.13.6