[Desktop][Nano] 6/7th gen iPod isn't recognized

Thread: 179016

Status: Won't fix


Spotify doesn't rezognize the latest iPods (6th and 7th gen) that use the new Lightning connector



Sync local files to your iPod via iTunes (since you can't sync Spotify content to generic iPods even with premium - full details of this restriction are outlined here).

If you have an iPod Touch, you need to sync via WiFi.


Additional information:

2013-01-14: Updated bug to reflect it also affects 6th gen (which also have Lightning connectors). (Thanks Peter)

2013-03-13: It looks like we may have a fix for this. Now it's just waiting to get it into a future desktop update.

2013-12-26: Updating work around information for clarity.

2014-01-15: We won't be fixing this. But, because you can only sync local tracks, the mentioned workaround to use iTunes works fine.




When posting in this forum please make sure you have read these guidelines.


I have this problem right now, and it's been two years since this post. I really hope this is fixed soon, because I want to be able to sync my iPod with iTunes 😞


I am also wondering, if there will be a fix for this?!

Especially, with Apple announcing its Apple Music service now (which I am pretty sure will support its iPod Nano for its music stream), this bug might be a good reason for a lot of customers to switch to Apple in order to enjoy their music on their iPod.


 So whats the deal? Bought Ipod nano 7th gen for little boy for Christmas and I can't sync because it won't show up in the devices.

I even went Premium to advoid commericals and to get the best downloads.

Any solotions? Sorry if I didn't see any. Help or Kiss Spotify Goodbye !


I tried all cheats. At least I think so.yes, tried as admin. did not work.

Know how to clear out I-tunes but need to connect to spotify first to do that.


Is the any spotify phone number to talk to a tech for help. Contact phone # ?

Community Manager
Community Manager
Status changed to: Not Right Now
Community Manager
Community Manager
Status changed to: Not Right Now

Related Issues