[Desktop] Progress Bar Resets to 0:00 when Switching to Fullscreen

Hi everyone, 

 

We're receiving reports from our users that while playing a song and switching to full screen mode the track's progress bar gets back to 0:00, but the song keeps on playing.

 

This happens on desktop devices with Windows across multiple countries.  

 

If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.

 

We'll be keeping everyone up to speed here, so make sure to Subscribe to this thread. 

 

Cheers!  

Hey folks,

 

Thanks for your patience while we looked into this. Since the original issue reported here has been resolved, we're closing this as fixed. 

 

We've seen a couple mentions that there's no moving point on the progress bar in full screen mode, which has already been reported to the right teams. We suggest you head over to this thread for more info - We'll make sure to check back there as soon as we have any news to share.

 

If you're experiencing a different issue, you can start a new topic in the relevant help board and we'll do our best to help.

 

Cheers!

Comments
Ognjen1
Casual Listener
Hi,
I've been experiencing the same issue, and I hope you find this info at all useful for fixing the problem.
When I switch to full screen mode, the progress bar goes back to the last point on which the song was paused. For example, if I pause a song at 0:30, and let it play for a few seconds, entering full screen mode sets the progress bar back to 0:30.
Pausing the song while in full screen mode actually fixes the issue temporarily, until I switch full screen mode off.
I hope your team finds this at all useful and the issue gets fixed soon!
philipredstone
Newbie

Plan

Premium

Country

Germany

Device

Desktop

Operating System

Windows 10

Version

1.1.55.498.gf9a83c60-a

 

My Issue

On the new player, when switching to fullscreen mode on Windows 10, the timer resets every time to 0, but the song keeps playing.

Video is attached.

hugobacher
Visitor

I got the same issue.
To clarify the bug only happens when you open full screen. When a song has played all the way through and another one starts or if you skip a song, then the player time is synced correctly.

If the track is paused when you open fullscreen mode then the player time shown correctly.

Plan - Premium Family
Country - Sweden
Device - Desktop
Operating System - Windows 10
Version - 1.1.58.820.g2ae50076-a

Misply
Visitor

Hello,

I am experiencing the same problem, but a little bit different. When going into fullscreen mode, the progress bar resets, is not accessible for me to use, is really big and does not disappear when my mouse is not used (i dont know if that would still happen in this new update (Windows 10)). I will link a video to this reply showing my problem

Eni
Moderator
Moderator

Hi folks! 

 

Thanks for reaching out about this here in the Community. 

 

First up, it's well worth running a clean reinstall to get rid of any cached files that might be causing trouble. This one is more thorough than the usual one. Make sure to download the app again from the Microsoft Store

 

If this doesn't do the trick, would you mind checking if this happens on the web player as well?

 

We'll be on the lookout for your reply.

 

 

philipredstone
Newbie
Hey,
a clean reinstall did not solve this issue. The web player does behave the same.

So the bug is not only on the Desktop Version but also on the web version as well.
CarlosE
Moderator
Moderator

Hey @philipredstone,

 

Thanks for keeping in touch.

 

That's odd. We've tried it on our end and couldn't replicate it. If possible, could you try it on a different computer and let us know if this behavior persists?

 

Also, try logging in to a different account, like a friend's or relative's, on your computer to see if the issue persists. This would help us check if this behavior is rather account or device related.

 

Keep us posted. We'll be on the lookout.

philipredstone
Newbie

So, because I dont have acces to another PC right now, I asked a friend of mine, if he could reproduce this bug. And yes, its reproducable on another PC & Account.

 

His Spotify/OS Information:

Plan

Premium

Country

Germany

Device

Desktop

Operating System

Arch Linux x86_64 xorg KDE Plasma

Version

1.1.55.498.gf9a83c60 (Flatpak)

 

Steps to reproduce this bug:

  1. Play any song
  2. Enable fullscreen mode
  3. Skip this song
  4. Leave Fullscreen mode
  5. Let the song play for a few seconds
  6. Enable fullscreen mode again
  7. Timer should start at 0:00 again

He also screen recorded his reproduction oft this bug, the video is attached.

 

CarlosE
Moderator
Moderator

Hey @philipredstone,

 

Thanks for all that info and the videos.

 

Can you try clearing your hosts file by following the steps in this article? We want to check if that makes any difference on your end.

 

We'll keep an eye out for your reply.

philipredstone
Newbie
Hey,
after cleaning my hosts file, the bug sadly still exists.