[Desktop] "Can't Play Current Track" Error on Free

Thread934135 (and many others)

Description:

"Can't play current track" error being displayed on Spotify Free accounts due to HQ streaming not being automatically disabled in v0.9.14.13.

 

To reproduce:

  1. Drop from Spotify Premium to Free with HQ streaming enabled in the desktop client.
  2. In v0.9.14.13 the option will not be unselected automtically which prevents playback as you are no longer using a Premium account. 

Workaround:

Untick "High Quality Streaming" in Edit/Spotify > Preferences > Playback and then fully restart Spotify (Windows: File > Exit | Mac: Spotify > Quit Spotify).

 

Additional information:

N/A

 

When posting in this forum please make sure you have read these guidelines.

Hey everyone! This issue was fixed with the release of the Desktop update 1.0.0. If you're having any other issues please post in the Desktop Help board, thanks!

Status: Fixed
0 Likes

Related Issues

Comments
Peter__
Community Legend
Status changed to: Fixed
 
Stigaard
Newbie

Thank you for this post. Worked like a charm, disableing High Quality Streaming.

fire_bling
Newbie

Thanks for the info, had this issue and found the fix here right away.

nickamaro
Newbie

You got man. Thanks!!!!

al-anselmo
Newbie

Thanks for the insight!

I tried uninstalling Spotify but the problem persisted. After disabling HQ streaming, it's working fine!

 

Enjoy the music.

ASTRODUB
Newbie

Thank you!

 

I also tried uninstalling and re-installing which only worked for one song before the problem returned.

 

Your solution solved the problem and I am back listening seamlessly.

 

Happy Friday everyone!

-a

smen0
Newbie

Thank you.

 

for me hq - Setting must have enabled via an update.  Unticking it totally solved the problem.

 

 

solarjohn
Newbie

this is a seriously annoying bug.

 

I almost quit using spotify. 

 

same thing. used to pay, I stopped paying, (perhaps temporarily) and then it kept saying "can't play the current track" but if i double click the song a couple times it would work. 

 

so annoying

JohannesC
Newbie

Thanks, hope thay fix this bug.

jeremyomeara
Newbie

I thought I was going batty! Turning off High Quality definitely fixes the issue.