Announcements

[Desktop] "Can't Play Current Track" Error on Free

Thread934135 (and many others)

Description:

"Can't play current track" error being displayed on Spotify Free accounts due to HQ streaming not being automatically disabled in v0.9.14.13.

 

To reproduce:

  1. Drop from Spotify Premium to Free with HQ streaming enabled in the desktop client.
  2. In v0.9.14.13 the option will not be unselected automtically which prevents playback as you are no longer using a Premium account. 

Workaround:

Untick "High Quality Streaming" in Edit/Spotify > Preferences > Playback and then fully restart Spotify (Windows: File > Exit | Mac: Spotify > Quit Spotify).

 

Additional information:

N/A

 

When posting in this forum please make sure you have read these guidelines.

Hey everyone! This issue was fixed with the release of the Desktop update 1.0.0. If you're having any other issues please post in the Desktop Help board, thanks!

Status: Fixed
0 Likes
Comments
Newbie

This is a stupid bug, I had a spotify premium account months ago and had HQ switched on and throught it would untick its self like before when I went back to spotify free after having a google play music account for a number of months. 

 

Anyway thanks for the fix I did not think of checking the options because I did not think that it could be that HQ still ticked because usually it unticks its self when you go from premium to free it seems to stupid to change it so you have to remember to do.

 

It is almost like by upgrading the spotify software you are given new features and stuff but also a bug which was not there before and should not be there now.

 

Anyway all is well now thanks for the help. I thought I was losing the plot I knew there was something wrong but I had not idea what it was and the with my web player working I honestly thought I was losing it.

 

 

 

 

Newbie

This has bugged me for over 6months thanks alottttttttttt.

Newbie

Perfect. I've had this problem a long time and have had to resort to the web player.

 

Confirm that turning off the High Quality Streaming solves the issue.

Regular

what about the people who has never used premium? I get this problem too and I can't uncheck the box because I never had it checked

Casual Listener

Thanks, worked just fine.

Newbie

Nice one bruuuvvvaaaaa!

Casual Listener

The same thing happened to me, if you have your local files synchronized with spotify and the hard drive where you have it is being disconnected, then a conflict between files you have and files spotify is created, because spotify gives preference to those local files and not find them, simply removes local routes or create them again

It work for me, note tha the error is only on the tracks that you have on your computer

Casual Listener

i cant even click on "high quality streaming" and never had premium. yet tracks that previously had no issues playing, will not play anymore.

Roadie

Wow Thank you ! 
Had this problem a few months, Time to get some premium again hehe 

Newbie

I can not check "High Quality Streaming" and it is not checked. I still get the error "Can't play the current track". I see this bug has been around for a while, why has it not been addressed?

Related Issues